LINUX.ORG.RU

Arch x86_64, amarok 2.4.3 - вылеты плеера


0

1

Началось с сегодняшнего утра, обновлений никаких не устанавливал. Амарок запускается, проходит секунды ~3-4 и процесс убивается.

$ amarok
KGlobal::locale::Warning your global KLocale is being recreated with a valid main component instead of a fake component, this usually means you tried to call i18n related functions before your main component was created. You should not do that since it most likely will not work 
 QUrl( "http://ws.audioscrobbler.com/2.0/?api_key=&lang=ru&method=user.getNeighbours&user=" )  
 QUrl( "http://ws.audioscrobbler.com/2.0/?api_key=&lang=ru&method=user.getFriends&user=" )  
 QUrl( "http://ws.audioscrobbler.com/2.0/?api_key=&lang=ru&method=user.getTopTags&user=" )  
 QUrl( "http://ws.audioscrobbler.com/2.0/?api_key=&lang=ru&method=user.getTopArtists&user=" )  
amarok(21061)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
amarok(21061)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
amarok(21061)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
QWidget::insertAction: Attempt to insert null action
amarok(21061)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
********************************************************************************************** 
** AMAROK WAS STARTED IN NORMAL MODE. IF YOU WANT TO SEE DEBUGGING INFORMATION, PLEASE USE: ** 
** amarok --debug                                                                           ** 
********************************************************************************************** 
[f1xman@SH_ne_G amarok-2.4.3]$ Expected node absent: neighbours 
Expected node absent: topartists 
Expected node absent: friends 
QMetaObject::invokeMethod: No such method App::onWsError(lastfm::ws::Error)
lastfm::ws::Error 
QSocketNotifier: Invalid socket 33 and type 'Read', disabling...
KCrash: Application 'amarok' crashing...
KCrash: Attempting to start /usr/lib/kde4/libexec/drkonqi from kdeinit
sock_file=/home/f1xman/.kde4/socket-SH_ne_G/kdeinit4__0
amarok: Fatal IO error: client killed
Unable to start Dr. Konqi
Amarok пересобирал, каталог с конфигом удалял, что с ним произошло - ума не приложу. Прошу помощи.

★★★★★

Ответ на: комментарий от Milky_Way

Не думаю, переустановка этой либы не помогла. Думаю, что-то с модулем ласта в амароке. Вычислить бы все места, где его конфиги лежат.

$ find -name "amarok"
./.kde4/share/apps/amarok
./.kde4/share/apps/amarok/mysqle/amarok
Подозреваю, что есть еще места.

f1xmAn ★★★★★ ()
Ответ на: комментарий от pekmop1024

Да, в этот раз очень толсто получилось :)

f1xmAn ★★★★★ ()
Ответ на: комментарий от darkshvein

> Да, действительно, твоя толстота не совпадает с числом твоего скора

Какой из этого вывод можно сделать? Что я тонко троллю. :) Так что все совпадает. Впрочем, конспирологи тут же скажут, что это кровавая гебня на моей стороне!

pekmop1024 ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.