LINUX.ORG.RU

[openSUSE 11.4] Compiz 0.9.5 + KDE 4.6.4


0

1

Доброго времени суток. Возникла проблема при установке компиза, он в принципе не хочет адекватно работать. Час усилий принёс свои плоды, более или менее корректный запуск обеспечился собственноручной установкой в автозагрузку fusion-icon (через Параметры системы - запуск и завершение, по другому не умею). Всё бы не плохо, но: http://rghost.ru/10443721/image.png 1. Некоторые значки трея отображаются в левом верхнем углу. 2-3. Запуск приложений некорректно «врезается» в окно. 4. Обычный трей двигается постоянно влево/вправо от своего должного состояния. Ну и по мелочи - при завершении работы экран делится главной диагональю на чёрный экран и рабочий стол (внизу чёрный, вверху рабочий(а может и наоборот)). Остальное в целом работает. В подобном новичок, гугл мягко говоря не помог. Напрягает сие высказываение: ( http://en.opensuse.org/Compiz_Fusion ) For the KDE Desktop Environment The .ymp for KDE users is in the Compiz repositories, but KDE 4.6 reportedly breaks Compiz. There is no good solution. You can try the 11.3 instructions, and you might be lucky enough to get it to start, but it will crash immediately.

Установка 11.3 не помогла... Помогите, если есть решение.


Единственный вариант - это выкинуть компиз и вколючить композитинг в кедах. Компиз вообще с новыми кедами очень плохо работает.

spoilt ★★★ ()
Ответ на: комментарий от spoilt

Помню ещё в 11.3 на 256 nVidia'вских дровах 0.86 что ли запустил без проблем, 0.9 на 260 уже не встал ещё тогда, но + руки _слишком_ кривые были. Чтож, печально. Будем ждать хороших вестей. Спасибо.

nivs ()

Как-то ставил openSUSE 11.4 с гномом, компиз там и правда мерзкий.

neocrust ★★★★★ ()
Ответ на: комментарий от daemonpnz

А где его найти со всеми зависимостями? В моих репозиториях нет, http://software.opensuse.org/ выдаёт 503 ошибку, ручками пробежался по репам - тоже не нашёл... Везде 0.9.*

http://pkgs.org/opensuse-11.3/opensuse-oss-i586/compiz-0.8.6-3.4.i586.rpm.html вот нашёл в сети, но там по пакетам всё отдельно, стоит ли доверять? Вручную придётся ставить каждый из зависимостей... Может в какой-нибудь репе всё это сейчас есть?

neocrust, из коробки у меня гном не запустился (изначально выбрал KDE), только содержимого рабочего стола было, даже панели не было. Через терминал, через yast доустановил как-то, но получилось что-то несуразное и снёс к чертям. Да и вообще, по скринам глянул гном, как-то кеды помилее выглядят... Потом хочу Ubuntu поставить, на Unity глянуть.

nivs ()
Ответ на: комментарий от nivs

А где его найти со всеми зависимостями? В моих репозиториях нет, http://software.opensuse.org/ выдаёт 503 ошибку, ручками пробежался по репам - тоже не нашёл... Везде 0.9.*

http://pkgs.org/opensuse-11.3/opensuse-oss-i586/compiz-0.8.6-3.4.i586.rpm.html вот нашёл в сети, но там по пакетам всё отдельно, стоит ли доверять? Вручную придётся ставить каждый из зависимостей... Может в какой-нибудь репе всё это сейчас есть?

Я в сюсе не очень разбираюсь, потому не знаю как можно продаунгрейдить compiz, может быть есть пакеты на OBS

daemonpnz ★★★★★ ()
Ответ на: комментарий от daemonpnz

Удалить прошлое, почитить конфиги, поставить нужное. Вот только чтобы поставить что-то нужное, сначала надо найти что-то нужное. И опять же незадача

Error 503 build.opensuse.org Sun Jun 12 13:51:12 2011 Apache/2.2.10 (Linux/SUSE)

Вот... Не мой день

nivs ()
Ответ на: комментарий от daemonpnz

да никуда он не перехал, просто пару часов как не доступен

Novell-ch ★★★★★ ()
Ответ на: комментарий от tn1

> далее - квин - говно - даже не обсуждается

«квин-говно» - это синоним слова «мегабакс»

registrant ★★★★★ ()
Ответ на: комментарий от tn1

далее - квин - говно - даже не обсуждается

На интегрированной нвидии 7x со всеми эффектами, после настройки тормозов замечено не было, так что проблема в кривизне рук видимо.

Одно время пробовал компиз, пришел к выводу что эта глючная хрень нафиг не нужна.

sl4mmer ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.