LINUX.ORG.RU

[Gentoo]KDM ne vidit DBUS.

 


0

1

Reshil vernutsea na KDE pole gnome, postavil KDE po rukovodstvu s gentoo.org, reboot.. kdm ne reagiruet na vvod bukv, mishi ne dvigaetsea... Reboot v System Recovery CD, /var/log/kdm.log:

Primary device is not PCI
klauncher(2292) kdemain: No DBUS session-bus found. Check if you have started the DBUS server. 
kdeinit4: Communication error with launcher. Exiting!
kdmgreet(2286)/kdecore (K*TimeZone*): KSystemTimeZones: ktimezoned initialize() D-Bus call failed:  "Not connected to D-Bus server"
pri etom dbus startuiet pri zapuske sistemi i rabotaiet. Kak sie ispraviti? Zaranee spasibo i izvinite za translit: s System Recovery CD siju.

★★

setxkbmap -option grp:ctrl_shift_toggle,grp_led:scroll us,ru

Если Вы про SystemRescueCD, то там при загрузке можно было выбрать keymap «ru», и все остальные настройки (включая setxkbmap) были бы применены автоматически.

AITap ★★★★★
()
Ответ на: комментарий от AITap

Спасибо. А по сабжу есть что- то?

Dorif ★★
() автор топика
Ответ на: комментарий от fads

Выполнилось ещё при установке иксов.

Dorif ★★
() автор топика
Ответ на: комментарий от vurdalak

Все правильно, работоспособность мыши и клавиатуры не зависит от D-Bus.

aspotashev ★★★
()
Ответ на: комментарий от anonymous

То есть файл лога есть, но он пустой? Короче, найдите последний лог X-сервера. Там наверняка написано, из-за чего не работает мышь и клавиатура.

Иногда это происходит из-за того, что xf86-input-evdev не был обновлен после обновления xorg-server. Но Вы вроде говорите, что устанавливали xf86-input-evdev. Может быть стоит ещё раз его переустановить? (отдельно xf86-input-evdev)

На всякий случай спрошу, клавиатура работает через evdev? (должна быть строчка 'Driver «evdev»' в разделе описания клавиатуры в /etc/X11/xorg.conf)

P.S.: вместо того, чтобы загружаться с LiveCD, в такой же ситуации я для загрузки системы без иксов делаю так: при загрузке жму «i» (у меня openrc), после чего разрешаю запуск всех служб кроме иксов.

aspotashev ★★★
()
Ответ на: комментарий от aspotashev

Uje j davno mofuliniie konfiguracii. Tak chto nikakogo xorg.conf. I pohoje vinovat deistvitelno udev. I ia voobshe esheo ne configuriroval xorg. No na x86 mashine u menea vseo rabotalo i bez konfigurirovaniia. Net ustroistva /dev/mouse Iksi toje na vvod bukv i dvijeniie mishi ne reagiruiut. Kak ispraviti etu trablu s udev?

anonymous
()

Пишу из генты под кедами. Проблема была самой тупой- udev не был прописан на автозапуск, хотя в x86 он стоит в автозапуске. Запустил udev, всё заработало.

Dorif ★★
() автор топика
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.