LINUX.ORG.RU

>Вопрос 1: Можно ли поменять gtk диалог, на kdeшный?

kgtk_wrapper, но он вроде подтухать начинает

Вопрос 2: Амарок 2.4.1 при запуске даёт такое: http://www.linux.org.ru/forum/desktop/6257648. kbuildsycoca4 --noincremental не помогает.


попробуй его конфиги переместить

madgnu ★★★★★ ()
Ответ на: комментарий от lognur
$ yaourt kgtk
1 aur/kde3-kgtk 0.10.1-1 (3)
    LD_PRELOAD hack with helper scripts to make gtk and qt-only programs use KDE file dialogs.
2 aur/kgtk 0.10.1-5 (229)
    LD_PRELOAD hack with helper scripts to make gtk and qt-only programs use KDE file dialogs.

второй, емнип, для 4-х

madgnu ★★★★★ ()
Ответ на: комментарий от lognur

> В смысле? Все равно он убогий в firefox.
У меня все диалоги KDE-шные - и в KDE-шных прогах и в GTK-шных.

Делал вот так (у меня Gentoo, комманда emerge - установка пакета):

$ emerge qtcurve-qt4
$ emerge gtk-engines-qtcurve
$ emerge kcm_gtk
После чего в настройках (System settings) появится пункт GTK Styles and Fonts. Запустить его и выбрать:
System settings > GTK Styles and Fonts
Use another style: [QtCurve]

KDE 4.6.1. Работает 100% .

Чтобы найти способ читал вот это:
http://ky6uk.org/kcm-gtk-all-apps-in-one-style
http://www.oper777.co.cc/2010/01/gtk-kde_2138.html
http://linuxopen.ru/2008/12/02/gtk-qt-theme-engine-feat-qtcurve.html
http://www.itfo.ru/
http://www.gentoo.ru/node/16823

Kroz ★★★★★ ()

1: Есть kgtk-wrapper, но поделие глючное...

erfea ★★★★★ ()
Ответ на: комментарий от lognur

Где-то тут был срач на эту тему, поищи. Там было предложение сусевский патч для ФФ. Ещё один плюс в пользу суси)

MrHouse ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.