LINUX.ORG.RU

tvinview gnome dpi


0

1

Есть два монитора. 15'-1900x1200 юзаемый по умолчанию и подключаемый 17'-1024x768.

По умолчанию, для 1900x1200,
В xorg у меня стоит

DisplaySize 328 221
Option «DPI» «147 x 147»

В gnome тоже выставил 147 dpi.

И все бы ничего, но когда подключаю 17' через tvinview, она тоже начинает давать 147 dpi.
Я так понимаю гном видит то что ему отдала tvinview как один большой экран, и применяет к этому стандартные настройки.

В результате подключаемая 17'- ка вообще не юзабельна, шрифты на пол экрана.

Пропишите в xorg.conf секции для обоих мониторов, используя опцию (при этом удалите параметры DisplaySize и Option «DPI»):

    Option         "DPI" "96 x 96"
Не ручаюсь за конечный результат, но, думаю, должно помочь.

carasin ★★★★★ ()
Ответ на: комментарий от carasin

Результат конечно будет. Но не такой как хотелось бы.

Мне надо отдельно выставить dpi для каждого монитора.

Если я проставлю 96 dpi, тогда проблема у меня переедет на другой монитор. Так как 15'-ка 1900x1200 вроде не должна иметь 96 dpi.

paranormal ★★ ()
Ответ на: комментарий от paranormal

Ну... 96 - это, конечно, просто у меня так прописано (скопипастил из своего xorg.conf'а).
Просто я подумал, что если эту опцию задействовать в разных секциях (для разных мониторов) с разными параметрами?

carasin ★★★★★ ()
Ответ на: комментарий от carasin

Я использую tvinview
там вроде достаточно одного монитора... Другой будет подхвачен автоматом.

Section «ServerLayout»
Identifier «Layout0»
Screen 0 «Screen0» 0 0
Option «Xinerama» «false»
EndSection

Section «Files»
EndSection

Section «Module»
#Load «GLcore»
Load «dbe»
#Load «dri»
Load «dri2»
Load «extmod»
Load «glx»
Load «record»
Load «xtrap»
Load «freetype»
Load «type1»
Load «xtt»
Load «synaptics»
EndSection

Section «Monitor»
Identifier «Monitor0»
VendorName «LG»
ModelName «LG-Samsung»
#HorizSync 30.0 - 81.0
#VertRefresh 56.0 - 75.0
Option «DPI» «146 x 147»
DisplaySize 328 221
Option «DPMS»
Option «AddARGBGLXVisuals» «True»
EndSection

Section «Device»
Identifier «Device0»
Driver «nvidia»
VendorName «NVIDIA Corporation»
BoardName «Quadro NVS 140M»
Option «NvAgp» «2» # AGPGART
Option «NoLogo» «1»
Option «CursorShadow» «1»
EndSection

Section «Screen»

#Depth 24
#EndSubSection
# Removed Option «metamodes» «nvidia-auto-select +0+0»
Identifier «Screen0»
Device «Device0»
Monitor «Monitor0»
DefaultDepth 24
#Option «TwinView» «1»
#Option «TwinViewOrientation» «RightOf»
#Option «MetaModes» «1024x768, 1920x1200»
#Option     «UseDisplayDevice» «CRT, DFP»
#Option «SecondMonitorHorizSync» «24.0 - 80.0»
#Option «SecondMonitorVertRefresh» «49.0 - 75.0»
SubSection «Display»
Depth 24
Modes «1920x1200»
EndSubSection
EndSection

Section «Extensions»
Option «Composite» «Enable»
EndSection

paranormal ★★ ()
Ответ на: комментарий от paranormal

Ах да... Запамятовал, что в своей структуре xorg.conf для одной секции screen требует также один идентифаер monitor...
Теперь даже и не знаю, чем помочь...

carasin ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.