LINUX.ORG.RU

Локаль


0

1

Вдруг отвалилась локаль в Xubuntu. После обычного включения компа установился английский язык в приложениях, в терминале вместо русских букв пишет вопросы, а, например, apt вот такую фигню выдает:

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = "ru_RU:en",
	LC_ALL = (unset),
	LANG = "ru_RU"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Gtk-WARNING **: Locale not supported by C library.
...
И что делать?

Ответ на: комментарий от Eddy_Em

> Прописать в i18n нужную локаль.

Как это сделать?

Или в .bashrc что-нибудь вроде export LC_ALL=нужная_локаль


Это же костыль, я так понимаю. Да и не только в терминале же проблема.

Shlyapa ★★ ()

в /etc/locale.gen раскомментируй те локали что тебе нужны, например: en_US.UTF-8 UTF-8 ru_RU.UTF-8 UTF-8

потом в терминале locale-gen

ну и можно ребутнуться

Gr1N ()
Ответ на: комментарий от aho

Выдает вот это:

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = "ru_RU:ru:en_GB:en",
	LC_ALL = (unset),
	LANG = "ru_RU"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Generating locales...
  en_AG.UTF-8... up-to-date
  en_AU.UTF-8... up-to-date
  en_BW.UTF-8... up-to-date
  en_CA.UTF-8... up-to-date
  en_DK.UTF-8... up-to-date
  en_GB.UTF-8... up-to-date
  en_HK.UTF-8... up-to-date
  en_IE.UTF-8... up-to-date
  en_IN.UTF-8... up-to-date
  en_NG.UTF-8... up-to-date
  en_NZ.UTF-8... up-to-date
  en_PH.UTF-8... up-to-date
  en_SG.UTF-8... up-to-date
  en_US.UTF-8... up-to-date
  en_ZA.UTF-8... up-to-date
  en_ZW.UTF-8... up-to-date
  ru_RU.UTF-8... up-to-date
  ru_UA.UTF-8... up-to-date
Generation complete.
И ничего не меняется.

Shlyapa ★★ ()
Ответ на: комментарий от Gr1N

У меня этого файла не было. Создал, вписал эти значения, запустил locale-gen. Всё равно не помогло.

Shlyapa ★★ ()

sudo dpkg-reconfigure -plow locales

/etc/default/locale
/etc/environment

LANG=«ru_RU.UTF-8»

Deleted ()

Удалил файл /usr/lib/locale/locale-archive
, потом снова перегенерировал, вроде всё нормально стало, тьфу-тьфу.

Всем спасибо за помощь.

Shlyapa ★★ ()
Ответ на: комментарий от lognur

Давно хочу что-то попробовать подобное, но всё лень :) Да и сносить уютную зубунточку, которой уже года два, жалко как-то.

Shlyapa ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.