LINUX.ORG.RU

[любой дистриб][nvidia] видео рвётся


0

0

Конфигурация -

01:00.0 VGA compatible controller: nVidia Corporation G92 [GeForce 8800 GT] (rev a2). Подключен монитор ViewSonic VX1962wm DVI-кабелем и телевизор PHILIPS какой-то HDReady кабелем DVI->HDMI. Включены через TwinView, хотя пробовал и xinerama, и separate X screen.

проприетарный драйвер. Дистриб пробовал Gentoo и Ubuntu.

Проблема такая. При воспроизведении видео на динамических сценах поперёк самой динамической сцены появляется горизонтальная полоска, выглядти так, будто над полоской уже новый кадр, а под полоской ещё старый - создаётся ощущение, что видео «рвётся». Заскриншотить не получается, потому что скрин снимается программно и там проблемы нет. Но смотреть видео меня напрягает.

Запускал под wine программу Nokia TFT test - там есть такой тест, когда летает цветной квадратик по всему экрану - у меня на этом тесте цветная каша на два монитора вместо квадратика. В винде этот тест показывал нормальный квадратик.

Видео воспроизвожу mplayer'ом. Проводил эксперименты с драйвером vo, пробовал vdpau, x11, xv, gl, gl2, из них на мониторе видео не рвётся только с -vo gl, на телевизоре рвётся всегда. Зато если отключить телевизор, то проблемы вроде не наблюдается. Но мне нужно наоборот, именно на телевизор выводить.

Помогите советом, как решить проблему.

Могу только сказать, что это называется Tearing.

Когда я пользовался проприетарными драйверами nvidia, то встречался с этим всего один раз - когда только-только к ним прикрутили VDPAU. Потом это дело пофиксили и кадры «рваться» перестали. Вроде такое ещё происходит при включенном Compiz'е и прочих подобных штуках.

Deleted ()
Ответ на: комментарий от Deleted

Сейчас попробовал в настроках КДЕ нажать на кнопку «приостановить графические эффекты» - и не помогло :'(

Помогает только отключение телевизора (достаточно в настройках nvidia-settings поставить флажок disabled). То есть для конфигурации с одним монитором пофиксили, а с двумя мониторами - придётся терпеть?

name_no ★★ ()

Скорее всего разница в частоте развёртки между основным монитором и телеком.

Нвидия умеет нормально показывать видео без теаринга только на основном мониторе.

Если на телике есть прибамбасы типа 100 (200) Hz mega motion plus и подобные - попробуй отключить, мне помогло снизить теаринг.

Unnamed_Hero ★★★ ()

У меня похожая ситуация (2 монитора - ЖК и ЭЛТ, разные частоты и всё такое).

Для меня был самый простой путь - запуск nvidia-settings, а затем в XServer Xvideo Settings выставить Sync to this display device [нужный монитор]. После этого на указанном мониторе видео перестаёт рваться.

P.S.: X настроены в режиме TwinView, если что.

LORanymous ()

у меня на телике наблюдается этот эффект только при выводе через vdpau (почти в самом верху кадра). Особо смотреть не мешает, но если смотрю не fullHD, то переключаюсь на вывод через xv.

azure ★★ ()

драйвер проапгрейдь. у меня такое на внешнем мониторе раньше было. после апгрейда драйверов все ОК.

isden ★★★★★ ()
Ответ на: комментарий от Unnamed_Hero

195.30, когда как, smplayer через него, другие плееры нет.

isden ★★★★★ ()
Ответ на: комментарий от Sekai

ION LE 195.36 никакие способы не помогают, полосы все равно есть.

roman77 ★★★★★ ()

195.36, 2 монитора, аналогичная ситуация
Спасает лишь nouveau.
Пробовал все возможные варианты, не хочет :( в винде такого не замечается, на форуме ихнем толком ответа не дали. Оно почему-то выставляет 50 Гц для того большого монитора в TwinView и всё :(
На днях Линус 2.6.33 ядро объявит, буду уже точно с nouveau и Randr сидеть

C_H_A_D_o ()

Кстати, если кому надо, минимум Tearing получил при:
- указал каждому устройству максимальную частоту
- в nvidia-settings у XVideo и OpenGL включено VSync
- nvidia-settings в XVideo, Sync to display указано для монитора на котором видео смотрю
- в KDE для графических эффектов указал OpenGL и отключил вертикальную синхронизацию
- видео вывожу через xv (для vdpau оно вновь сильно проявляется)

C_H_A_D_o ()

Только что решал аналогичную проблему. В nvidia-settings везде ставишь включаешь sync to vblank. А дальше нужно выполнить nvidia-settings -l до старта компиза. И... Вуа-ля. :)

KVaS ()
Ответ на: комментарий от KVaS

Полосы все равно есть (особо заметно при большом кол-ве вертикальных объектов в фильме, чем их больше, тем полос больше). Это не при vdpau

roman77 ★★★★★ ()
Ответ на: комментарий от roman77

И компиз вообще не причем, без него тоже полосы. И в играх (нативных) полосы.

roman77 ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.