LINUX.ORG.RU

[не понимаю] В Linux нет общего буфера обмена?


0

0

Способ номер раз.

1. С помощью gedit я открываю файл text.txt.
2. Выделяю кусок текста.
3. Копирую текст.
4. С помощью OpenOffice.org открываю файл text.odt.
5. Вставляю скопированный тескт из файла text.txt в text.odt.
6. ЗАКРЫВАЮ ФАЙЛ text.txt и работаю дальше с text.odt.

Способ номер два.

1. С помощью gedit я открываю файл text.txt.
2. Выделяю кусок текста.
3. Копирую текст.
4. ЗАКРЫВАЮ ФАЙЛ text.txt
5. С помощью OpenOffice.org открываю файл text.odt.
6. Вставляю скопированный тескт из файла text.txt в text.odt.
6. Работаю дальше с text.odt.

Почему способ номер два не работает? После закрытия программы (из которой я копировал текст) вставить этот текст уже никуда не получается — на Ctrl+V программы не реагируют, а кнопка «Вставить» просто становится неактивной! И Debian с XFCE, и в Ubuntu с GNOME, и Kubuntu с KDE. В роли gedit может быть и kate / mousepad / etc, в роли OpenOffice.org — AbiWord / Notes / любой другой текстовый редактор.

Буфер обмена сбрасывается после того, как я закрываю программу, с которой он (буфер) взаимодействует? Это как-то лечится?

Ответ на: комментарий от nnz

В klipper'е KDE4 тоже есть галка «Сохранять содержимое буфера обмена при выходе».

anonymous ()
1. С помощью gedit я открываю файл text.txt. 
2. Выделяю кусок текста. 
3. Копирую текст. 
[b]4. Закрываю файл text.txt[/b] 
5. С помощью OpenOffice.org открываю файл text.odt. 
6. Вставляю скопированный тескт из файла text.txt в text.odt. 
6. Работаю дальше с text.odt.

Всё работает. Ты уверен Ctrl+C нажимал в латинской раскладке?

Кстати в Linux необязательно нажимать Ctrl+C/Ctrl+V, достаточно просто выделить текст и затем щелкнуть колесиком мышки (или левой и правой кнопкой мыши одновременно) на то место куда его нужно вставить.

ei-grad ★★★★★ ()
Ответ на: комментарий от nnz

2nnz:

Спасибо, а то в KDE я всегда выключал её из автозагрузки не нужную :-)

2anonymous:

Благодарю.

vkapas ()

Как уже сказали, используйте менеджеры буфера обмена (e.g. klipper), а не держится в памяти текст по соображениям системной безопасности.

anonymous ()
Ответ на: комментарий от ei-grad

>Ты уверен Ctrl+C нажимал в латинской раскладке?

Да.

Только что проверил: в латинской раскладке из mousepad вставил строку в Notes. Без закрытия копируется, после закрытия mousepad'а не копируется. Debian Squeeze, XFCE 4.6.
Про колёсико знаю, но всё равно спасибо.

А есть ли что-нибудь вроде klipper, но для XFCE?

vkapas ()

Более того, даже в после закрытия/открытия одного и того же редактора содержимое Ctrl-С-буфера также не сохраняется. Жутко бесило.

Если же копировать/вставлять колесиком то вроде работает. KDE.

Вообще по-кретински и до сих пор неочевидно, всё правилом научного тыка через одно место.

mclaudt ()

Причем тут linux и X-server?

anonymous ()
Ответ на: комментарий от mclaudt

0_o Arch, GNOME 2.28, KDE 4.3.4, xorg-server 1.7.3.

Не могу воспроизвести.

1. Открываю kate/gedit/soffice 2. Набираю строку, выделяю ее, жму Ctrl+C (Ctrl+Insert) 3. Закрываю редактор. 4. Открываю другой редактор. 5. Ctrl+V (Shift+Insert), всё работает.

ei-grad ★★★★★ ()
Ответ на: комментарий от ei-grad

Гм. Воспроизвел. Иногда, причем похоже только если не производить в редакторе никаких действий (только выделить и скопировать), то текст действительно в буффер не записывается. Если какие-нибудь действия произвести (ну добавить/удалить где-нибудь пробел), то копируется всегда с первого раза.

В любом случае повторное нажатие Ctrl+C исправляет проблему. Странный глюк.

ei-grad ★★★★★ ()
Ответ на: комментарий от anonymous

> а не держится в памяти текст по соображениям системной безопасности.

кеш этих апплетов, по вашему, безопасней памяти?

допустим, тот же keepassx, умеет чистить буфер через n секунд, так вот с клипманами это ломается, пароли ложатся в плейнтекст

areafix ()

>Почему способ номер два не работает?
У меня работает

anotheranonymous ()
Ответ на: комментарий от areafix

>кеш этих апплетов, по вашему, безопасней памяти?

если ты про системный кеш, который ядро держит, то безопаснее, ибо динамические объекты он не хранит, это кеш только для файлов.

nu11 ★★★★★ ()
Ответ на: комментарий от nu11

У меня Ctrl-C всегда нормально, а вот если мышкой выделять, то работает только если ничего не открывать и не закрывать. (убунта)

ratatosk ()

Это глюк gedit'а. У меня, например, при выделении мышкой строки, если снять выделение (например, щелкнув в другом месте текста), буфер обмена опустошается. Т.е. для того, чтобы скопировать блок текста надо следить, чтобы выделение не сбилось...

Eddy_Em ☆☆☆☆☆ ()
Ответ на: комментарий от annoynimous

Re: [не понимаю] В Linux нет общего буфера обмена?

Цитируем annoynimous

parcellite

+100

athost ★★★★★ ()
Ответ на: комментарий от ei-grad

> Кстати в Linux необязательно нажимать Ctrl+C/Ctrl+V, достаточно просто выделить текст и затем щелкнуть колесиком мышки (или левой и правой кнопкой мыши одновременно) на то место куда его нужно вставить.
А ещё это два разных и независимых буфера :)

Nao ★★★★★ ()
Ответ на: комментарий от vkapas

> А есть ли что-нибудь вроде klipper, но для XFCE?

Clipman --- Clipboard Manager for Xfce

ip1981 ☆☆ ()
Ответ на: комментарий от Nao

>А ещё это два разных и независимых буфера :)

а еще если вставлять в емулятор терминала (возможно не любой, но у меня с guake именно так) то shift+ins или среднее колесико будут вставлять одно и тоже - то что выделено. Но зато после этого содержимой обоих буферов станет одинаковым, тем которое выделено :)

короче все очень неочевидно и работает неоднозначно. потому что велосипедов много хороших и разных, а вот что они между собой не спорили надо в этом зоопарке разбираться....

griz ()

Хорошая тема! Тоже мучился от этих фокусов с буфером. Но уже как-то привык не закрывать документ до вставки)) Ух ты, вспомнил - дополнительные клавиши на мышке на OpenSUSE 11.0 у меня так и не получилось забиндить на копипаст - надо будет сейчас попробовать на 11.2...

Sauron_AZM ()
Ответ на: комментарий от ei-grad

В gnome-settings-daemon есть плагин clipboard, который как раз и сохраняет содержимое буфера обмена после выхода из программы. Но работает он почему-то только для gtk+-приложений.

Deleted ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.