LINUX.ORG.RU

mplayer+ass+utf8=*&#%^


0

0

Имеем mplayer и сабы к видео в ass, кодировка utf8, но mplayer понимает либо то что это utf либо что это ass.

тоесть запуская mplayer -ass -uft8 video.mkv мы имеем кашу, но кашу красивую, как надо в асс.

запуская mplayer -ass -subcp utf8 video.mkv имеем читаемые субтитры, но с забитыми правилами асс, т.е. субтитры на пол экрана в его центре.

Никто не сталкивался с этим? что делать чтобы сабы отображались нормально? оО

for i in *ass; do iconv -c -f utf-8 -t cp1251 «$i» > «/tmp/$i»; mv «/tmp/$i» .; done

не помогло так как субрититры утратили свою ass`овость. тесть отображаются оаять таки на пол экрана.

desruptor ()
Ответ на: комментарий от ptah_alexs

У меня с таким конфигом ass нормально работает:

$ cat config # Write your default config options here! framedrop=1 af=volnorm utf8=yes vsync = 1 subcp=enca:ru:cp1251:utf8 stop-xscreensaver = 1

ptah_alexs ★★★★★ ()
Ответ на: комментарий от ptah_alexs

Блин:

~/.mplayer$ cat config

# Write your default config options here!

framedrop=1

af=volnorm

utf8=yes

vsync = 1

subcp=enca:ru:cp1251:utf8

stop-xscreensaver = 1

ptah_alexs ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.