LINUX.ORG.RU

русификация Slackware 9


0

0

В Slackware 9 такая трабла: переключение раскладок настроил с .Xmodmap (без нее вообще не переключало даже), все вроде переключает, но вот с локалью трабла, export LC_ALL=ru_RU.KOI8-R не помогает, русские символы отображаются крякообразами, а в гноме так вообще, все пункты меню из каких-то квадратиков... Что-то я слышал, что там несколько иначе локаль настраивается, чем в предыдущих версиях...

Подскажите, как лечить это дело? Или линк на доку :-)

Заранее благодарен...

anonymous

Re: русификация Slackware 9

Сделал как написано на http://multilinux.sakh.com Всё замечательно работает:-)

anonymous
()

Re: русификация Slackware 9

хрен знает как иначе!! у меня вообще на диске не было пакета glocale.tgz!!! взял из 8.1... появились локали и все работает!

anonymous
()

Re: русификация Slackware 9

все работало сразу с LANG=ru_RU.KOI8-R

anonymous
()

Re: русификация Slackware 9

спасибо, в кде русский пахать стал, но вот с xchat и gnome траблы, какие-то квадратики вместо русских букв... Имхо, шрифты где-то нада прописать правильные... но вот где? .gtkrc с 8-ой версии не сильно помог (вроде тока на gimp подействовал)...

Как это дело лечить?

anonymous
()

Re: русификация Slackware 9

1. Делаем
sudo localedef -f KOI8-R -i ru_RU -c ru_RU.KOI8-R

2. В файлах /etc/profile.d/lang.sh и /etc/profile.d/lang.sh
меняем en_US.ISO8859-1 на KOI8-R

3. Делаем
sudo vi /etc/rc.d/rc.font
в котороый помещаем строки
setfont -v -m koi8-r /usr/share/kbd/consolefonts/Cyr_a8x16.psfu
for n in 1 2 3 4 5 6; do echo -ne "\033(K" > /dev/tty$n; done
loadkeys ru

4. Делаем наглую морду и подло пиздим из виндов трутайп шрифты.
Попижженое кладём в папочку /usr/share/fonts/stolen

5. Файл /etc/X11/XF86Config:
В секции Section "Files" добавляем
FontPath "/usr/share/fonts/stolen/"
В секции "InputDevice", там где Identifier "Keyboard0", добавляем/редактируем
Option "XkbLayout" "us,ru"
Option "XkbOptions" "grp:ctrl_shift_toggle"

6. делаем
sudo fc-cache

7. непонимаем, зачем нужен .Xmodmap

voila

anonymous
()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.