LINUX.ORG.RU

Скринсейвер вырубает гамму.


0

0

Чудо чудное. На компе жены вдруг после запуска скринсейвера (любого) и выхода из него стала сноситься чуть ли не в ноль гамма. Всё ч0рное-ч0рное, только самые яркие участки слегка проглядывают. Лечится убийством-растартом иксов. До следующего запуска скринсейвера.

Куда копать?

★★★★★

Re: Скринсейвер вырубает гамму.

> Куда копать?

что обновлял за последние сутки? наверное в генте опять что нибудь сломали

JB ★★★★★ ()
Ответ на: Re: Скринсейвер вырубает гамму. от JB

Re: Скринсейвер вырубает гамму.

>что обновлял за последние сутки? наверное в генте опять что нибудь сломали

Гы. ВСЁ :D У меня VLC и mplayer не находили некоторые кодеки (при том что Totem находил всё, как ни странно) и я не долго думая (благо, жена на выходные в Питере) запустил на её машине emerge -e world :D

KRoN73 ★★★★★ ()
Ответ на: Re: Скринсейвер вырубает гамму. от KRoN73

Re: Скринсейвер вырубает гамму.

офигенный способ решать проблемы =) Попробуй пересобрать систему еще раз, вдруг поможет

JB ★★★★★ ()
Ответ на: Re: Скринсейвер вырубает гамму. от JB

Re: Скринсейвер вырубает гамму.

>офигенный способ решать проблемы =)

Да давно уже пора было, года полтора не пересобиралось :)

Кроме того, на счёт кодеков так и непонятно было, что к чему. Ошибок никаких, просто не находили кодеки vlc с mplayer и всё. При чём про vlc - вообще сколько раз говорилось, что у него, вроде как, кодеки все в себе... Фиг там. Естественно, их пересборка делу не помогала :)

>Попробуй пересобрать систему еще раз, вдруг поможет

Да нет, ИМХО, в настройках что-то.

KRoN73 ★★★★★ ()

Re: Скринсейвер вырубает гамму.

Забавно. 2 "пятизвездочных" линуксоида обсуждают проблему и находят выход "пересобрать мир" =)

iriyoox ()

Re: Скринсейвер вырубает гамму.

Ию мать! Понял! Я ж у жены XGL/Beryl отрубил. Остался голый Xorg. Вот с ним и есть такой глюк. Вернул XGL - всё ок.

Придётся в эту сторону ковырять.

KRoN73 ★★★★★ ()
Ответ на: Re: Скринсейвер вырубает гамму. от KRoN73

Re: Скринсейвер вырубает гамму.

> Для Beryl'а.

darkstar ~ # cat /var/log/Xorg.0.log | grep -i dri
        X.Org Video Driver: 1.2
        X.Org XInput driver : 0.7
        ABI class: X.Org Video Driver, version 1.2
        ABI class: X.Org Video Driver, version 1.2
(II) LoadModule: "dri"
(II) Loading /usr/lib/xorg/modules/extensions//libdri.so
(II) Module dri: vendor="X.Org Foundation"
(II) Loading extension XFree86-DRI
(II) Loading /usr/lib/xorg/modules/drivers//radeon_drv.so
        Module class: X.Org Video Driver
        ABI class: X.Org Video Driver, version 1.2
(II) Loading /usr/lib/xorg/modules/drivers//ati_drv.so
        Module class: X.Org Video Driver
        ABI class: X.Org Video Driver, version 1.2
        Module class: X.Org XInput Driver
        ABI class: X.Org XInput driver, version 0.7
        Module class: X.Org XInput Driver
        ABI class: X.Org XInput driver, version 0.7
(II) ATI: ATI driver (version 6.6.3) for chipsets: ati, ativga
(II) R128: Driver for ATI Rage 128 chipsets:
(II) RADEON: Driver for ATI Radeon chipsets: ATI Radeon QD (AGP),
(II) Reloading /usr/lib/xorg/modules/drivers//radeon_drv.so
        ABI class: X.Org Video Driver, version 1.2
        ABI class: X.Org Video Driver, version 1.2
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: node name is /dev/dri/card0
(II) RADEON(0): [dri] Found DRI library version 1.3.0 and kernel module version 1.27.0
        ABI class: X.Org Video Driver, version 1.2
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: node name is /dev/dri/card0
(II) RADEON(0): [drm] created "radeon" driver at busid "pci:0000:01:00.0"
(II) RADEON(0): [dri] Visual configs initialized
(**) RADEON(0): DRI New memory map param
(**) RADEON(0): DRI PCIGART param
(**) RADEON(0): DRI Finishing init !
(II) RADEON(0): [DRI] installation complete
        ABI class: X.Org Video Driver, version 1.2
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: node name is /dev/dri/card0
(II) AIGLX: Loaded and initialized /usr/lib64/dri/r300_dri.so
(II) GLX: Initialized DRI GL provider for screen 0

darkstar ~ # cat /var/log/Xorg.0.log | grep Composite
(**) Extension "Composite" is enabled

darkstar etc # cat /var/log/Xorg.0.log | grep AIGLX
(**) Option "AIGLX" "true"
(**) AIGLX enabled
(II) AIGLX: Loaded and initialized /usr/lib64/dri/r300_dri.so

darkstar ~ # genlop -e mesa
 * media-libs/mesa

     Fri Mar 23 17:26:10 2007 >>> media-libs/mesa-6.5.2-r1
     Sat Aug  4 16:54:17 2007 >>> media-libs/mesa-6.5.3
     Thu Aug 16 22:51:34 2007 >>> media-libs/mesa-7.0.1
     Sat Aug 25 12:20:28 2007 >>> media-libs/mesa-7.0.1
     Tue Aug 28 18:54:15 2007 >>> media-libs/mesa-7.0.1
     Thu Aug 30 02:08:14 2007 >>> media-libs/mesa-7.0.1
     Sun Sep  2 17:40:05 2007 >>> media-libs/mesa-7.0.1


А берил замечательно работает через AIGLX без всяких костылей.

Gharik ()
Ответ на: Re: Скринсейвер вырубает гамму. от Gharik

Re: Скринсейвер вырубает гамму.

> ATI driver (version 6.6.3)

OS-драйвера поставлю как только googleearth под ними тормозить перестанет. И X800 заработает.

KRoN73 ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.