LINUX.ORG.RU

Re: А нужно ли мне утф-8?

Всем нужно
Но тебе всё-таки придётся решать самому...

Fedor ★★★ ()

Re: А нужно ли мне утф-8?

>А нужно ли мне утф-8?

Да, лучше сейчас, чем потом. А переходить всё равно когда-нибудь потребуется :)

manntes ★★ ()
Ответ на: Re: А нужно ли мне утф-8? от manntes

Re: А нужно ли мне утф-8?

флаг unicode поди не поставил с самого начала... ссзб.

Deleted ()

Re: А нужно ли мне утф-8?

Я вот тоже думаю -- нужно ли мне сходить отлить или еще потерпеть?

Relan ★★★★★ ()
Ответ на: Re: А нужно ли мне утф-8? от Fedor

Re: А нужно ли мне утф-8?

> Всем нужно

Нужно тем, кто использует одновременно три и более языков с различными (очень различными) кодировками. Остальным это кривой винегрет с переменным числом байт на символ никуда не уперся.

anonymous ()

Re: А нужно ли мне утф-8?

нужно. потому как снимает кучу проблем в будущем.

DemonZLa ()
Ответ на: Re: А нужно ли мне утф-8? от DemonZLa

Re: А нужно ли мне утф-8?

> потому как снимает кучу проблем в будущем.

... и добавит ещё больше уже в настоящем.

anonymous ()
Ответ на: Re: А нужно ли мне утф-8? от anonymous

Re: А нужно ли мне утф-8?

из man wc: -c The number of _bytes_

используй тогда -m, для количества characters....

cursed ()
Ответ на: Re: А нужно ли мне утф-8? от anonymous

Re: А нужно ли мне утф-8?

а где такие проблемы существуют (дистрибутив)?
этот пример, к сожалению тоже работает

> echo "Привет" | cut -c 2-5
риве

PS: FreeBSD

cursed ()

Re: А нужно ли мне утф-8?

$ echo "Привет" | cut -c 2-5
риве

- Mandriva 2007.0

Сейчас без utf-8 проблем больше, чем с ней.
Реально, единственные проблемы, с которыми столкнулся:
- падает Window Maker на русских po (Возможно, проблема не в них - с koi8 тоже не работал - стёр нах)
- нет поддержки в некоторых любимых классических терминалках (wterm/aterm/Eterm) - я Eterm не использую, остальное urxvt решает.

Shadow ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.