LINUX.ORG.RU

kdelibs 3.5.5-r5 и >=Qt 3.3 < 4.0


0

0

Здравствуйте! Вот уже месяц не могу обновить на ноуте кеды :-( Все было чудесно до тех пор, пока при сборке kdemultimedia (а после некоторых попыток что-то изменить - и kdelibs) мне не выдалось следующее:

[code] checking for Qt... configure: error: Qt (>= Qt 3.3 and < 4.0) (library qt-mt) not found. Please check your installation! For more details about this problem, look at the end of config.log. Make sure that you have compiled Qt with thread support!

!!! Please attach the following file when filing a report to bugs.gentoo.org: !!! /var/tmp/portage/kdemultimedia-3.5.5/work/kdemultimedia-3.5.5/config.log

!!! ERROR: kde-base/kdemultimedia-3.5.5 failed. Call stack: ebuild.sh, line 1546: Called dyn_compile ebuild.sh, line 937: Called src_compile kdemultimedia-3.5.5.ebuild, line 88: Called kde_src_compile kde.eclass, line 172: Called kde_src_compile 'all' kde.eclass, line 342: Called kde_src_compile 'myconf' 'configure' 'make' kde.eclass, line 324: Called econf '--with-cdparanoia' '--with-taglib' '--with-akode' '--with-alsa' '--without-audiofile' '--with-gstreamer' '--with-xine' '--without-theora' '--without-musicbrainz' '--with-lame' '--with-vorbis' '--without-flac' '--without-akode' '--with-x' '--enable-mitshm' '--without-xinerama' '--with-qt-dir=/usr/qt/3' '--enable-mt' '--with-qt-libraries=/usr/qt/3/lib' '--disable-dependency-tracking' '--disable-debug' '--without-debug' '--disable-final' '--with-arts' '--prefix=/usr/kde/3.5' '--mandir=/usr/kde/3.5/share/man' '--infodir=/usr/kde/3.5/share/info' '--datadir=/usr/kde/3.5/share' '--sysconfdir=/usr/kde/3.5/etc' ebuild.sh, line 540: Called die

!!! econf failed !!! If you need support, post the topmost build error, and the call stack if relevant. [/code]

Самое интересное, что Qt у меня стоит, причем двух разных версий (qt-4.2.1 правда не вписывется в рамки требования ">= Qt 3.3 and < 4.0", но 3.3.6 есть, и собрана с ключом -thread)... В exports есть QTPATH, указывающий на /usr/qt/3, где, сопсно, и установлен Qt. Дистр - Gentoo. Что делать? Буду признателен за помощь!

anonymous

Re: kdelibs 3.5.5-r5 и >=Qt 3.3 < 4.0

в /var/tmp/portage/kdemultimedia-3.5.5/work/kdemultimedia-3.5.5/config.log что на тему ошибки есть?

Rikz ★★★ ()
Ответ на: Re: kdelibs 3.5.5-r5 и >=Qt 3.3 < 4.0 от iron

Re: kdelibs 3.5.5-r5 и >=Qt 3.3 < 4.0

О, неплохая идея обновить все :) Вот начал обновлять, и отхватил другую ошибку - pango не ставится из-за того, что в libXft отсутствует референс на FT_GlyphSlot_Embolden :( В И-нете нашел описание этой ошибки - говорят, что надо поставить старую библиотеку libXft - поставил, ноль на массу... Версия панго, которую оно хочет обновлять - 1.14.9, версия либХфт - 2.1.10 (последняя на данный момент- 2.1.12) Подскажите, что делать? Оставить старый панго?

anonymous ()
Ответ на: Re: kdelibs 3.5.5-r5 и >=Qt 3.3 < 4.0 от anonymous

Re: kdelibs 3.5.5-r5 и >=Qt 3.3 < 4.0

Ну, из configure.log видно, что тест на Qt лажает с сообщением /usr/lib/libXft.so.2: undefined reference to `FT_GlyphSlot_Embolden', попробуй revdep-rebuild пустить, может в либах какие проблемы.

Rikz ★★★ ()
Ответ на: Re: kdelibs 3.5.5-r5 и >=Qt 3.3 < 4.0 от iron

Re: kdelibs 3.5.5-r5 и >=Qt 3.3 < 4.0

Спасибо за советы (пригодится в будущем), но в данном случае не помогло... Может это из-за того, что по неопытности недавно переключился на новый GCC (4.1.1) а система и много библиотек собирались старым (3.4.4)? Может проще все переустановить, или есть еще варианты? Спасибо за помощь!

anonymous ()
Ответ на: Re: kdelibs 3.5.5-r5 и >=Qt 3.3 < 4.0 от anonymous

Re: kdelibs 3.5.5-r5 и >=Qt 3.3 < 4.0

# gcc-config -l - окажет зеленой звездочкой какой у тебя сейчас используется.

У меня так:
# gcc-config -l
[1] x86_64-pc-linux-gnu-3.4.6
[2] x86_64-pc-linux-gnu-3.4.6-hardened
[3] x86_64-pc-linux-gnu-3.4.6-hardenednopie
[4] x86_64-pc-linux-gnu-3.4.6-hardenednopiessp
[5] x86_64-pc-linux-gnu-3.4.6-hardenednossp
[6] x86_64-pc-linux-gnu-4.1.1 *

Для того чтоб переключить на другую версию gcc, нужно выполнить:
# gcc-config <помер>

После изменения версии, нужно выполнить:
# source /etc/profile

iron ★★★★★ ()
Ответ на: Re: kdelibs 3.5.5-r5 и >=Qt 3.3 < 4.0 от iron

Re: kdelibs 3.5.5-r5 и >=Qt 3.3 < 4.0

Ну все это я знаю, иначе не спрашивал бы (не первый день с Пингвином :))

Я имел в виду - какой именно версией GCC компилятора предпочтительнее пользоваться? На что опираться при выборе?

anonymous ()
Ответ на: Re: kdelibs 3.5.5-r5 и >=Qt 3.3 < 4.0 от anonymous

Re: kdelibs 3.5.5-r5 и >=Qt 3.3 < 4.0

Я лично не задумываюсь над подобными вопросами. Раз объявили что gcc-4.1.1 является стабильным, то поставил его, и им компилю. Всетаки, если он стабильный, то разработчики считают что не должно быть проблем. Так что советую его и юзать.

iron ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.