LINUX.ORG.RU

Автомонтирование разделов в i3 с помощью devmon+udevil

 , , ,


0

1

Установил udevil, потом devmon, запустил последнее, и…

device: [/dev/sr0]
    systeminternal: [0]
    usage:          []
    type:           []
    label:          []
    ismounted:      [0]
    nopolicy:       [0]
    hasmedia:       [0]
    opticaldisc:    [1]
    numaudiotracks: [0]
    blank:          [0]
    media:          []
    partition:      [0]

Все нормально, теперь подключаю флешку…

===========================================
Monitoring activity from the disks daemon. Press Ctrl+C to cancel.
===========================================
added:     /org/freedesktop/UDisks/devices/sdb
===========================================
added:     /org/freedesktop/UDisks/devices/sdb1
device: [/dev/sdb1]
    systeminternal: [0]
    usage:          [filesystem]
    type:           [exfat]
    label:          []
    ismounted:      [0]
    nopolicy:       [0]
    hasmedia:       [1]
    opticaldisc:    []
    numaudiotracks: []
    blank:          []
    media:          []
    partition:      [1]
devmon: /usr/bin/udevil --mount /dev/sdb1 --mount-options "noexec,nosuid,nodev,noatime"    
FUSE exfat 1.3.0
WARN: volume was not unmounted cleanly.
fuse: mountpoint is not empty
fuse: if you are sure this is safe, use the 'nonempty' mount option
devmon: error mounting /dev/sdb1 (1)
===========================================
changed:     /org/freedesktop/UDisks/devices/sdb1
device: [/dev/sdb1]
    systeminternal: [0]
    usage:          [filesystem]
    type:           [exfat]
    label:          []
    ismounted:      [0]
    nopolicy:       [0]
    hasmedia:       [1]
    opticaldisc:    []
    numaudiotracks: []
    blank:          []
    media:          []
    partition:      [1]

Вот сказали использовать nonempty операцию, но вот проблема…

$ cat /etc/udevil/udevil.conf | grep nonempty
default_options_sshfs     = nosuid, noexec, nodev, noatime, uid=$UID, gid=$GID, nonempty, allow_other
default_options_curlftpfs = nosuid, noexec, nodev, noatime, uid=$UID, gid=$GID, nonempty, allow_other
allowed_options_sshfs     = nosuid, noexec, nodev, noatime, ro, rw, uid=$UID, gid=$GID, nonempty, allow_other, idmap=user, BatchMode=yes, port=*
allowed_options_curlftpfs = nosuid, noexec, nodev, noatime, ro, rw, uid=$UID, gid=$GID, nonempty, allow_other, user=*
default_options_exfat = nosuid, noexec, nodev, noatime, umask=0077, uid=$UID, gid=$GID, iocharset=utf8, namecase=0, nonempty
allowed_options_exfat = nosuid, noexec, nodev, noatime, fmask=0133, dmask=0022, uid=$UID, gid=$GID, umask=0077, namecase=*, ro, rw, sync, flush, iocharset=*, remount, nonempty

Но если в этом же конфиге, по этому же пути есть ошибка, то он не работает, => он читает его. В чем проблема, Лор?

используй udiskie лучше

anonymous ()

Проблема в том, что devmon запускает udevil с принудительно заданными опциями:

devmon: /usr/bin/udevil --mount /dev/sdb1 --mount-options "noexec,nosuid,nodev,noatime"
Здесь опции - умолчание заданное в самом скрипте. Можно ли это обойти, я не знаю, смотри текст.
А вообще в какой среде тебе это нужно (консоль, DE...)?

ABW ★★★★★ ()

fuse: mountpoint is not empty

Черт с ним с его конфигом. Поудаляй мусор из каталога лучше ))

vasily_pupkin ★★★★★ ()
Ответ на: комментарий от madreyk

Ага, я увлекся самим сообщением и позабыл про заголовок. Тогда можешь попробовать вот это, там udevil работает с собственными настройками. Только бери не релиз, а поcледнее состояние. Скриншоты можешь глянуть здесь.

ABW ★★★★★ ()
Но впрочем, это ерунда,
и было всё не так...
    А. Галич, "Легенда о табаке"

См. отсюда и далее по ссылкам. Насколько я понял, тебе надо либо откатить fuse-exfat на 1.28, либо ставить свежий срез, потому что исправили, но релиза ещё не было. Кстати, а нужен ли он? Вроде же в ядре есть поддержка?

ABW ★★★★★ ()
Для того чтобы оставить комментарий войдите или зарегистрируйтесь.