LINUX.ORG.RU

Как убрать мерцание(flickering) на ноуте?

 , ,


0

2

Как проявляется: мерцание экрана при бездействии:

  • На рабочем столе двигать мышкой - мерцания нет. Мышку остановить - через полторы секунды мерцание, подвигать снова - мерцания нет.
  • Открыть терминал, пока мигает курсор ввода - мерцания нет. Если мигающий курсор закрыть другим статичным окном - мерцание есть.
  • Если в браузере медлено прокручивать страницу - мерцания нет. После остановки страницы - мерцание.
  • Если окно постинга на лор активное и курсор мигает - мерцания нет. Если убрать фокус из окна, курсор пропадает - будет мерцание.
  • Если из ноута выдернуть\воткнуть питание - на 2 секунды мерцания не будет.

Виновники:

00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 09)
04:00.0 3D controller: NVIDIA Corporation GK107M [GeForce GT 750M] (rev a1)

Попробовал три ядра на трех разных ОС:

  • rhel 4.18

  • ubuntu 5.4

  • manjaro 5.9

Гуглил i915 flickering - много ошибок на разных ОС и ядрах. Запускался со следющими параметрами:

intel_idle.max_cstate=4 
i915.edp_vswing=2 
i915.enable_psr=0

Не помогло.

Поставил проприетарные дрова на nvidia в убунте одной кнопкой, в прайме выбрал nvidia - не помогло. Пробовал wayland - не помогло. На винде и фряхе проблемы такой нет.

И чего делать?

На винде и фряхе проблемы такой нет.

Не мучаться и использовать ее.

Я тут с picom мучаюсь - тиринга нет, зато есть моргание черным в разных местах экрана (

gutaper ★★★★ ()
Последнее исправление: gutaper (всего исправлений: 1)

Попробуй

i915.enable_guc=2

i915.enable_dc=4 или другие значения

У меня на свежей manjaro такого нет, гружусь с

cat /etc/modprobe.d/i915.conf 
options i915 enable_guc=2 i915_enable_fbc=1 enable_dc=4
Flotsky ()

На некоторых интеловых интеграшках лечится Ctrl + Alt + F2 , Alt + F1. А возникает мусор после того, как подведёшь аппаратный курсор к левому краю экрана. В общем случае таблетки нет.

anonymous ()

По описанию — точь в точь PSR. Но почему тогда i915.enable_psr=0 не работает?..

Вы точно правильно загружались с этим параметром? Можете описать свою последовательность действий?

Rootlexx ★★★ ()
Ответ на: комментарий от Rootlexx

Чекал параметр до изменений, грепал 915 через систулз или как там. Смотрел что пср равен не нулю.

Далее редактировал граб, добавил в конце 915 пср равен 0, после квает сплэш или как там в конец строки.

После переобновлял граб и ребутался. Смотрел после ребута что 915 пср равен 0 через систулз. То же самое делал со всеми другими параметрами что указал выше, то есть чекал до и после изменений.

Потом я устал страдать и накатил сервер 2019.

chenbr0 ()

Попробовал три ядра на трех разных ОС

Они все слишком новые. Нужно <4.16 с параметром i915.enable_rc6=0. Т.е. запретить понижать напряжение на GPU. Ну или поновее железо купите.

bread ()
Ответ на: комментарий от Pups

Звучит больше как какая то динамическая и при этом косячная частота обновления экрана. Не представляю как может лечиться.

kirill_rrr ★★★★★ ()
Для того чтобы оставить комментарий войдите или зарегистрируйтесь.