LINUX.ORG.RU

Не могу настроить Pulseaudio на Archlinux

 , , , ,


0

1

Здравствуйте. $SUBJ.

Мне нужен звук. К алсе я апплет напанельку и хоткеи не нашел, да и пульсой пользуюсь с незапямятных времен. Правда, никогда ее не конфигурировал руками. Апплет нашелся, хоткеи чуть ниже.

Пытался сделать по вики. Дошел до копирования из /etc/pulse в ~/.config/pulse. Поставил микшер pavucontrol. Дальше я не понял, что нужно сделать.

Пробовал вручную, при запуске говорит что пульса уже запущена, а pavucontrol её в упор не видит. Что делать? Спасибо.

ps. Пока что пользуюсь алсой. Думаю, как прикрутить увеличение и уменьшение громкости на дефолтные Fn-Right и Fn-Left соответственно. Мой костыль. Проверялся только на Archlinux Xfce, наверняка в других DE можно сделать что-либо подобное. И да, работает только в иксах и возможно только в крысе, но в ядерной консоли мне не до музыки и DE я менять не собираюсь, так что мне пока нормально.

  1. Открываются Настройки -> Клавиатура, вкладка Комбинации клавиш.
  2. Создается новая комбинация, команда amixer -c 0 set Master 10%+ >> /dev/null (проценты можно изменять), после ввода нажимается Ret и клавиша для увеличения громкости по умолчанию на вашей клавиатуре. У меня это Fn-Right.
  3. Аналогичное проделывается и с уменьшением громкости, только команда amixer -c 0 set Master 10%- >> /dev/null.
  4. Работает, меня устраивает. Профит!

Зачем «конфигурировать руками» в 2020?

Сносишь пульсу. Сносишь /etc/pulse и ~/.config/pulse. Ставишь пульсу. systemctl --user enable --now pulseaudio.socket pulseaudio.service. Всё.

Пытался сделать по вики

Русскую арчвики можешь выкинуть сразу. Там и английская местами уже устарела, а на русскую даже смотреть без слёз нельзя.

intelfx ★★★★★ ()
Последнее исправление: intelfx (всего исправлений: 1)
Ответ на: комментарий от intelfx

Тогда говорил что сервис и сокет не найдены. Сейчас к какому-то автобусу подключится хочет…

~/tor-browser_ru$ sudo systemctl --user enable --now pulseaudio.socket pulseaudio.service
Failed to connect to bus: Нет такого файла или каталога
~/tor-browser_ru$ 
zagatov_lev ()
Ответ на: комментарий от zagatov_lev

Сейчас к какому-то автобусу подключится хочет

Это начинает напоминать троллинг тупизной. Оставлю тебя с этой проблемой наедине.

intelfx ★★★★★ ()
Ответ на: комментарий от zagatov_lev

Bus — это шина. Имеется в виду D-Bus — та шина, по которой systemctl общается с инстансом systemd. Поскольку мы говорим о systemd --user, то шина здесь имеется в виду сессионная. В норме сессионный экземпляр шины D-Bus создаётся при первом входе пользователя в систему и не исчезает до последнего выхода, а путь до сокета шины записывается в переменную окружения.

TL;DR: если у тебя на этом месте возникают ошибки, значит, в твоей системе что-то серьёзно пошло не так.

intelfx ★★★★★ ()
Ответ на: комментарий от Korchevatel

Так не знает про пульсу никто, ни systemctl, ни pavucontrol, если бы знали, то я бы не делал дальше и не спрашивал бы.

zagatov_lev ()
Последнее исправление: zagatov_lev (всего исправлений: 1)
Ответ на: комментарий от intelfx
~$ sudo systemctl enable --now pulseaudio.socket pulseaudio.service
Failed to enable unit: Unit file pulseaudio.socket does not exist.
~$ yay -Qs pulseaudio
local/libcanberra-pulse 0.30+2+gc0620e4-3
    PulseAudio plugin for libcanberra
local/pavucontrol 1:4.0-2
    PulseAudio Volume Control
local/pulseaudio 13.0-3
    A featureful, general-purpose sound server
local/pulseaudio-alsa 1:1.2.2-2
    ALSA Configuration for PulseAudio
local/pulseaudio-bluetooth 13.0-3
    Bluetooth support for PulseAudio
local/pulseaudio-equalizer 13.0-3
    Equalizer for PulseAudio
local/pulseaudio-jack 13.0-3
    Jack support for PulseAudio
local/pulseaudio-qt 1.2-2
    Qt bindings for libpulse
local/xfce4-pulseaudio-plugin 0.4.3-1 (xfce4-goodies)
    Pulseaudio plugin for Xfce4 panel
~$ ~$ yay -Qs pavucontrol
local/pavucontrol 1:4.0-2
    PulseAudio Volume Control
~$ 
zagatov_lev ()
Ответ на: комментарий от BOSS-NIGGER

Это начинает напоминать троллинг тупизной.

персонаж уже был замечен в подобном, в треде про емакс вчера

В подобном он был замечен с первых тем. А жаль. Мог бы кормиться тонкой едой, набрав очки.

Vault_Boy ()

И по теме: я не помню, пожтому установи alsa-utils. запусти alsamixer, на основном канале нажми M чтобы убрать Muted. Делая данные процедуры стоит! установить силу громкости колонок на макс. Выбрать что-то в youtube, желательно крики диких жЫвотных.

Vault_Boy ()
Ответ на: комментарий от zagatov_lev

Да удачи. Честно, безразлично. Не работает, ну и Бог с ним. Учись по губам читать. Смотри фильмы с англ сабами. Без разницы.

P.S. Вот в Ubuntu да, была закорюка. Dbus поделён на dbus и dbus-x11. Пока не воткнешь…

Vault_Boy ()
Последнее исправление: Vault_Boy (всего исправлений: 1)
Ответ на: комментарий от zagatov_lev

[mode for child]А чего ты на арч-то полез? Сидел бы на дебиане, ковырял бы хмонад с dwm?[/mode for child]

[mode for adult]Неужели в крыске апплет звука правда не видит альсу? Может просто панель сменишь на какую-нибудь tint2 или что там сейчас у ньюфагов модно (lemonbar?)? А то как-то странно - у тебя апплет не работает, а ты полез пульсу ковырять.[/mode for adult]

[note]Тут недавно решил повозиться с гентой, настроил альсу. Поставил firefox-bin, так мне пульса сама вкорячилась. И все работает. Так что таким макаром - путь тебе на генту.[/note]

gill_beits ★★★★ ()
Ответ на: комментарий от gill_beits
  1. Dwm у меня не было. Да и дебиан я юзал только потому, что 32бит версия хоть как-то, но вставала. Арч я просто устанавливал по-хипсторски, через Anarchy. Сейчас нормально установил. А дебиан глючит.
  2. Да, он даже называется xfce4-pulseaudio-plugin или что-то похожее.
  3. Не умею я генту ставить.
zagatov_lev ()
Ответ на: комментарий от zagatov_lev

Dwm, помнится, я тебе рекомендовал как более легкий вариант вместо xmonad. Есть еще прикольная шутка qtile, тоже на поразмять мозги.

Да, он даже называется xfce4-pulseaudio-plugin

Может, тебе это https://aur.archlinux.org/packages/xfce4-alsa-plugin/ нужно вместо него?

Не умею я генту ставить.

Если поставил арч «нормально», то и генту осилишь, там принципиальных отличий нет. Только ядро сразу ковырять не суйся, делай genkernel all, а дальше все то же самое, только веселья больше и конкурсы интереснее.

gill_beits ★★★★ ()
Ответ на: комментарий от zagatov_lev

Надо чинить возникшую проблему, а не пробовать похожие команды в надежде на то, что одна из них сработает.

intelfx ★★★★★ ()
Ответ на: комментарий от zagatov_lev

~/tor-browser_ru$ sudo systemctl –user enable –now pulseaudio.socket pulseaudio.service Failed to connect to bus: Нет такого файла или каталога

А если без sudo?

bowtda ()
Ответ на: комментарий от zagatov_lev

А я откуда знаю, как чинить? Гугл ничего не дал.

Тем временем, посмотри метрополис. Фильм прикольный, звук не нужен.

tiinn ★★★★ ()
Ответ на: комментарий от intelfx
~$ systemctl --user enable --now pulseaudio.socket pulseaudio.service
Created symlink /home/user/.config/systemd/user/sockets.target.wants/pulseaudio.socket → /usr/lib/systemd/user/pulseaudio.socket.
Created symlink /home/user/.config/systemd/user/default.target.wants/pulseaudio.service → /usr/lib/systemd/user/pulseaudio.service.
Job for pulseaudio.service failed because the control process exited with error code.
See "systemctl --user status pulseaudio.service" and "journalctl --user -xe" for details.
~$ systemctl --user status pulseaudio.service
● pulseaudio.service - Sound Service
     Loaded: loaded (/usr/lib/systemd/user/pulseaudio.service; enabled; vendor preset: enabled)
     Active: failed (Result: exit-code) since Mon 2020-08-17 12:01:45 MSK; 47s ago
TriggeredBy: ● pulseaudio.socket
    Process: 68703 ExecStart=/usr/bin/pulseaudio --daemonize=no (code=exited, status=1/FAILURE)
   Main PID: 68703 (code=exited, status=1/FAILURE)

авг 17 12:01:45 lev systemd[412]: pulseaudio.service: Main process exited, code=exited, status=1/FAILURE
авг 17 12:01:45 lev systemd[412]: pulseaudio.service: Failed with result 'exit-code'.
авг 17 12:01:45 lev systemd[412]: Failed to start Sound Service.
авг 17 12:01:45 lev systemd[412]: pulseaudio.service: Scheduled restart job, restart counter is at 5.
авг 17 12:01:45 lev systemd[412]: Stopped Sound Service.
авг 17 12:01:45 lev systemd[412]: pulseaudio.service: Start request repeated too quickly.
авг 17 12:01:45 lev systemd[412]: pulseaudio.service: Failed with result 'exit-code'.
авг 17 12:01:45 lev systemd[412]: Failed to start Sound Service.
~$
zagatov_lev ()
Ответ на: комментарий от zagatov_lev

Home directory not accessible: Отказано в доступе

Какие-то проблемы с правами. А если от рута войти, запустится?

systemctl –user. Имейте в виду, что systemd –user представляет собой процесс для каждого пользователя, а не для сессии.

Вопрос в том нужно ли было делать

sudo systemctl –user enable –now pulseaudio.socket pulseaudio.service

через sudo?

Я не специалист по systemd и никак это проверить не могу, но есть теория, что ты таким образом запустил от рута пульсу для рутового пользователя. А потом стартанул сессию для своего нерутового юзера. И теперь у тебя нерутовая сессия пытается залезть в хомяк к руту, но не может, прав нет.

gill_beits ★★★★ ()
Ответ на: комментарий от gill_beits

А если от рута войти, запустится?

[root@lev ~]# systemctl --user enable --now pulseaudio.socket pulseaudio.service
Failed to connect to bus: Нет такого файла или каталога
[root@lev ~]# 
zagatov_lev ()
Ответ на: комментарий от zagatov_lev

Странно это все… У меня на генте похожая ошибка вылезала, когда я альсу ставил. Но тогда я не те дрова в ядре включил. В Арче такого, по идее, быть не должно, да и альса у тебя, говоришь стоит…

Пытался сделать по вики. Дошел до копирования из /etc/pulse в ~/.config/pulse. Поставил микшер pavucontrol. Дальше я не понял, что нужно сделать.

Я вот никакие конфиги не ковырял, а у меня, что альса, что пульса фурычит. Так что пункт с конфигами явно опциональный.

PulseAudio строится только на компонентах ядра, но предлагает совместимость с libalsa через pulseaudio-alsa.[2]

А у тебя эта pulseaudio-alsa установлена?

gill_beits ★★★★ ()
Последнее исправление: gill_beits (всего исправлений: 1)
Ответ на: комментарий от gill_beits

check ничего не выдает.

~$ su root -c "pulseaudio --start; echo '==='; pulseaudio --check"
Пароль: 
W: [pulseaudio] main.c: Эта программа не предназначена для запуска с привилегиями администратора (кроме случая, когда указан ключ «--system»).
E: [autospawn] core-util.c: XDG_RUNTIME_DIR (/run/user/1000) принадлежит не данному пользователю (uid 0), а пользователю с uid 1000. (Это может происходить, например, в случае подключения от имени администратора к серверу PulseAudio, запущенному от имени обычного пользователя, по родному протоколу. Не делайте так.)
W: [autospawn] lock-autospawn.c: Не удалось получить доступ к блокировке, используемой для запуска сервера по требованию.
E: [pulseaudio] main.c: Failed to acquire autospawn lock
===
E: [pulseaudio] core-util.c: XDG_RUNTIME_DIR (/run/user/1000) принадлежит не данному пользователю (uid 0), а пользователю с uid 1000. (Это может происходить, например, в случае подключения от имени администратора к серверу PulseAudio, запущенному от имени обычного пользователя, по родному протоколу. Не делайте так.)

zagatov_lev ()
Ответ на: комментарий от zagatov_lev

[pulseaudio] main.c: Эта программа не предназначена для запуска с привилегиями администратора (кроме случая, когда указан ключ «–system»).

Ух ты, не знал, однако. А если тогда так: тоже под рутом но pulseaudio --start --system?

gill_beits ★★★★ ()
Ответ на: комментарий от zagatov_lev

Что lol? Я уж, честно говоря, решил, что она у тебя запущена раз уж

это может происходить, например, в случае подключения от имени администратора к серверу PulseAudio, запущенному от имени обычного пользователя, по родному протоколу.

Но нет.

gill_beits ★★★★ ()
Ограничение на отправку комментариев: только для зарегистрированных пользователей