LINUX.ORG.RU

Alpine Linux не работают устройства ввода в иксах

 , , ,


0

2

Поставил на свой старенький amd k6-ii alpine linux потом поставил иксы, они запускаются, но ни мышка ни клавиатура не работают (ctrl+alt+backspace тоже) В чём дело непонятно.

Пробовал ставить всякие xf86-libinput или evdev ни чего не меняется.

Поставил я этот apline на virtualbox, то же баг.

/var/log/Xorg.0.log

https://paste.ubuntu.com/p/ZWT9YnXRXq/

★★★

Ответ на: комментарий от chenbr0

Я отсюда https://wiki.alpinelinux.org/wiki/XFCE_Setup ввел

  Section "ServerFlags"
    Option "AutoAddDevices" "False"
  EndSection

в /etc/X11/xorg.conf.d/

мышь заработала, а клавиатура нет.

gtk3 ★★★ ()
Последнее исправление: gtk3 (всего исправлений: 1)
Ответ на: комментарий от gtk3

А что не так? Может не установлен xf86-input-evdev?

Из Вики взял: https://wiki.alpinelinux.org/wiki/Alpine_setup_scripts#setup-xorg-base

setup-xorg-base

This is a standalone script; it’s not invoked by setup-alpine but must be run manually.

Installs the following packages: xorg-server xf86-video-vesa xf86-input-evdev xf86-input-mouse xf86-input-keyboard udev.

Mixa ()
Последнее исправление: Mixa (всего исправлений: 1)

[ 791.033] (**) |-->Input Device «Mouse0»
[ 791.033] (**) |-->Input Device «Keyboard0»

[ 791.033] (**) ModulePath set to «/usr/lib/xorg/modules»
[ 791.033] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[ 791.033] (WW) Disabling Mouse0
[ 791.033] (WW) Disabling Keyboard0

убери эти записи из xorg.conf.d

mittorn ★★★★★ ()