LINUX.ORG.RU

FireFox нет звука с микрофона

 , , , ,


0

2

Здравствуйте! Заметил, что в firefox'е не работает микрофон. Ни через alsa, ни через jack (там даже соединений при записи нет).

Даже нагуглил .asoundrc

pcm.usb
{
    type hw
    card Camera
}

pcm.!default
{
    type asym
    playback.pcm
    {
        type plug
        slave.pcm "dmix"
    }
    capture.pcm
    {
        type plug
        slave.pcm "usb"
    }
}

Но он как я понял точно не причём, виноват 100% firefox 69.0.3.

★★★

Ни через alsa, ни через jack

ff официально поддерживает только pulseaudio. самому пришлось её ставить, чтобы заработал микрофон в лисе.

anonymous ()
Ответ на: комментарий от gtk3

Ну как бы да. А должен?

Другой вопрос: ты занимаешься этим в firefox? Какое отношение имеет подсистема звука для firefox (и других обычных, «повседневных» приложений) к подсистеме звука для профессиональной работы со звуком?

eternal_sorrow ★★★★★ ()
Ответ на: комментарий от eternal_sorrow

Ну мне надо было в Discord'е поболтать, не получилось. А установленный pulseaudio будет мешать всему моему софту работать.

gtk3 ★★★ ()
Последнее исправление: gtk3 (всего исправлений: 1)
Ответ на: комментарий от gtk3

Он уже собран с --enable-alsa

Что-то это я в стартовом посте не углядел, тогда извиняюсь.

Вообще ни где не работает? ну тогда расскажи больше про сборку, все флаги – если сам собирал, если нет – то дистр, версию лисы и т.п.

mandala ★★★★ ()
Последнее исправление: mandala (всего исправлений: 1)
Ответ на: комментарий от mandala

Я поставил pulseaudio, заработало. Firefox из реп arch linux.

Configure options

--enable-application=browser MOZILLA_OFFICIAL=1 --enable-update-channel=release MOZBUILD_STATE_PATH=/build/firefox/src/mozbuild
 --disable-tests 'CC=clang --target=x86_64-unknown-linux-gnu' 'CXX=clang++ --target=x86_64-unknown-linux-gnu' 
--enable-profile-use --with-pgo-profile-path=/build/firefox/src/firefox-69.0.3 --with-pgo-jarlog=/build/firefox
/src/firefox-69.0.3/jarlog --enable-lto=cross --enable-hardening AR=llvm-ar
 --enable-alsa --enable-jack
 --with-mozilla-api-keyfile=/build/firefox/src/firefox-69.0.3
/mozilla-api-key --with-google-location-service-api-keyfile=/build/firefox/src/firefox-69.0.3/google-api-key
 --with-google-safebrowsing-api-keyfile=/build/firefox/src/firefox-69.0.3/google-api-key --enable-rust-simd
 --with-unsigned-addon-scopes=app,system
 MAKE=/usr/bin/make --enable-crashreporter --disable-gconf --enable-official-branding --enable-startup-notification
 --disable-updater --prefix=/usr --with-distribution-id=org.archlinux
 --with-system-nspr --with-system-nss

gtk3 ★★★ ()
Ответ на: комментарий от gtk3

Чтобы запустить jackd нужно убить демон pulseaudio

если ты в основном используешь jack, то можешь настроить пульсу, чтобы она тоже через джек работала. тогда никого и ничего не придётся убивать. почитай на той же арчвики. тебе нужны модули module-jack-sink и module-jack-source. кроме них ещё нужен только module-native-protocol-unix, всё остальное можешь смело закомментировать. файл — /etc/pulse/default.pa либо ~/.config/pulse/default.pa.

anonymous ()

Я даже не сомневаюсь, что ты не собирал его с подержкой альсы.
Если бы собрал (и пульсу выключил в сбоке флагом), то всё работает.
А с arch тащить - ставь пульсу.

FF-esr 68.1.0, alsa, нет ни pulse ни apulse.

naked_joe ()
Ответ на: комментарий от gtk3

Ну и какая интересная вещь? apulse позволяет работать с приложениями, собранными с поддержкой pulse (Ринат написал, получило распостранение). Все бинарные сборки по умолчанию поддерживают только пульсу. Маргинальные дистры - antix, puppy и мой любимый - alpine, те да, те в силу своей особенности «заточены» под альсу.

naked_joe ()