LINUX.ORG.RU

Ищу дистрибутив для i386 с более или менее стабильно работающим хромиумом

 , , , ,


0

1

Ищу дистрибутив для 32-битной архитектуры (i386) с более или менее стабильно работающим хромиумом, желательно легковесный дистрибутив.

Гляньте, что я нашёл! ;))) http://ftp.ch.debian.org/ubuntu/pool/universe/c/chromium-browser/


antiX быстро работает, а вот современные браузеры не взлетели, не хватает им 960 Мб оперативки из которых еще что-то отжирает сама система и видео.

anonymous ()
Ответ на: комментарий от darkenshvein

с более или менее стабильно работающим хромиумом,

что это значит?
дай угадаю...который жрёт мало ОЗУ?

Такого не бывает, лишь бы не «Segmentation fault (core dumped)»

jia ()
Ответ на: комментарий от ZenitharChampion

Огромное спасибо! Даже подумать не мог о таком щасе!

Если в Raspbian для x86 такой же хороший Хромиум,
как в Raspbian для ARMv7, то он использует мало памяти.
Но я не знаю, есть ли Raspbian x86_32

Cпасибо! Бум смотреть! https://www.raspberrypi.org/downloads/raspberry-pi-desktop/

jia ()
Ответ на: комментарий от ZenitharChampion

Скорее всего, это 64-бит.
Там только одна ссылка на скачивание, и не написано,
для какой это архитектуры

Ставлю на 32, под 64 на малине сейчас только Кали есть, оригинальный распбиан только под 32

jia ()
Последнее исправление: jia (всего исправлений: 2)

Xubuntu/Linux Mint Xfce.
Debian не рекомендую, в нем обновляют Chromium (для любой разрядности) меньше двух лет, в Ubuntu 4 года (из 5). Вот, например, сейчас дебиановцы забили на обновление Хромиума в Debian 9, а дистру только два года. В SUSE нет 32-битного Хромиума даже в Tumbleweed. Fedora всегда отстает на версию и она делается не для людей. В Mageia очень старые пакеты всегда. Что там еще остается?

Nakita-Markov ()
Ответ на: комментарий от Nakita-Markov

Имей в виду, что в убунте промежуточные версии в целях безопасности не сохраняются на сервере. Это значит, что если понадобится старая версия хромиума, например, потому что она лучше работает, ее можно будет взять только из кэша пакетов /var/cache/apt/archives и установить sudo dpkg -i *.deb

Nakita-Markov ()
Ответ на: комментарий от Nakita-Markov

у manjaro32 свои репы, вполне актуально ведут, только лучше выбирать testing ветку. уж точно chromium будет самым актуальным, archlinux32 после их переезда на архитектуру pentium4 для i386 я не смотрел

One ★★★ ()
Ответ на: комментарий от ZenitharChampion

Linux raspberry 4.9.0-8-686-pae #1 SMP Debian 4.9.144-3.1 (2019-02-19) i686 GNU/Linux

Скорее всего, это 64-бит. Там только одна ссылка
на скачивание, и не написано, для какой это архитектуры

Встало хорошо, имидж там, кстати, инсталлятора, но, внезапно:

The hardware on this system lacks support for the sse2
instruction set. The upstream chromium project no longer
supports this configuration. For more information, please
read and possibly provide input to their bug tracking
system at http://crbug.com/348761.

https://ru.wikipedia.org/wiki/SSE2 :

Кроме того, не поддерживают IA-32-совместимые процессоры, >> появившиеся до SSE2:
Все AMD до Athlon 64

cat /proc/cpuinfo 
processor	: 0
vendor_id	: AuthenticAMD
cpu family	: 6
model		: 10
model name	: AMD Athlon(tm) XP 2500+
stepping	: 0
cpu MHz		: 1837.477
cache size	: 512 KB
physical id	: 0
siblings	: 1
core id		: 0
cpu cores	: 1
apicid		: 0
initial apicid	: 0
fdiv_bug	: no
f00f_bug	: no
coma_bug	: no
fpu		: yes
fpu_exception	: yes
cpuid level	: 1
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 mmx fxsr sse syscall mmxext 3dnowext 3dnow 3dnowprefetch vmmcall
bugs		: fxsave_leak sysret_ss_attrs spectre_v1 spectre_v2 spec_store_bypass
bogomips	: 3674.95
clflush size	: 32
cache_alignment	: 32
address sizes	: 34 bits physical, 32 bits virtual
power management: ts
jia ()
Ответ на: комментарий от One

i386 отлично реализован в voidlinux, легковесный (вместо systemd runit).

The i686 images have these requirements: Pentium 4 CPU (SSE2), 96MB RAM, 350MB disk, Ethernet / WiFi for network installation.

Если человек идиот - то это надолго! (c) А если они ещё и в стаю собираются - на выходе получаются такие вот роллинг-дистры

anonymous ()
Ответ на: :-)))) Slackware! Какой кавай! от jia

Похоже, что хрома там нет

И хром тоже:
http://slackware.osuosl.org/slackware-14.2/extra/google-chrome/

Правда стартовом сообщении темы речь шла о chromium. В моем ответе — о нем же.

Тем не менее, беру свой совет обратно; Slackware скорее всего не подойдет тому, кто не в состоянии понимать прочитанное даже в таком ничтожном объеме (всего два предложения, одно из которых — команда):

Доустановить slackpkg+, подключить хранилище alien, поставить chromium:
# slackpkg install chromium

bormant ★★★★★ ()
Ответ на: комментарий от anonymous

sse2 требует хромиум с версии 35, firefox c версии 53, если современный дистр такие требования не указывает по sse2, это значит, что просто для десктопа обманывают пользователя, очнись и пой.

One ★★★ ()
Ответ на: комментарий от One

sse2 требует хромиум с версии 35, firefox c версии 53,
если современный дистр такие требования не указывает
по sse2, это значит, что просто для десктопа обманывают
пользователя, очнись и пой.

Полностью с вами согласен, но у firefox есть esr версия, которая не только работает на системах без sse2, но и даже флеш-видео кажет ( это как бы тест производительности ), на установленных мной распбиане и лубунте стоят именно firefox esr, к сожалению ничего подобного для хромиума / хрома не нашел

jia ()
Ответ на: комментарий от NaiLi

Дистрибутив включён в Единый реестр российских программ для электронных вычислительных машин и баз данных.

Попробуйте https://wiki.calculate-linux.org/ru/desktop

Спасибо, заинтриговали! Gentoo для чиновников :)))

jia ()
Ответ на: комментарий от bormant

http://slackware.osuosl.org/slackware-14.2/extra/google-chrome/README

Google Chrome (Open Source Web Browser)
---------------------------------------
Here's how to install Google Chrome on Slackware.
First, go to the Google Chrome site:
http://www.google.com/chrome
Click the download button, and select either:
< > 32 bit .deb (for Debian/Ubuntu)
OR
< > 64 bit .deb (for Debian/Ubuntu)
Read and accept the license terms, and download the .deb
package.
Then, with the google-chrome-stable_current_i386.deb or
google-chrome-stable_current_amd64.deb package in the same
directory as the google-chrome.SlackBuild script, run the
script as root to convert the .deb to a Slackware .txz:
./google-chrome.SlackBuild
This will produce a Slackware compatible .txz package.
The exact version number in the package filename will
depend on the version of Google Chrome found in the
.deb package, but it will be something
like: google-chrome-10.0.648.151-x86_64-1.txz
You'll find the output package in the /tmp directory.
Then, install the package (again as root):
cd /tmp
upgradepkg --install-new google-chrome-10.0.648.151-x86_64-1.txz
Enjoy! :-)

Получаем последнюю версию хрома / хромиума, которая заведомо не будет работать без sse2, нахуа?

jia ()

Встречный вопрос: Chrome (бинарная сборка от Google) и Chromium различаете?

Chrome может быть только таким, каким его собрал Google. Претензии про прекращение поддержки процессоров без SSE2 к Slackware не по адресу.

Сhromium для Slackware собирается без явных патчей отключения sse2 (в Debian такой есть). Если сборочная система chromium на ARCH=i586 не реагирует отключением sse2 (а в Chromium 76 его разработчиками вовсе была предпринята попытка вообще выкинуть 32-битную сборку), тогда для вашей задачи бинарная сборка от Эрика (AlienBob) не подходит. Собирает ли кто-то еще, сейчас не готов сказать.

Можно пропатчить самому и пересобрать, но все понимают, что подобный геморрой в описанных условиях не стоит свеч.

Поэтому да, под процессор без sse2 для Chromium-а вариант со Slackware 14.2 скорее всего не подходит.


PS. Ответ про SLackware был дан ДО указания на отсутствие sse2.

bormant ★★★★★ ()
Последнее исправление: bormant (всего исправлений: 1)
Ответ на: комментарий от jia

Особенно про: «в Debian такой есть»

Про «есть» возможно и погорячился, но по крайней мере был точно:
https://github.com/saiarcot895/chromium-ubuntu-build/blob/master/debian/patch...

Сколь актуален он к современным версиям chromium судить не возьмусь.

bormant ★★★★★ ()
Ответ на: комментарий от One

Сам в шоке! 60.08esr (32-bit)

Последняя ESR без SSE2 вроде аж 45.х, это не очень свежо

https://d.radikal.ru/d43/1908/2a/7bdc23717eca.png

На распбиане и лубунте. Работает как молния, смазанная салом, но некоторые сайты стабильно валятся в табах: вк ...

linux.org.ru, жужу и известный всем трекер работают :)))

( чтобы скриншот сделать, решил установить gimp, вместо gimp'а случайно поставил gnome, который, в свою очередь, встал криво, 596 пакетов! Чтобы получить их список, написал полезную колбасину:

dpkg -l |  grep iU | awk -F " " '{print $2}' | tr -s '\n' ' ' > TEST.gnom.sh
)

jia ()