LINUX.ORG.RU

firefox рандомно вешает симтему при переходе по ссылке

 ,


0

1

Наблюдалось а Fedora, Arch, Tumbleweed. Совершенно случайно при переходе по ссылке полный зависон без возможности вызвать консоль по ctr+alt+1-7

Никогда небыло на Дебиане.

Расширений или совсем нет или один uBlock.

Ну что, ты, вероятно, нашел баг в новой версии видеодров. Бывает.

Если сумеешь собрать отладочный вывод, инфу о железе и дистрибутиве — оформляй багрепорт.

Для себя — сиди на том, что работает, для свежатинки snap, flatpak и appimage есть.

Vsevolod-linuxoid ★★★★★ ()
Последнее исправление: Vsevolod-linuxoid (всего исправлений: 1)
Ответ на: комментарий от Vsevolod-linuxoid

Есть для тебя ещё один вариант — в PCLinuxOS есть все LTS ветки ядра в репозитории, так что в нём должен корректно работать блоб от nVidia для твоей видяхи, при этом это apt+rpm роллинг со вполне свежим ПО.

Но я не уверен в этом, говорю из общих соображений.

Vsevolod-linuxoid ★★★★★ ()
Последнее исправление: Vsevolod-linuxoid (всего исправлений: 1)

У меня нормально работает, поэтому делаю вывод, что проблема в Nouveau. Самое простое, что ты можешь попробовать, это использовать LTS ядро (оно есть в репах Арча). Если не поможет, тогда ставь проприетарный драйвер из AUR'а.

Kron4ek ★★★ ()
Ответ на: комментарий от Kron4ek

А что дает lts ядро? Весь софт будет lts? Для этого нужно переустанавливать систему?

Для моей видяхи нет дров в репах, только в аур. При установке с помощью yay вылазит ошибка. Наверное создам тему про это.

deepforest ★★★ ()
Ответ на: комментарий от deepforest

А что дает lts ядро?

Стабильность.

Весь софт будет lts?

Что?

Для этого нужно переустанавливать систему?

Только установить ядро и загрузиться с ним. pacman -S linux-lts, потом в загрузчике выбери его.

Prosto_user ()
Ответ на: комментарий от deepforest

Всё очень просто: твоя карта работает нормально только с проприетарным драйвером от nVidia. Данный драйвер нормально работает только с LTS ядрами.

Весь остальной софт — побоку, LTS не LTS. Я даже писал дистр, где есть все LTS ядра, но свежий софт.

Vsevolod-linuxoid ★★★★★ ()
Последнее исправление: Vsevolod-linuxoid (всего исправлений: 1)
Ответ на: комментарий от Prosto_user

Только установить ядро и загрузиться с ним. pacman -S linux-lts, >потом в загрузчике выбери его.

Установил. Запустил. Теперь не работают 3д приложения - игры, блендер.

[root@home nquake]# ./ezquake-linux-x86_64
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  152 (GLX)
  Minor opcode of failed request:  3 (X_GLXCreateContext)
  Value in failed request:  0x0
  Serial number of failed request:  86
  Current serial number in output stream:  87


[root@home nquake]# 
[root@home blender-2.80-bb7b741d2f1c-linux-glibc217-x86_64]# ./blender
Received X11 Error:
	error code:   170
	request code: 152
	minor code:   34
	error text:   GLXBadFBConfig
Received X11 Error:
	error code:   170
	request code: 152
	minor code:   34
	error text:   GLXBadFBConfig
Received X11 Error:
	error code:   170
	request code: 152
	minor code:   34
	error text:   GLXBadFBConfig
Received X11 Error:
	error code:   170
	request code: 152
	minor code:   34
	error text:   GLXBadFBConfig
Received X11 Error:
	error code:   170
	request code: 152
	minor code:   34
	error text:   GLXBadFBConfig
Received X11 Error:
	error code:   170
	request code: 152
	minor code:   34
	error text:   GLXBadFBConfig
Received X11 Error:
	error code:   170
	request code: 152
	minor code:   34
	error text:   GLXBadFBConfig
Error! Unsupported graphics card or driver.
A graphics card and driver with support for OpenGL 3.3 or higher is required.
The program will now close.

[root@home blender-2.80-bb7b741d2f1c-linux-glibc217-x86_64]# 

deepforest ★★★ ()
Последнее исправление: deepforest (всего исправлений: 1)
Ответ на: комментарий от deepforest

А что дает lts ядро?

Это просто ядро с длительным сроком поддержки. Я его предложил чтобы выяснить, исправит оно твою проблему или нет.

Весь софт будет lts?

Нет.

Для этого нужно переустанавливать систему?

Нет.

Kron4ek ★★★ ()
Последнее исправление: Kron4ek (всего исправлений: 2)