LINUX.ORG.RU

Amarok умер?

 , , ,


0

2

Долгое время пользовался amarok-ом, проблем не знал - он становился лучше с каждым релизом!.. Пока его не выкинули из основных репов арча, т.к. он «подпротух» по зависимостям: https://www.reddit.com/r/archlinux/comments/9bwbgn/what_happened_to_amarok_ca...

Последний релиз https://amarok.kde.org/ в марте прошлого года. Тут https://wiki.archlinux.org/index.php/Talk:Amarok тишина.

Собственно, сабж! Раньше думал «подожду порта», теперь по ходу надо на что-то переходить... Clementine выглядит хорошо, но судя по ее gui она тоже на старых либах, не день другой - протухнет.

Ответ на: комментарий от VarfolomeyKote4ka

Ну не флейма ради, но нужен базовый функционал амарока: коллекция с поиском, умение синхронизировать метаданные в файлах с файлом БД коллекции. Умение импортировать новые альбомы, аккуратно следя за тройным соответствием: метаданные в файлах - БД - имена файлов и директорий. И, достаточно важное, *gui* должен хорошо списываться в текущие кеды (примечание: clementine, например, не очень «хорошо», там виджеты от старого кьюта, видимо).

omegatype ★★ ()

Amarok 1 и Amarok 2 - разные вещи.
Clemetine развивается, пользуюсь им уже N лет, с тех пор как Amarok испоганили во второй версии.

Clementine выглядит хорошо, но судя по ее gui она тоже на старых либах, не день другой - протухнет.

Что есть старые либы?

 * dependency graph for media-sound/clementine-1.3.1_p20190127
 `--  media-sound/clementine-1.3.1_p20190127  amd64
   `--  app-crypt/qca-2.1.3-r2  (app-crypt/qca) amd64  [qt5(+)]
   `--  dev-db/sqlite-3.25.3  (dev-db/sqlite) amd64
   `--  dev-libs/crypto++-7.0.0-r3  (dev-libs/crypto++) amd64  [asm]
   `--  dev-libs/glib-2.58.3  (dev-libs/glib) amd64
   `--  dev-libs/libxml2-2.9.9  (dev-libs/libxml2) amd64
   `--  dev-libs/protobuf-3.6.1.3  (dev-libs/protobuf) amd64
   `--  dev-qt/qtconcurrent-5.11.3  (dev-qt/qtconcurrent) amd64
   `--  dev-qt/qtcore-5.11.3-r2  (dev-qt/qtcore) amd64
   `--  dev-qt/qtgui-5.11.3  (dev-qt/qtgui) amd64
   `--  dev-qt/qtnetwork-5.11.3  (dev-qt/qtnetwork) amd64  [ssl]
   `--  dev-qt/qtsql-5.11.3  (dev-qt/qtsql) amd64  [sqlite]
   `--  dev-qt/qtwidgets-5.11.3  (dev-qt/qtwidgets) amd64
   `--  media-libs/chromaprint-1.4.3  (media-libs/chromaprint) amd64
   `--  media-libs/gstreamer-1.14.4  (media-libs/gstreamer) amd64
   `--  media-libs/gst-plugins-base-1.14.4-r1  (media-libs/gst-plugins-base) amd64
   `--  media-libs/libmygpo-qt-1.1.0  (>=media-libs/libmygpo-qt-1.0.9) amd64  [qt5(+)]
   `--  media-libs/taglib-1.11.1_p20181028  (>=media-libs/taglib-1.11.1_p20181028) amd64
   `--  sys-libs/zlib-1.2.11-r2  (sys-libs/zlib) amd64
   `--  virtual/glu-9.0-r2  (virtual/glu) amd64
   `--  x11-libs/libX11-1.6.7  (x11-libs/libX11) amd64
   `--  dev-libs/libcdio-2.0.0-r1  (dev-libs/libcdio) amd64
   `--  dev-qt/qtdbus-5.11.3  (dev-qt/qtdbus) amd64
   `--  media-libs/libgpod-0.8.3-r2  (>=media-libs/libgpod-0.8.0) amd64
   `--  media-libs/liblastfm-1.1.0_pre20150206  (>=media-libs/liblastfm-1.1.0_pre20150206) amd64
   `--  sci-libs/fftw-3.3.6_p2  (sci-libs/fftw) amd64
   `--  media-libs/libmtp-1.1.16  (>=media-libs/libmtp-1.0.0) amd64
   `--  media-libs/glew-2.1.0-r1  (media-libs/glew) amd64
   `--  media-libs/libprojectm-2.1.0-r2  (>=media-libs/libprojectm-1.2.0) amd64
   `--  virtual/opengl-7.0-r2  (virtual/opengl) amd64
   `--  dev-libs/boost-1.65.0  (dev-libs/boost) amd64
   `--  dev-qt/qtopengl-5.11.3  (dev-qt/qtopengl) amd64
   `--  dev-qt/qtx11extras-5.11.3  (dev-qt/qtx11extras) amd64
   `--  dev-qt/qtxml-5.11.3  (dev-qt/qtxml) amd64
   `--  dev-cpp/sparsehash-2.0.3-r1  (dev-cpp/sparsehash) amd64
   `--  media-sound/pulseaudio-12.2-r1  (media-sound/pulseaudio) amd64
   `--  dev-util/desktop-file-utils-0.23  (dev-util/desktop-file-utils) amd64
   `--  x11-misc/shared-mime-info-1.10  (x11-misc/shared-mime-info) amd64
   `--  media-plugins/gst-plugins-meta-1.14.3  (media-plugins/gst-plugins-meta) amd64
   `--  media-plugins/gst-plugins-soup-1.14.4  (media-plugins/gst-plugins-soup) amd64
   `--  media-plugins/gst-plugins-taglib-1.14.4  (media-plugins/gst-plugins-taglib) amd64
   `--  media-plugins/gst-plugins-libmms-1.14.3  (media-plugins/gst-plugins-libmms) amd64
   `--  gnome-base/gvfs-1.32.2  (gnome-base/gvfs) amd64  [mtp]
   `--  sys-fs/udisks-2.8.1  (sys-fs/udisks) amd64
[ media-sound/clementine-1.3.1_p20190127 stats: packages (44), max depth (1) ]

Kroz ★★★★★ ()

Он давно мертв, примерно с 2010 года, когда он стал 2.0, а 1.4 форкнули в clementine. Правда сейчас Clementine сам еле живой и не развивается почти, хотя работы и идут в его гите, но последний стабильный релиз был 3 года назад. Правда там и добавлять особо нечего, он практически идеален как по мне.

peregrine ★★★★★ ()
Последнее исправление: peregrine (всего исправлений: 1)
Ответ на: комментарий от fenris

Не фига. Вовсе не все слушают онлайн или на мобиле. Тем более мобильные девайсы все еще очень сильно упираются в батарею, а еще не у всех хороший мобильный безлимитный интернет.

rumgot ★★★★ ()
Ответ на: комментарий от omegatype

А почему у неё виджеты выглят не так, как у, например, doplhin? Полосы прокрутки, табы, вообще все. Визуально на qt3 похоже, что ли... или я один такой?

Или перфекционист, или у тебя что-то не так.
Вот у меня: https://imgur.com/OPS801E

Kroz ★★★★★ ()
Последнее исправление: Kroz (всего исправлений: 1)

Умер.

Clementine тоже слабо шевелится, Qt5 ветка была юзабельной уже года два назад, но ни одного релиза так и не сделали, везде собирают из гита.

На реддите тут подсказали про форк клементина на Qt5, который активно развивается: https://github.com/jonaski/strawberry Но там судя по коммитам и пулреквестам театр одного актера, и будущее тоже довольно туманно

UPD: не прочитал всю тему, про клубнику уже упоминали оказывается

Midael ★★★★★ ()
Последнее исправление: Midael (всего исправлений: 1)