LINUX.ORG.RU

Не могу становить nvidia драйвер в Debian 9 stretch.

 , , , ,


0

1

Я хотел немного не по инструкции поставить драйв. Написал в /etc/apt/soures.list http://ftp.ru.debian.org/debian stretch-backports main contrib non-free. Но потом поменял на тот, что указан в инструкции. Кстати linux-headers- без сообщениях об ошибках установился.

#uname -a

4.9.0-7-amd64 #1 SMP Debian 4.9.110-3+deb9u2 (2018-08-13) x86_64 GNU/Linux
# apt-get install -t stretch-backports nvidia-driver
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 nvidia-driver : ПредЗависит: nvidia-installer-cleanup но он не может быть установлен
                 ПредЗависит: nvidia-legacy-check (>= 343) но он не будет установлен
                 Зависит: nvidia-driver-libs (= 390.77-1~bpo9+1) но он не будет установлен или
                                 nvidia-driver-libs-nonglvnd (= 390.77-1~bpo9+1) но он не будет установлен
                 Зависит: nvidia-driver-bin (= 390.77-1~bpo9+1) но он не будет установлен
                 Зависит: xserver-xorg-video-nvidia (= 390.77-1~bpo9+1) но он не будет установлен
                 Зависит: nvidia-vdpau-driver (= 390.77-1~bpo9+1) но он не будет установлен
                 Зависит: nvidia-alternative (= 390.77-1~bpo9+1) но он не будет установлен
                 Зависит: nvidia-kernel-dkms (= 390.77-1~bpo9+1) но он не будет установлен или
                                 nvidia-kernel-390.77
                 Зависит: nvidia-support но он не может быть установлен
                 Рекомендует: nvidia-settings (>= 390) но он не будет установлен
                 Рекомендует: nvidia-persistenced но он не будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

#cat /etc/apt/soures.list

# 

# deb cdrom:[Debian GNU/Linux 9.5.0 _Stretch_ - Official amd64 NETINST 20180714-10:25]/ stretch main

#deb cdrom:[Debian GNU/Linux 9.5.0 _Stretch_ - Official amd64 NETINST 20180714-10:25]/ stretch main

deb http://ftp.ru.debian.org/debian/ stretch main
deb-src http://ftp.ru.debian.org/debian/ stretch main

deb http://security.debian.org/debian-security stretch/updates main
deb-src http://security.debian.org/debian-security stretch/updates main

# stretch-updates, previously known as 'volatile'
deb http://ftp.ru.debian.org/debian/ stretch-updates main
deb-src http://ftp.ru.debian.org/debian/ stretch-updates main

# stretch-backports, nvidia-driver
deb http://deb.debian.org/debian stretch-backports main contrib non-free
# apt-cache policy linux-headers-amd64
linux-headers-amd64:
  Установлен: 4.9+80+deb9u6
  Кандидат:   4.9+80+deb9u6
  Таблица версий:
     4.17+97~bpo9+1 100
        100 http://deb.debian.org/debian stretch-backports/main amd64 Packages
 *** 4.9+80+deb9u6 500
        500 http://security.debian.org/debian-security stretch/updates/main amd64 Packages
        100 /var/lib/dpkg/status
     4.9+80+deb9u5 500
        500 http://ftp.ru.debian.org/debian stretch/main amd64 Packages

Просто накати нормальный дистрибутив, секса с компьютером поубавится. Ты крайне неэффективно расходуешь время, а это как известно самый ценный ресурс.

anonymous ()

Однажды некоторые компании упоролись и взяли ядро и переименовали его и присвоили себе, а терь ты разгребай и жертвуй этим компашкам, ставь 16.04 пока я не решу эту проблему

anonymous ()
Ответ на: комментарий от anonymous

указание секции contrib non-free?

Не было, я забыл про expert mode при установки системы, установщик про это не спросил. Я думал это дописать, но раз на той странице не было про это написано, то решил без contrib non-free установить драйвер.

just_a_brake ()
Ответ на: комментарий от anonymous

Где в

deb http://ftp.ru.debian.org/debian/ stretch main

указание секции contrib non-free?

Добавил contrib non-free и всё и больше началось устанавливаться. Спасибо за помощь!

just_a_brake ()
Ответ на: комментарий от anonymous

Просто накати нормальный дистрибутив, секса с компьютером поубавится. Ты крайне неэффективно расходуешь время, а это как известно самый ценный ресурс.

Однажды некоторые компании упоролись и взяли ядро и переименовали его и присвоили себе, а терь ты разгребай и жертвуй этим компашкам, ставь 16.04 пока я не решу эту проблему

Щас уже 18.04, но я не буду Ubuntu,Mint'ы и подобные устанавливать. Во первых там ppa, они меня расстраивают. А во вторых, в Debian KDE изкоробки.

just_a_brake ()
Ответ на: комментарий от just_a_brake

КДЕ блеклая она какая то, если по цветам смотреть то лучшая это соляра баджи , но у нее есть эффекты которые нравяться пользователям, но кинишко то я конечно буду смотреть там где цветов побольше. Так что КДЕ лучше бы баджи пилило

anonymous ()
Ответ на: комментарий от anonymous

КДЕ блеклая она какая то, если по цветам смотреть то лучшая это соляра баджи , но у нее есть эффекты которые нравяться пользователям, но кинишко то я конечно буду смотреть там где цветов побольше. Так что КДЕ лучше бы баджи пилило

Посмотрел, этот budgie. Похоже на что-то между xfce,mate,kde3-4. Я не знаю чем оно лучше KDE, но мне нравиться KDE сейчас. Все приложения что мне нужны — есть. Всё красиво и просто выглядит.

Вообще мне в принципе всё-равно на DE, лишь бы работало. Но ppa я не люблю, ну или не осилил.

just_a_brake ()
Ответ на: комментарий от just_a_brake

Но удачи не забудь колориметры и раскрашивалки проверить на разных осях если будешь еще мигрировать конечно. А, то может цветность уже есть и более 255

anonymous ()
Ответ на: комментарий от anonymous

Но удачи не забудь колориметры и раскрашивалки проверить на разных осях если будешь еще мигрировать конечно. А, то может цветность уже есть и более 255.

Скорее всего не буду. Да мне кажется и волноваться не о чем. При первом S.M.A.R.T.'е всё нормально было, синеньким.

just_a_brake ()

Стаьте последнее ядро версии 4.18.7

Deleted ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.