LINUX.ORG.RU

Alsa - Щелчки в колонках

 , ,


2

1

Всем привет,

Недавно появилась такая проблема. После того как подключаю наушники в колонках появляются странные щелчки. К примеру, приходит сообщение в Телеграме, резкий щелчок через колонки, а в наушниках проигрывается звук уведомления. Проблемы не наблюдается если например играет музыка, сначала щелчок, а потом уже звук нормально идет через наушники.

Т.к. по звуку я особо не специалист, подскажите в какую сторону смотреть.


Варианты в порядке возрастания эффективности:

- удалить пульсаудио
- поменять звуковую карту
- установить win10

как правило достаточно 1 из 3.

anonymous ()
Ответ на: комментарий от alex07

Тогда подождём специалистов по pulseaudio, у меня пока в нём не было острой необходимости и он создавал одни проблемы.

anonymous ()
Ответ на: комментарий от anonymous

Он идет по умолчанию в Arch Linux. У меня вот до сих пор проблем с ним не было.

Возможно кстати дело и не в нем. Такое ощущение что при подключении наушников колонки не сразу отключаются, а как только начинает идти звук и первые мс пробивает.

alex07 ()
Ответ на: комментарий от alex07

Если сильно повезло, то заставить его работать как нужно вообще не получится. Удачи в общем, может проблема и в звуковухе или подключениях.

anonymous ()
Ответ на: комментарий от anonymous

Да не, до недавнего времени все работало как надо. Может конечно и в звуковухе как таковой что то перегорело.

alex07 ()
Ответ на: комментарий от alex07

Он идет по умолчанию в Arch Linux.

Вообще-то в арче по умолчанию только TTY идет. Я как-то ставил себе Xfce без PA на нём — работает нормально.

Vsevolod-linuxoid ★★★★★ ()
Ответ на: комментарий от Vsevolod-linuxoid

Так а какие альтернативы то? Читая темы понимаешь что Pulseaudio это как Systemd. Все от него плюются, но по факту приходится жрать что дают, либо выпиливать его, что, судя по отзывам приносит с собой больше проблем чем починка дефолта.

alex07 ()

А если серьезно, то попробуй запустить PulseAudio в режиме отладки. Чтоб хоть логи ошибок были. Можешь сразу писать их в файл.

Vsevolod-linuxoid ★★★★★ ()
Ответ на: комментарий от alex07

Чего? Альса, по моему опыту, ни фига не сложная для быта. Единственная настройка, что я сделал — это поменял порядок нумерации звуковых карт, чтобы можно было уровень звука с комфортом через GUI регулировать. Переключение на наушники само в ноуте работает. Все приложения, кроме FF свежего, работают.

И да, до этого я пытался починить пульсу — проще удалить её нахрен, если что пойдет не так.

Vsevolod-linuxoid ★★★★★ ()
Последнее исправление: Vsevolod-linuxoid (всего исправлений: 2)
Ответ на: комментарий от Vsevolod-linuxoid

Я не говорю что Альса сложная, я говорю что 5 лет назад, когда я ставил Арч каким то образом поставилось Pulseaudio, может это даже я его поставил следуя какому то мануалу — я не помню.

Нумерировать звук. карты мне не надо, т.к. она у меня одна.

Приложения тоже работают, а вот щелчки эти раздражают. Про режим отладки — гляну.

Но на то чтобы удалять пульсу и ставить альтернативу у меня как то нет ни времени, ни особого желания. Да и я не знаю какие оно мне бонусы принесет.

alex07 ()

В новых ядрах включен режим powersaving. От этого и щелчки (просыпание). Проверить можно:

$ cat /sys/module/snd_hda_intel/parameters/power_save
если 1, то оно включено.

Чтобы отключить, создай /etc/modprobe.d/alsabase.conf с содержимым:

options snd_hda_intel power_save=0
и перезагрузись.

anonymous ()

Да и переименуй тему на «Alsa - Щелчки в колонках», т.к. pulseaudio тут никаким боком.

anonymous ()
Ответ на: комментарий от anonymous

Отличное предложение, спасибо.

Создал файлик, но после перезагрузки параметр не изменился. Проверил наличие модуля

snd_hda_intel
 — есть такой.

Заглянул в powertop, увидел это:

>> Good          Enable Audio codec power management

Может это оно его обратно включает?

alex07 ()
Ответ на: комментарий от alex07

Создал файлик, но после перезагрузки параметр не изменился.

Какой файлик? Какой параметр не изменился? При чем тут powertop?

anonymous ()
Ответ на: комментарий от anonymous

Первым советом будет установить pulseaudio. Да и в чём дело, почему недавно тогда? Мне казалось, уже лет много лет как поверсейвинг для звуковых карт включен.

anonymous ()
Ответ на: комментарий от anonymous

поверсейвинг для звуковых карт стали включать по-умолчанию в ядрах начиная с 4.17

anonymous ()
Ответ на: комментарий от alex07

> Удалять Pulseaudio стремно как то

Отключи

mkdir ~/.config/pulse
echo "autospawn = no" >> ~/.config/pulse/client.conf
killall pulseaudio
ZenitharChampion ★★★★★ ()
Ответ на: комментарий от anonymous

Ну говорю же, все сделал, при ребуте параметр не меняется.

$ cat /sys/module/snd_hda_intel/parameters/power_save
1
$ cat /etc/modprobe.d/alsabase.conf
options snd_hda_intel power_save=0

Это меня наталкивает на мысль что либо файл не работает (вряд ли), либо что то включает обратно энергосберегающий режим.

C другой стороны, вики арча рекомендует сделать тоже самое: https://wiki.archlinux.org/index.php/Power_management#Audio

А еще вот тут рекомендуют поменять значение параметра power_save_controller на N.

alex07 ()
Ответ на: комментарий от alex07

Сделай так:

# echo N > /sys/module/snd_hda_intel/parameters/power_save_controller
# echo 0 > /sys/module/snd_hda_intel/parameters/power_save
Если щелчков нет, то пропиши в alsabase.conf:
options snd_hda_intel power_save_controller=N power_save=0

anonymous ()
Ответ на: комментарий от alex07

У себя только что проверил:

$ cat /sys/module/snd_hda_intel/parameters/power_save
0

$ cat /sys/module/snd_hda_intel/parameters/power_save_controller
N
Щелчки перестали проявляться.

anonymous ()
Ответ на: комментарий от anonymous

Господа, вы читаете что я пишу? Параметр power_save не переживает перезагрузку в отличие от power_save_controller.

Отсюда вопрос, что может его перезаписывать в самой ОС?

alex07 ()
Ответ на: комментарий от alex07

Если параметр не слетает после ручного изменения, положи в скрипт и выполняй его после загрузки/пробуждения.

anonymous ()
Ответ на: комментарий от anonymous

Ну видимо так и придется сделать, хоть это костыль из серии «лекарство хуже болезни».

alex07 ()
Ответ на: комментарий от anonymous

Вот специально вам отвечу: повертоп здесь при том что в арче есть сервис powertop.service который делает --auto-tune соот-но повертоп выставляет свои параметры, включая экономию энергии на звук.

Всем остальным спасибо, дело разрешилось вот этим:

# /etc/systemd/system/powertop.service
[Unit]
Description=Powertop tunings

[Service]
Type=oneshot
ExecStart=/usr/bin/powertop --auto-tune
ExecStart=/usr/bin/bash -c '/usr/bin/echo 0 > /sys/module/snd_hda_intel/parameters/power_save'

[Install]
WantedBy=multi-user.target

alex07 ()
Ответ на: комментарий от anonymous

Alsa - Щелчки в колонках

- удалить пульсаудио

гм. я всё чаще задумываюсь, а может из-под анонимуса всегда пишут женщины лора?

darkenshvein ★★★★★ ()
Ответ на: комментарий от alex07

Дык да, дело именно в этом.

В чем? В pulseaudio? Каким боком звуковой сервер может влиять на параметры загрузки модуля alsa?

anonymous ()
Ответ на: комментарий от darkenshvein

ну это уже сексизм

Так то проверенный метод, идиотина. При чём тут заголовок, который менялся, я не знаю. Ты из этих, системд-положительных, что ли?

anonymous ()
Ответ на: комментарий от darkenshvein

Скорее Systemd, Pulseaudio и т.д. это слова триггеры. Я вот без понятия что там щелкало, но т.к. у меня Pulseaudio то я и написал заголовок мол пульса глючит. Знающий человек объяснил мне что пульса ни при чем и что на самом деле дело в Альсе и в режиме энергосбережения и попросил сменить название темы (в самом начале камментов).

Остальные же просто показали свою мнимую крутость советом что то там куда то удалить, хотя суть проблемы заключалась в том чтобы поменять параметр модуля.

alex07 ()
Ответ на: комментарий от darkenshvein

а может из-под анонимуса всегда пишут женщины лора?

А мне наоборот кажется, что за никнэймами юзеров с ★★★★★, домохозяйки блондинистого типа, кроме члена во рту ничего не державших.

anonymous ()
Ответ на: ну это уже сексизм от anonymous

Так то проверенный метод, идиотина. При чём тут заголовок, который менялся, я не знаю. Ты из этих, системд-положительных, что ли?

я запутался, удалять пульсу советуешь ты, а системд-положительный оказывается, я? :(

darkenshvein ★★★★★ ()
Ответ на: комментарий от alex07

Ты акценты не правильно расставил. Речь про 5 звезд, что по факту является признаком нешарящего «умника».

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.