LINUX.ORG.RU

Debian 9 strech отсутствует разрешение 1280x1024

 


0

1

Добрый день. Установил debian на десктоп, видеокарта nvidia GT220. Установил на нее драйвера, выводит разрешения:

  • 1024x768
  • 1360x768
  • 1152x864
  • 800x600

а мне нужно установить 1280x1024

мне дали ссылку на подобную проблему только с ubuntu http://www.msav.ru/blog/159-adjusts-the-resolution-of-the-xorg-12801024-in-ubuntu-linux-with-integrated-video-adapter-intel-part-one, но у меня в Debian 9 strech нет конфига /etc/X11/xorg.conf папка Х11 содержит:

locale  rgb.txt  XErrorDB  xkb  xman.help  xorg.conf.d
xorg.conf.d - это каталог

Ввожу команды по данной мне ссылке:

vitaliy@Personal-Desktop:~$ sudo /etc/init.d/gdm stop
sudo: /etc/init.d/gdm: команда не найдена
ввожу следующую команду:
vitaliy@Personal-Desktop:Ё$ sudo Xorg -configure
_XSERVTransSocketUNIXCreateListener: ...SocketCreateListener() failed
_XSERVTransMakeAllCOTSServerListeners: server already running
(EE) 
Fatal server error:
(EE) Cannot establish any listening sockets - Make sure an X server isn't already running(EE) 
(EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
(EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
(EE) 
(EE) Server terminated with error (1). Closing log file.
Вот что находится в папке /usr/share/X11/xorg.conf.d:
10-amdgpu.conf  40-libinput.conf  nvidia-drm-outputclass.conf
10-quirks.conf  70-wacom.conf
Файл nvidia-drm-outputclass.conf содержит:
# This xorg.conf.d configuration snippet configures the X server to
# automatically load the nvidia driver when it detects a device driven by the
# nvidia.ko kernel module.  Please note that this only works on Linux kernels
# version 3.9 or higher with CONFIG_DRM enabled, and only if the nvidia.ko
# kernel module is loaded before the X server is started.

Section "OutputClass"
    Identifier     "nvidia"
    MatchDriver    "nvidia-drm"
    Driver         "nvidia"
EndSection
в этот nvidia файл пытался закинуть:
Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"
        DefaultDepth 16
        SubSection "Display"
                Depth     16
                Modes   "1280x1024"
        EndSubSection
EndSection
но после перезапуска все программы графически ломались будто артефакты но именно в программе появлялись..

Какой день ищу решение и никак не найду...

По ссылке устаревшие инструкции. У тебя дрова проприетрные или нет?

Vsevolod-linuxoid ★★★★★ ()
Ответ на: комментарий от Vsevolod-linuxoid

По ссылке устаревшие инструкции. У тебя дрова проприетрные или нет?

Увы, да.. Ставил sudo apt-get install nvidia-legacy-340xx-driver

Если были бы не проприетарные - поставил бы их..

TheLinuxUser ()
Ответ на: комментарий от TheLinuxUser

Все нормально, на самом деле. Теперь

sudo rm /etc/X11/xorg.conf
или куда ты там понаписал настроек (но содержимое /etc/X11/xorg.conf.d лучше не удалять, просто верни к изначальному виду), затем
sudo apt install nvidia-xconfig
sudo nvidia-xconfig
и перезагрузись, после чего доложи о результатах. Последняя команда создаст родной xorg.conf, куда и нужно записывать параметры, старые методы его генерации работают некорректно как правило.

Vsevolod-linuxoid ★★★★★ ()
Последнее исправление: Vsevolod-linuxoid (всего исправлений: 2)
Ответ на: комментарий от Vsevolod-linuxoid

или куда ты там понаписал настроек (но содержимое /etc/X11/xorg.conf.d лучше не удалять, просто верни к изначальному виду)

Я вернул сразу после того как не получилось.

sudo apt install nvidia-xconfig

sudo nvidia-xconfig

и перезагрузись, после чего доложи о результатах. Последняя команда создаст родной xorg.conf, куда и нужно записывать параметры, старые методы его генерации работают некорректно как правило.

После последней команды выбило:

WARNING: Unable to locate/open X configuration file.

New X configuration file written to '/etc/X11/xorg.conf'
перезагрузился, пропали все разрешения и установилось одно без выбора 640х480...

TheLinuxUser ()

судя по присутствию 1360x768 - ноутбук?

shashilx ()
Ответ на: комментарий от TheLinuxUser

Так, а вот теперь можно выставить нужное вручную. Выложи сюда /etc/X11/xorg.conf

Vsevolod-linuxoid ★★★★★ ()
Ответ на: комментарий от TheLinuxUser

/etc/init.d/gdm stop

там же systemd. или по старинке дрочить подручнее?

shashilx ()
Ответ на: комментарий от shashilx

Он на старые инструкции ориентируется. К сожалению, свежие обычно только на английском.

Vsevolod-linuxoid ★★★★★ ()
Ответ на: комментарий от TheLinuxUser

окей, десутоп. но монитор не квадратный, а какойнить 16:9, 16:10?

shashilx ()
Ответ на: комментарий от Vsevolod-linuxoid

Он на старые инструкции ориентируется. К сожалению, свежие обычно только на английском.

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 384.111  (buildd@debian)  Sun Feb 25 23:27:00 UTC 2018

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

shashilx квадратный.

TheLinuxUser ()

Вообще тут дело, кмк, в мониторе, который выдаёт кривой EDID. В своё время я с таким намучался (дешманский эйсер 5:4 с разрешением 1280x1024).

Thetan ★★★ ()
$ cvt 1280 1024
$ xrandr --newmode "1280x1024_60.00"  109.00  1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsync
$ xrandr --addmode VGA-1 1280x1024
$ xrandr --output VGA-1 --mode 1280x1024
amd_amd ★★ ()
Ответ на: комментарий от shashilx

модель монитора?

Philips 190C6FS

Зачастую дело может быть вообще в плохом кабеле.

Vsevolod-linuxoid, не в нем дело, на других дистрибутивах было всё ок, только в дебиане не находит, а на другие дистрибутивы идти не хочу. Я выше сбросил конфиг

TheLinuxUser ()
Ответ на: комментарий от TheLinuxUser

Измени вот так часть секций:

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
        Modes      "1280x1024" "1024x768" "800x600"
    EndSubSection
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    Option "TripleBuffer" "True"
    Option "metamodes" "nvidia-auto-select +0+0 { ForceCompositionPipeline = On }"
EndSection

И перезагрузись. Изменения в Device опциональны, они против тиринга.

Vsevolod-linuxoid ★★★★★ ()
Последнее исправление: Vsevolod-linuxoid (всего исправлений: 1)

nvidia-settings это оно выдает такие разрешения?

amd_amd ★★ ()
Ответ на: комментарий от Vsevolod-linuxoid

Помимо Modes нужно прописать Modeline с описанием виде режима.

kostik87 ★★★★★ ()
Ответ на: комментарий от Vsevolod-linuxoid

Измени вот так часть секций: ... И перезагрузись. Изменения в Device опциональны, они против тиринга.

Сделал, перезагрузился, разрешение то же самое 640х480 и в списке выбора разрешния новых не появилось.

nvidia-settings

amd_amd, смотрю через обычные настройки GNOME

TheLinuxUser ()
Ответ на: комментарий от TheLinuxUser

из терминала nvidia-settings долбануть религия не прозволяет? откроется штатная утилита nvidia - в ней посмотри интересующее тебя разрешение

amd_amd ★★ ()
Ответ на: комментарий от Vsevolod-linuxoid

Покажи вывод команды

sudo gtf 1280 1024 60
# 1280x1024 @ 60.00 Hz (GTF) hsync: 63.60 kHz; pclk: 108.88 MHz
  Modeline "1280x1024_60.00"  108.88  1280 1360 1496 1712  1024 1025 1028 1060  -HSync +Vsync
TheLinuxUser ()
Ответ на: комментарий от TheLinuxUser

Отлично. Я слегка напутал, и тебе следует изменить ещё одну секцию xorg.conf:

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Modeline "1280x1024_60.00"  108.88  1280 1360 1496 1712  1024 1025 1028 1060  -HSync +Vsync
    Option         "DPMS"
EndSection
Vsevolod-linuxoid ★★★★★ ()
Последнее исправление: Vsevolod-linuxoid (всего исправлений: 1)
Ответ на: комментарий от Vsevolod-linuxoid

Отлично. Я слегка напутал, и тебе следует изменить 3, а не 2 секции xorg.conf, и немного иначе

Так же ничего не изменилось..

TheLinuxUser ()
Ответ на: комментарий от Vsevolod-linuxoid

Выложи текущий xorg.conf

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 384.111  (buildd@debian)  Sun Feb 25 23:27:00 UTC 2018

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Modeline "1280x1024_60.00"  108.88  1280 1360 1496 1712  1024 1025 1028 1060  -HSync +Vsync
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    Option "TripleBuffer" "True"
    Option "metamodes" "nvidia-auto-select +0+0 { ForceCompositionPipeline = On }"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
        Modes      "1280x1024"
    EndSubSection
EndSection
TheLinuxUser ()
Ответ на: комментарий от TheLinuxUser

Попробуй заменить

        Modes      "1280x1024"
обратно на
        Modes      "1280x1024" "1024x768" "800x600"
и перезагрузиться.

Vsevolod-linuxoid ★★★★★ ()
Ответ на: комментарий от Vsevolod-linuxoid

Попробуй заменить

0 реакции, всё равно то же самое разрешение и новых в выборе не появляется..

TheLinuxUser ()

amd_amd, kostik87, Thetan — я тут вспомнил, что у ТСа GNOME 3, а его GDM по умолчнию иксы не от root запускает, как обычно. Это может влиять?

Vsevolod-linuxoid ★★★★★ ()
Ответ на: комментарий от Vsevolod-linuxoid

xorg.conf если стоят дрова должен в /usr/share/X11/xorg.conf.d находится, но сгенерировать его надо при помощи утилиты nvidia-settings

amd_amd ★★ ()
Ответ на: комментарий от amd_amd

Чего? Все настройки всегда в /etc находятся, в /usr/share их варианты по умолчанию только.

Vsevolod-linuxoid ★★★★★ ()
Ответ на: комментарий от Vsevolod-linuxoid

Так или иначе из /etc/X11 настройки должны были прочесться.

Thetan ★★★ ()
Ответ на: комментарий от Vsevolod-linuxoid

А если запустить

sudo nvidia-settings

, то там какие разрешения?

Там вообще не понятно где выбирать, у меня на столько всё огромное что уже голова болит. Там вкладка «X Server Display Configuration» на ней есть пункт Resolution и на ней всего 2 разрешения, это 640х480 и 320х240. Больше нигде ничего выбирать не могу

TheLinuxUser ()
Ответ на: комментарий от Vsevolod-linuxoid

не люблю блоб, но без него невидиа не может... разрешение настраиваю так - в терминале запускаю nvidia-settings выбираю разрешение и сохраняю конфигурацию, при сохранении спрашивает куда - кидаю в /usr/share/X11/xorg.conf.d и это по феншую - в /etc/x11 не феншуйный вариант, там правят когда иксы не распознают разрешение...

amd_amd ★★ ()
Ответ на: комментарий от amd_amd

У тебя каша в голове. Почитай FHS. В /usr/share неправильно менять что-либо, там дефолт. В /etc X11 смотрит не при ошибках, а когда значения отличны от умолчательных.

Vsevolod-linuxoid ★★★★★ ()
Последнее исправление: Vsevolod-linuxoid (всего исправлений: 1)
Ответ на: комментарий от TheLinuxUser

640х480 и 320х240

да это жопа - дрова не пашут, рассказывай как дрова ставил...

amd_amd ★★ ()
Ответ на: комментарий от amd_amd

640х480 и 320х240

да это жопа - дрова не пашут, рассказывай как дрова ставил...

У меня Nvidia GT220, ставил так: sudo apt-get install nvidia-legacy-340xx-driver

TheLinuxUser ()
Ответ на: комментарий от Vsevolod-linuxoid

Я когда на ноутбук ставил Debian то думал что проблем дофига и на десктоп будет легче и не будет проприетарных драйверов, не тут то было ..... Есть еще мысли как его сделать?

TheLinuxUser ()
Ответ на: комментарий от TheLinuxUser

Жду ответа костика, сам не знаю. Но amd про /usr/share бред написал, даже мне это очевидно, хотя и сам новичек.

Vsevolod-linuxoid ★★★★★ ()
Ответ на: комментарий от Vsevolod-linuxoid

если иксы нужного разрешения не находят, генерирую xorg.conf при помощи xorg -configure добавляю необходимое разрешение и кидаю его в /etc/X11, а если установлен блоб генерю xorg.conf при помощи nvidia-settings и кидаю его в /usr/share/X11/xorg.conf.d ... каша это у тебя и иксы и блоб в одном конфиге

amd_amd ★★ ()
Последнее исправление: amd_amd (всего исправлений: 1)
Ответ на: комментарий от amd_amd

Без разницы какой драйвер используется, блоб или открытый.

Конфигурационный файл читает xorg-server, в /etc/X11/xorg.conf в конечном итоге.

kostik87 ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.