LINUX.ORG.RU

Запретить окнам вылезать поверх других

 , ,


0

2

Здравствуйте. Подскажите, пожалуйста, можно ли настроить Debian 9 xfce, чтобы по умолчанию окна не вылезали неожиданно поверх текущего? Настройки диспетчера окон не помогли. Очень мешает, когда приложение, выполняя задачу, периодически открывает маленькое окошко (например, при обработке файлов цепью эффектов в Audacity), которое легко случайно закрыть нажатием клавиши, прервав операцию.

Ответ на: комментарий от Deleted

Придётся это делать для каждого окна, с которым работаешь, а ведь можно и на рабочем столе находиться в момент, когда это окошко вылезет.

rdstrcmrd ()

Можно сделать с помощью менеджера окон openbox, найти строчку <focusNew>yes</focusNew> поменять yes на no в файле ~/.config/openbox/rc.xml, запустить openbox --replace & тогда фокус не будет передаваться новым запускаемым окнам ps. https://unix.stackexchange.com/questions/156515/how-to-forbid-windows-from-st...

Samamy ★★★ ()
Последнее исправление: Samamy (всего исправлений: 1)
Ответ на: комментарий от Samamy

После этих настроек

Settings/Window Manager/Focus Automatically give Focus to newly created windows (off) Settings/Window Manager Tweaks/Focus Activate Focus Stealing Prevention (on) Honor standard ICCCM focus hint (off) When a window raises itself, (do nothing)

всё ещё вылазит, если просто переключить окно. А если в этом окне что-то поделать, тогда уже не вылазит. Ну и на рабочий стол по-прежнему выскакивает.

rdstrcmrd ()
Ответ на: комментарий от rdstrcmrd

Ну пощелкай разные комбинации, может найдешь ту, при которой xfwm4 (менеджер окон Xfce) ведет себя как ты хочешь.

Или можешь заменить xfwm4 на openbox по совету выше. Но для этого придется установить openbox, а затем в настройках Xfce указать его использовать вместо xfwm4. http://openbox.org/wiki/Help:XFCE/Openbox

Vsevolod-linuxoid ★★★★★ ()
Последнее исправление: Vsevolod-linuxoid (всего исправлений: 1)
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.