LINUX.ORG.RU

archlinux и virtualbox оно вообще работает?

 , ,


0

1

При попытке создать виртуальный жесткий диск получаю:

Could not create the medium storage unit '/mazday/mazday.vhd'.
VHD: cannot create image '/mazday/mazday.vhd' (VERR_ACCESS_DENIED).


Код ошибки: 
VBOX_E_FILE_ERROR (0x80BB0004)
Компонент: 
MediumWrap
Интерфейс: 
IMedium {4afe423b-43e0-e9d0-82e8-ceb307940dda}
ЧЯДНТ?

★★★★★

Ответ на: комментарий от burato

Это как пример в ответ анону. Или запускайте от рута(плохая идея)

или настраивате группы

добавили себя в vboxusers?

vs220
()
Ответ на: комментарий от burato

Создайте группу и добавьте туда пользователя.

Shein
()
Ответ на: комментарий от vs220

добавили себя в vboxusers?

Оно нужно разве что для доступа к USB устройствам.

fornlr ★★★★★
()
Последнее исправление: fornlr (всего исправлений: 1)

Рач всему виной.

anonymous
()

работает - должно работать, headers установлен? у меня по крайней мере работает - но я не в восторге, держу под арч одну машину ради общего развития...

amd_amd ★★★★★
()

Вобщем с диском непонятки. Динамический диск создаётся, фиксированный нет, ошибка обозначенная в топике. Но машину не запустить, жалуется на отсутствующий драйвер:

http://segacam.ddns.net/files/kernel_driver.png

burato ★★★★★
() автор топика
Ответ на: комментарий от burato

У тебя модули Vbox'а загружены? Они загружаются при запуске системы. Однако если ты установил vbox, но еще не перезагружался, тебе нужно подгрузить их вручную.

Kron4ek ★★★★★
()
Ответ на: комментарий от anonymous

без него не установить систему.

burato ★★★★★
() автор топика
Ответ на: комментарий от Kron4ek
Linux bur-pc 4.15.1-2-ARCH #1 SMP Sun Feb 4 22:27:45 UTC 2018 x86_64 GNU/Linux
burato ★★★★★
() автор топика
Ответ на: комментарий от burato

Второй вариант требует также установки хэдеров: linux-headers, linux-lts-headers или linux-zen-headers - в зависимости от ядра.

Kron4ek ★★★★★
()
Ответ на: комментарий от Kron4ek

Кстати, ни разу не обновлял. Пытался гуглить, но там на неделю. Как вкратце, чтоб ничего не сломать?

burato ★★★★★
() автор топика
Ответ на: комментарий от burato

Если у тебя zita-resampler установлен, сделай это перед обновлением.

Kron4ek ★★★★★
()
Ответ на: комментарий от burato

Кстати, ни разу не обновлял.

Пиздец просто. В нескольких местах написано, что нужно обновляться, но нет, у нас ubuntu-way.

Partial upgrades are unsupported

https://wiki.archlinux.org/index.php/Pacman#Upgrading_packages

https://wiki.archlinux.org/index.php/System_maintenance#Partial_upgrades_are_...

onlybugs ★★
()
Ответ на: комментарий от burato

Про установку headers поподробнее

# pacman -S linux-headers-4.15.xx-x-amd64

номер xx-x должен совпадать с номером ядра, без этой шляпы dkms не пересоберет модули в ядре... почему не ввосторге - глючный стал и жрет много, а раньше только на нем и ехал - сейчас пересел на debian, а старье певел на devuan

amd_amd ★★★★★
()
Ответ на: комментарий от onlybugs

У меня после обновления беспроводной адептер перестал отключаться и функциональные клавиши перестали работать

burato ★★★★★
() автор топика

Заработало!! Спасибо всем отметившимся в топе.

Но диск фиксированным сделать так и не даёт.

burato ★★★★★
() автор топика
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.