LINUX.ORG.RU

RDP на сервер Windows через канал OpenVPN : жёсткие тормоза.

 , , ,


0

1

Есть кусок хостинга где-то в Германии, под управлением Windows Server 2008. На нём крутится жёлтая программа, на него люди ходят по протоколу RDP по каналу OpenVPN. Канал и сервер сам по себе хорошие, если использовать клиент удалённого рабочего стола Windows — всё быстро работает, нареканий нет. Я же работаю под Xubuntu. Сервис openvpn установил, клиент настроил, интерфейс tun0 поднимается и работает. Любым клиентом RDP на сервер стабильно заходит и соединение нормально держит - как из консоли xfreerdp, так и графической Remminoй. Одна беда - ОЧень сильно тормозит, как будто канал не в мегабитах, а диалапом соединились. Работать крайне некомфортно. На этой же машине установлена Win7, из-под неё всё отлично летает. В какую сторону копать, кто знает?

Ответ на: комментарий от NewUser

Установил с офсайта openvpn последней версии (собрал из src), без толку.

NewUser ()
Ответ на: комментарий от r0ck3r

Тут в соседней теме мне высказывали своё «фе» по поводу того, что я хожу на офсайты качаю софт, а не из репозиториев ставлю. Так вот, проблему решил типичным для пользователя Windows (и наименее вероятным для пользователя Linux) способом. Пошёл на сайт Realtek, скачал ихние брова на свою встроенную сетевую карту, собрал, вставил ядерный модуль, проблема исчезла. Кто-нибудь когда-нибудь качал/собирал проприетарные дрова на встроенную сетевуху, если она при этом нормально работает? :DD

NewUser ()
Ответ на: комментарий от NewUser

Кто-нибудь когда-нибудь качал/собирал проприетарные дрова на встроенную сетевуху, если она при этом нормально работает?

Только любители поделок от Realtek, NVIDIA, Broadcom и прочего говна.

anonymous ()
Ответ на: комментарий от r0ck3r

Ну у меня суть как раз в том была, что плохо работал свободный драйвер для Rlt, а проприетарный - нормально.

Хотя, учитывая то, что я всё-таки не докопался на 100% до причины проблем, вполне допускаю, что процесс установки/обновления модуля драйвера для сетевухи просто сбросил/обнулил какие-нибудь конфиги, касающиеся работы сети, бывшие до того не самыми благоприятными для работы rdp over vpn, а сами дрова работают так же.

P.S. Немножко не в тему, но очень веселит подход " Если я не могу найти правильный драйвер для имеющегося железа под Linux, я лучше пересоберу всю аппаратную часть компьютера, но пингвину не изменю ни с чем" :DDDD

NewUser ()
Ответ на: комментарий от NewUser

К сожалению, проблема вернулась. Работать с удалённым сервером по RDP через канал openvpn крайне некомфортно, очень жёсткие тормоза. Рядом стоит Windows 7, в ней всё отлично летает. Куда бы покопать, чтобы исправить проблему, кто что думает?

NewUser ()

Попробуй потестировать связь через впн iperf3.
Ещё попробуй freerdp2-x11 вот так:

xfreerdp /u:user /v:server +fonts  +clipboard  /gfx

Deleted ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.