LINUX.ORG.RU

Переменная LINGUAS в make.conf перестала применяться

 ,


1

5

Буквально несколько часов назад выполнил eix-sync и при выводе списка пакетов для обновления portage мне сообщил, что пакеты, которые были собраны с русскоязычной локализацией будут пересобраны с флагом "-linguas_ru".

В make.conf всё так же прописано

LINGUAS="en ru ru_RU"
L10N="${LINGUAS}"

, что вроде бы должно соответсовать этой старой новости:

https://gentoo.org/support/news-items/2016-06-23-l10n-use_expand.html

и до сегодняшней ночи всё было нормально.

Pinkbyte, не подскажешь, может я новость какую пропустил и снова что-от поменяли? Как раз недавно закончил пересобирать мир с профилем 2017.0.

★★★★★

Тоже самое произошло. Уже, к сожалению, обновил несколько софтин, в Deadbeef весь интерфейс стал на английском.

With ★☆☆ ()

Пока не исправили, можно откатить дерево portage на e48e6d6.

backbone ★★★★★ ()

Похоже не все пакеты ещё перевели на L10N. Можно пока добавить в make.conf:

USE_EXPAND=«LINGUAS»

Lautre ★★★★★ ()
Ответ на: комментарий от Deleted

Можно, например, явно указать для пакета USE=«linguas_ru», может даже в make.conf прописать, но надеюсь, что починят.

grem ★★★★★ ()
Ответ на: комментарий от Lautre

кста, как оказалось всё работает с USE=«linguas_*». просто не отображаются языки, но устанавливаются только прописанные языки

Deleted ()
Ответ на: комментарий от Deleted

Ну то есть я пытался посмотреть что выдаст

USE="linguas_ru" emerge -1av openoffice-bin

и тогда то он флаг языкового пакета опять включает.

А так для некоторых пакетов выглядит так, словно вообще поддержка локализации для других языков пропала.

покажи выхлоп
emerge -avtp git

чуть попозже гляну.

Из описания того бага не совсем понятно, как теперь управлять установкой языковых пакетов то или они всё-таки починят?

grem ★★★★★ ()
Ответ на: комментарий от grem

Из описания того бага не совсем понятно, как теперь управлять установкой языковых пакетов то или они всё-таки починят?

оно управляется втихаря

~ $ equery f git | grep -i locale
/usr/share/locale
/usr/share/locale/ru
/usr/share/locale/ru/LC_MESSAGES
/usr/share/locale/ru/LC_MESSAGES/git.mo
~ $ equery f bleachbit | grep -i locale
/usr/share/locale
/usr/share/locale/ru
/usr/share/locale/ru/LC_MESSAGES
/usr/share/locale/ru/LC_MESSAGES/bleachbit.mo
~ $ equery f deadbeef | grep -i locale
/usr/share/locale
/usr/share/locale/ru
/usr/share/locale/ru/LC_MESSAGES
/usr/share/locale/ru/LC_MESSAGES/deadbeef.mo
т.е. русский язык устанвливается, но не так явно, как было ранее

Deleted ()
Ответ на: комментарий от Deleted

для ряда пакетов вывод emerge -uDNav @world

# emerge -uDNav @world

These are the packages that would be merged, in order:

Calculating dependencies -, ... done!
[ebuild   R    ] app-text/iso-codes-3.75::gentoo  USE="... (-linguas_ro%) (-linguas_ru%*) (-linguas_rw%)..." 0 KiB
[ebuild   R    ] net-libs/gnutls-3.5.15:0/30::gentoo  USE="cxx idn nls openssl seccomp tls-heartbeat zlib -dane -doc -examples -guile -openpgp -pkcs11 -sslv2 -sslv3 -static-libs {-test} (-test-full) -tools -valgrind ... (-linguas_en%*) ..." ABI_X86="32 (64) (-x32)" 0 KiB                                                                                                          
[ebuild   R    ] media-gfx/exiv2-0.26_p20171104:0/26::gentoo  USE="nls png xmp -doc -examples ...l -linguas_pt -linguas_ru* -linguas_sk .. -webready" ABI_X86="32 (64) (-x32)" 0 KiB                                                    
[ebuild   R    ] app-text/po4a-0.47-r1::gentoo  USE="{-test} ... (-linguas_pt_BR%) (-linguas_ru%*) (-linguas_sl%)..." 0 KiB                                                       
[ebuild   R   ~] app-text/coolreader-3.1.2.71-r4::gentoo  USE="-wxwidgets ...(-linguas_pl%) (-linguas_ru%*) (-linguas_uk%)" L10N="ru -bg -cs -de -es -hu -pl -uk" 0 KiB                                                                                                                                 
[ebuild   R   ~] app-office/openoffice-bin-4.1.5::gentoo  USE="java -gnome ... -linguas_pt_BR -linguas_ru* -linguas_sk..." 0 KiB                                                                                                                                                                          

и для

$ emerge -avtp git

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild   R    ] dev-vcs/git-2.13.6::gentoo  USE="blksha1 curl gpg iconv nls pcre perl python threads webdav -cgi -cvs -doc -emacs -gnome-keyring -highlight -libressl -mediawiki -mediawiki-experimental (-ppcsha1) -subversion {-test} -tk -xinetd ... (-linguas_pt_PT%) (-linguas_ru%*) (-linguas_sv%)..." PYTHON_TARGETS="python2_7" 0 KiB
grem ★★★★★ ()
Последнее исправление: grem (всего исправлений: 1)

странно что еще не сказал что лингвасы ненужны

deity ★★★★ ()
Ответ на: комментарий от grem

у меня также было при пересборке пакетов, а счас этих linguas_* просто нет, но языки всё равно устанавливаются

Deleted ()

Ну чего починили уже внутри дистра или надо самому колупать где-то? Можно обновляться уже или нет?

With ★☆☆ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.