LINUX.ORG.RU

PaleMoon и странность при переключении раскладки клавиатуры

 ,


0

1

debian/gnome3
поставил palemoon - быстро, удобно, но онид косяк раздражает. В адресной строке и в поле поиска при переключении языка ввода выделяется весь набранный в поле текст и если продолжать набор затирается то, что было ранее набрано. неудобно.
пробовал поменять сочетание клавиш - то же самое.
кто нибудь сталкивался?


Ответ на: комментарий от Aceler

gnome 3
palemoon Version: 27.2.1 (64-bit)

переключение раскладок как я понмаю производится средствами гнома - настраивается через gnome-tweak-tool

griz ()
Последнее исправление: griz (всего исправлений: 1)
Ответ на: комментарий от xaizek

ну я тоже не придумываю. Понмаю что это какая то нештатная ситуация, но как её решать непонятно.

griz ()
Ответ на: комментарий от griz

В Gnome3 есть баг - при переключении раскладки пропадает фокус на приложении. Palemoon интерпретирует пропадание фокуса как завершение редактирования.

Либо поменять переключатель на gxkb, либо DE, либо браузер.

Aceler ★★★★★ ()
Ответ на: комментарий от Aceler

да, это тот самый баг.
не все гладко с исправлением.
сначала попробовал gxkb - этот тупо виснет через пару минут.
попробовал сделать переключение средствами xkb но что то пошло не так.
вроде как присутствует в логах xorg
[ 27.790] (**) Option «xkb_rules» «evdev»
[ 27.790] (**) Option «xkb_model» «pc105»
[ 27.790] (**) Option «xkb_layout» «us,ru»
[ 27.790] (**) Option «xkb_variant» ","
[ 27.790] (**) Option «xkb_options» «grp:ctrl_shift_toggle»

но ничего не делает. Т.Е. если снять галки в гноме то никаких переключений по нажатию непроисходит.

griz ()
Последнее исправление: griz (всего исправлений: 1)
Ответ на: комментарий от Aceler

даже вот так можно посмотреть
localectl status
System Locale: LANG=ru_RU.UTF-8
VC Keymap: us-acentos
X11 Layout: us,ru
X11 Model: pc105
X11 Options: grp:ctrl_shift_toggle,grp_led:none

но не работает

griz ()
Ответ на: комментарий от griz

Надо ещё отключить гномий способ: gsettings set org.gnome.settings-daemon.plugins.keyboard active false

Иначе он будет постоянно перенастраивать.

Aceler ★★★★★ ()
Ответ на: комментарий от Aceler

видимо это еще не все
gsettings get org.gnome.settings-daemon.plugins.keyboard active
false

но не работает....

griz ()
Ответ на: комментарий от Aceler

и при этом если в gnome-tweak-tool поставить галку напротив переключения то работает то, что поставишь.
А вывод
gsettings get org.gnome.settings-daemon.plugins.keyboard active
false

griz ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.