LINUX.ORG.RU

Разрешение экрана

 ,


0

0

X-ы запускаю командой startx. Оконный менеджер запускается из .xinitrc exec xwm. После запуска оконного менеджера выставляется не родное разрешение экрана. При помощи xrandr выставляю родное разрешение без проблем. Где прописать чтобы выставлялось родное разрешение после входа? Може можно куда-то прописать xrandr с моими параметрами? Видео Intel, подключено HDMI кабелем. Пробовал в параметрах ядрах прописывать video=VGA1:d но эффекта нет.

Xorg.log


Ответ на: комментарий от kostik87

У меня на sddm такая же проблема была, на экране ввода пароля выставлялись не родное разрешение. Но, после входа, kde выставляло нужное. Вариант использования xorg.conf рассматривал, но думал есть другое решение.

lukman ()
Ответ на: комментарий от lukman

но думал есть другое решение.

Есть, сгенерируй файл с данными edid и пропиши его в параметрах ядра. Но проще написать корректный xorg.conf, сейчас у тебя драйвер не может корректно прочитать edid данные твоего монитора.

kostik87 ★★★★★ ()

Оконный менеджер запускается из .xinitrc exec xwm.
Може можно куда-то прописать xrandr с моими параметрами?

Туда же, перед exec

arson ★★★★★ ()
Ответ на: комментарий от kostik87

Решил проблему созданием конфига /etc/X11/xorg.conf.d/10-monitor.conf

Section "Monitor"
	Identifier "HDMI1"
	Modeline "1920x1080_60.00" 173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync
	Option "PreferredMode" "1920x1080_60.00"
EndSection

Section "Screen"
	Identifier "Screen0"
	Monitor "HDMI1"
	DefaultDepth 24
	SubSection "Display"
		Modes "1920x1080_60.00"
	EndSubSection
EndSection

Section "Device"
	Identifier "Device0"
	Driver "intel"
EndSection

lukman ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.