LINUX.ORG.RU

Стабильность и удобство Debian Unstable

 , , , ,


0

1

Добрый день. Я покупаю ноутбук с процессором Skylake и мне сказали, что лучше использовать новое ядро. В связи с этим я предполагаю вместо Debian Stable (который у меня на десктопе) поставить на ноутбук Debian Unstable. Пожалуйста, поделитесь историями успеха, как у Вас что-нибудь под Debian Unstable сломалось или наоборот не сломалось. Заранее спасибо.

★★

А теперь объясни, нафейхоа тебе ради одного ядра менять версию дистра. Поставь ядро+фирмварь и дрова (если внешние) от Unstable и продолжай сидеть на Stable.

Pavval ★★★★★ ()

Лично я использую testing с добавлением пакетов из unstable. За несколько лет использования серьёзных проблем не было, хотя мелкие баги и косяки были.

Использовать ветку unstable в качестве основной не рекомендую. Достаточно использовать нужные пакеты из этой ветки.

Wind ★★ ()

Лучше использовать нормальный роллинг-дистрибутив со свежими пакетами. Например, Manjaro.

Deleted ()

Если осилите самосборное ядро, то можно использовать самое-самое последнее в дистрибутиве почти любой древности.

А по поводу debian unstable пользовался, вроде всё работало, багов в то время было мало. Но я его убил своими экспериментами с подключением сторонних реп. Вроде как сам виноват.

kirill_rrr ★★★★★ ()
Ответ на: комментарий от Pavval

Смешивать версии репозитариев не всегда хорошо кончается. И почти всегда сложно и вручную разруливать зависимости.

kirill_rrr ★★★★★ ()

Сижу на testing - иногда прилетают ломающие баги.
Так что советую stable + backports.

Deleted ()

Достаточно использовать Fedora совершенно любой нормальный дистрибутив, вместо серверного убожества Debian Stable или пародии на fedora (только с куда меньше пользовательской базой и концентрацией специалистов, вот ведь засада) Debian Unstable, чтобы избежать всех проблем. Ну или возьми максимально свежее ядро и оставайся на стейбле, коли такой неадекват.

anonymous ()

Свежее ведро и иксовый драйвер для скайлейка есть в backports. К чему все эти сложности?

Polugnom ★★★★★ ()

А теперь объясни, нафейхоа тебе ради одного ядра менять версию дистра. Поставь ядро+фирмварь и дрова (если внешние) от Unstable и продолжай сидеть на Stable.

+ собирай через make-kpkg, будь ласкав.

darkenshvein ★★★★★ ()

Сижу на sid. Ноут использую для дома и работы. Всё норми.

Один раз только при переезде на systemd немного сломалось, но легко починил.

anonymous ()
Ответ на: комментарий от alozovskoy

Сижу на sid уже, наверно, год, проблем никаких ни разу не встречал.

Буквально на прошлой неделе в Debian обновили NetworkManager до версии 1.4 и перестал работать wi-fi https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=835922 по ссылке приводится work around для этой проблемы.

А несколько месяцев назад в Debian Sid добавили только часть пакетов от Cinnamon 3, в результате после обновления часть пакетов Cinnamon оказалась третьей версии, а часть второй, а они между собой несовместимы так что невозможно было залогиниться в DE, недостающие пакеты от третьей версии Cinnamon пришли в Sid только через неделю.

anonymous ()
Ответ на: комментарий от anonymous

NetworkManager

Не пользуюсь этой поделкой

добавили только часть пакетов от Cinnamon 3

Вот кстати ловил как-то раз подобную проблему при установке пакета, но после apt-get update все поставилось без проблем - видно я просто не попал на тот период, пока оно было сломано. Но это разовый случай, да и зависит от того как часто обновляешься, так что не стал учитывать.

alozovskoy ★★★★★ ()
Ответ на: комментарий от alozovskoy

Не пользуюсь этой поделкой

Поделкой? Вообще-то это стандартный системный компонент который используется для настройки и управления сетью в GNOME, KDE и Xfce (вроде только в LXDE используется какой-то кривой костыль на Python вместо NetworkManager), так что баг о котором шла речь выше затронул большинство пользователей Debian Sid.

после apt-get update

Уже давным-давно просто apt update, зачем использовать legacy-команды?

Но это разовый случай, да и зависит от того как часто обновляешься, так что не стал учитывать.

Речь про то что обновления в Debian Sid таковы, что игнорируются возможные проблемы при обновлении группы взаимно зависимых пакетов.

anonymous ()
Ответ на: комментарий от anonymous

Так никто и не обещал что «сломанная» ветка не будет ломаться. Я хотел сказать что на десктопе в целом каких-то проблем мне это не приносит.

Касаемо NM - кривой костыль на python работает гораздо лучше, чем NM, а опыт с ним у меня был и в убунте, и в Debian, и немного даже в Fedora. По-этому уже долгое время я везде использую только wicd.

alozovskoy ★★★★★ ()
Ответ на: комментарий от kirill_rrr

Смешивать версии репозитариев не всегда хорошо кончается. И почти всегда сложно и вручную разруливать зависимости.

В случае с ядром все достаточно беспроблемно. Но backports лучше.

Pavval ★★★★★ ()
Ответ на: комментарий от alozovskoy

Такой разовый случай в сиде по жизни, из-за чего использование его является русской рулеткой. Я тоже сидел на нем пару лет, когда мне пытались объяснить, что сид не зря называется сид, и работать вообще не обязан, я смеялся. Пока не досмеялся до полностью нерабочей разваленной системы, не подлежащей восстановлению аптом. Лучше поставить намного более стабильный и безглючный арч.

curufinwe ★★★★★ ()
Ответ на: комментарий от curufinwe

Я тоже сидел на нем пару лет, когда мне пытались объяснить, что сид не зря называется сид, и работать вообще не обязан

Sidux/Aptosid?

dhameoelin ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.