LINUX.ORG.RU

XScreensaver пишет что старая версия

 


0

1

при каждом входе в систему выскакивает сообщение:

Warning. xscreensaver very old и ссылка на сайт

я удалил командой apt-get remove xscreensaver а потом установил apt-get install xscreensaver но опять то сообщение.

удали опять. хочу другую прогу длч скринсейвера, но не знаю какая умеет также блокировать экран по кнопке на панели ЛХДЕ. мне надо для защиты данных по нажатию этой кнопки на экране блокировать экран.

★★

Ответ на: комментарий от Avial

спасибо, буду пробовать.

debian 8.3 и debian 8.4, причем на двух компьютерах сегодня начал сообщать.

znavko ★★ ()

Xscreensaver выводит это сообщение по прошествии определённого времени с выхода версии. В принципе, оно безвредно. Поэтому есть следующие варианты:

1. Смириться и забить. 2. Накатать в багтрекер Дебиана просьбу выпилить это предупреждение и/или обновить пакет.

anonymous ()

Автор XScreenSaver задолбался:

Bool
senescent_p (void)
{
  /* If you are in here because you're planning on disabling this warning
     before redistributing my software, please don't.

     I sincerely request that you do one of the following:

         1: leave this code intact and this warning in place, -OR-

         2: Remove xscreensaver from your distribution.

     I would seriously prefer that you not distribute my software at all
     than that you distribute one version and then never update it for
     years.

     I am *constantly* getting email from users reporting bugs that have
     been fixed for literally years who have no idea that the software
     they are running is years out of date.  Yes, it would be great if we
     lived in the ideal world where people checked that they were running
     the latest release before they report a bug, but we don't.  To most
     people, "running the latest release" is synonymous with "running the
     latest release that my distro packages for me."

     When they even bother to tell me what version they're running, I
     say, "That version is three years old!", and they say "But this is
     the latest version my distro ships".  Then I say, "your distro
     sucks", and they say "but I don't know how to compile from source,
     herp derp I eat paste", and *everybody* goes away unhappy.

     It wastes an enormous amount of my time, and kind of makes me regret
     ever having released this software in the first place.

     So seriously. I ask that if you're planning on disabling this
     obsolescence warning, that you instead just remove xscreensaver from
     your distro entirely.  Everybody will be happier that way.  Check
     out gnome-screensaver instead, I understand it's really nice.

     Of course, my license allows you to ignore me and do whatever the
     fuck you want, but as the author, I hope you will have the common
     courtesy of complying with my request.

     Thank you!

     jwz, 2014
  */
  time_t now = time ((time_t *) 0);				/*   N   */
  struct tm *tm = localtime (&now);				/*   o   */
  const char *s = screensaver_id;				/*       */
  char mon[4], year[5];						/*   d   */
  int m, y, months;						/*   o   */
  s = strchr (s, ' '); if (!s) abort(); s++;			/*   n   */
  s = strchr (s, '('); if (!s) abort(); s++;			/*   '   */
  s = strchr (s, '-'); if (!s) abort(); s++;			/*   t   */
  strncpy (mon, s, 3);						/*       */
  mon[3] = 0;							/*   d   */
  s = strchr (s, '-'); if (!s) abort(); s++;			/*   o   */
  strncpy (year, s, 4);						/*       */
  year[4] = 0;							/*   i   */
  y = atoi (year);						/*   t   */
  if      (!strcmp(mon, "Jan")) m = 0;				/*   ,   */
  else if (!strcmp(mon, "Feb")) m = 1;				/*       */
  else if (!strcmp(mon, "Mar")) m = 2;				/*   s   */
  else if (!strcmp(mon, "Apr")) m = 3;				/*   t   */
  else if (!strcmp(mon, "May")) m = 4;				/*   o   */
  else if (!strcmp(mon, "Jun")) m = 5;				/*   p   */
  else if (!strcmp(mon, "Jul")) m = 6;				/*   ,   */
  else if (!strcmp(mon, "Aug")) m = 7;				/*       */
  else if (!strcmp(mon, "Sep")) m = 8;				/*   s   */
  else if (!strcmp(mon, "Oct")) m = 9;				/*   t   */
  else if (!strcmp(mon, "Nov")) m = 10;				/*   a   */
  else if (!strcmp(mon, "Dec")) m = 11;				/*   a   */
  else abort();							/*   a   */
  months = ((((tm->tm_year + 1900) * 12) + tm->tm_mon) -	/*   h   */
            (y * 12 + m));					/*   h   */
							  	/*   h   */
  return (months > 18);						/*   p   */
}

i-rinat ★★★★★ ()

Можешь воспользоваться моим ppa для xscreensaver. Я его периодически обновляю, как новая версия выходит. Правда я в последную сборку забыл патч для того, чтобы переключение пользователей работало (по дефолту оно вообще отключено) добавить, добавлю уже когда новая версия выйдет.
Если нужно, то просто добавь, в конфиг для нужных юзеров (это для lightdm).

newLoginCommand:	dm-tool switch-to-greeter

anonymous_sama ★★★★★ ()
Последнее исправление: anonymous_sama (всего исправлений: 1)
Ответ на: комментарий от anonymous_sama

А здесь ( https://packages.debian.org/sid/amd64/xscreensaver/download ) написано, что если добавить в сорс.лист репозиторий, то вроде как должна устанавливаться последняя версия, я добавил как там написано, заменил сервер на тот, который у меня был в сорс лист: http.us. В результате даже после удаления пакета и повторной установки ставится древняя версия 5.30. Взял руками скачал 5.32, через dpkg установил, вроде работает.

sergvg ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.