LINUX.ORG.RU

мерзкого бага в dolphin'е

aka “New Folder”?

Stil ★★★★★ ()

мерзкого бага в dolphin'е

Что за бага?

По сабжу: там же не весь софт приготовили на Qt5. Или уже весь? KF вкусно выглядит, но на деле ещё не готов для повседневного юзания, ящитаю.

// Не пользователь кед, но иногда тыкаю.

r3lgar ★★★★★ ()
Ответ на: комментарий от r3lgar

kde-apps/kdialog, kde-apps/kgpg, kde-apps/ksnapshot, kde-apps/okular, kde-apps/plasma-apps из ::5 все ещё зависят от qt4.

init_6 ★★★★★ ()
Ответ на: комментарий от init_6

все ещё зависят от qt4

А нафига? Что, Qt5 до сих пор не готов?

r3lgar ★★★★★ ()
Ответ на: комментарий от r3lgar

А нафига?

При чем здесь готов он или нет к портированию?

init_6 ★★★★★ ()
Ответ на: комментарий от init_6

Так, погоди. Начнём с того, что я тыкал KF достаточно давно (полгода назад, плюс-минус), и немного не в теме. kde-apps/*:5 вроде как готовят на Qt5 (пятоплазма и компания на пятокутях → софт на них же), соответственно биндить их же в Qt4 нет резона. Или я что-то пропустил в твоём комменте, и оно до сих пор с Qt4 написано? И с багой в долфине тоже неясность: что за бага-то?

r3lgar ★★★★★ ()
Ответ на: комментарий от r3lgar

kde-apps/*:5 вроде как готовят на Qt5

Так «вроде как» или сперва сам проверишь хотя-бы то что я назвал выше?

init_6 ★★★★★ ()
Ответ на: комментарий от r3lgar

Оно до сих пор написано с Qt3 Qt3 Qt3. Но с qt5-only вполне можно жить кстати. Практически никаких неудобств, пришлось только выкинуть амарок окуляр кдевелоп и остальные 2/3 софта. А баг в дельфине из-за локалей насколько я помню. Любители локализации должны страдать.

anonymous ()
Ответ на: комментарий от init_6

Я уже пояснил, почему я задаю такой тупой вопрос. Проверю, когда будет нужда тыкать пятокеды, сейчас у меня нет возможности и желания, но хочется быть в курсе.

r3lgar ★★★★★ ()
Ответ на: комментарий от anonymous

Но с qt5-only вполне можно жить кстати.

Можно было бы, если бы хоть одно DE полноценно юзало его, без нужды тащить другие тулкиты. KDE4 радовало именно этим, KF5 в этом плане ещё не готово. Я не тулкитофоб, просто хочется гармонии.

Практически никаких неудобств, пришлось только выкинуть [...] остальные 2/3 софта

То есть с Qt5 в KF5 совсем печально.

Любители локализации должны страдать.

Многие юзеры не согласятся, особенно те, у кого знаний английского вообще нет (причём этот список не ограничен школьниками, пенсионерами и домохозяйками, есть ещё те, кто в школе учил немецкий/французский). Для себя не вижу смысла в локализации, но юзеры жалуются.

r3lgar ★★★★★ ()
Ответ на: комментарий от r3lgar

другие тулкиты

Ну почему, всё гораздо лучше чем год назад. Тут даже почти весь десктопный софт уже портировали. DE более чем полноценно только с qt5, хотя я не вижу почему нельзя использовать софт на gtk2, тем более что визуально он не особо отличается и всегда можно USE='-introspection'. Совершенно никаких неудобств от файрфокса или пиджина не испытываю.

anonymous ()

Вот те на, только закончил компилять 4.14.3...

iVS ★★★★★ ()

kde стабилизировал я, тестировал тоже я, и УМВР

Zlogene ()
Ответ на: комментарий от r3lgar

Что за бага?

Мне вот тоже интересно. Правда, Dolphin у меня 15.12.2, и вообще, у меня суся 42.1, но интересно.

IceWindDale ()

Внезапно, прилетело обновление приложений kde с 4.14.x до 15.08.

В генте до сих пор KDE4? Рад за гентушников, честно.

Значит ли это, что пора обновлять кеды до (мерзкого бага в dolphin'е) KF?

Нет, в опенсусю 13.2 прилетал массивный апдейт этих приложений, но KF5 не требовался. Вообще, они вполне себе даже Qt5 в зависимостях не имели, по идее, эта версия должна уметь жить без Qt5, до поры-до времени и ты сможешь. И что за баг в Dolphin?

Или скоро KF сам попадет в стабильное дерево?

Однозначно попадёт. Скоро или нет — не известно. Скорее всего, так же, как и КДЕ4 в своё время. Хотя вон в кальке и сабайоне вроде уже.

IceWindDale ()
Ответ на: комментарий от init_6

ksnapshot

его же деприкейтнули и заменили на spectacle, который уже на qt5

f1u77y ★★★ ()

судя по заверениям kde team, скоро KF будет штабилен

Zlogene ()
Ответ на: комментарий от f1u77y

его же деприкейтнули и заменили на spectacle, который уже на qt5

grep kde4 -R * в оверлее kde даст ещё кучу примеров.

init_6 ★★★★★ ()
Ответ на: комментарий от fang90

Вполне возможно, что это нечто дистроспецифичное.

В любом случае, для 15.08 KF5 не нужен, и Qt5 тоже. C KDE4 соберётся без проблем. А вот для 15.12 и новее, вполне возможно, потребуется KF5. А может, и они соберутся на Qt4.

IceWindDale ()

А почему на этой фигне до сих пор глоток свежего воздуха когда заводишь свежего юзера? Как в винде, блин

TooPar ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.