LINUX.ORG.RU

[SOLVED] Проблемы с разрешением экрана на ноуте

 , ,


0

2

Привет, камрады! Опять нужна ваша помощь. Вчера гуглил до 2 ночи, но так и не решил проблему.

Случайно заметил, что после ребута разрешение экрана на лэптопе сбрасывается на 1360х768, а должно быть 1366x768. Данный баг(?) наблюдается только на intel карте, когда я подрубаю дискретку (nvidia), все путём, разрешение 1366x768.

Вот что в /var/log/Xorg.0.log после ребута на интеле:

[    37.365] (II) intel(0): Modeline "1366x768"x0.0   70.00  1366 1402 1450 1492  768 771 776 782 -hsync -vsync (46.9 kHz eP)
[    37.764] (II) intel(0): resizing framebuffer to 8x8
[    37.767] (II) intel(0): resizing framebuffer to 1360x768
[    37.767] (II) intel(0): switch to mode 1360x768@59.8 on LVDS1 using pipe 0, position (0, 0), rotation normal, reflection none

Как видно из лога, что-то меняет в последний момент разрешение экрана на 1360х768, что это может быть? Если через xrandr или штатную утилиту xfce выставлю нужное разрешение экрана, то оно держится только до ребута.

Вот лого после того, как исправлю разрешение:

[    37.308] (II) This device may have been added with another device file.
[    37.364] (II) intel(0): EDID vendor "LGD", prod id 732
[    37.365] (II) intel(0): Printing DDC gathered Modelines:
[    37.365] (II) intel(0): Modeline "1366x768"x0.0   70.00  1366 1402 1450 1492  768 771 776 782 -hsync -vsync (46.9 kHz eP)
[    37.764] (II) intel(0): resizing framebuffer to 8x8
[    37.767] (II) intel(0): resizing framebuffer to 1360x768
[    37.767] (II) intel(0): switch to mode 1360x768@59.8 on LVDS1 using pipe 0, position (0, 0), rotation normal, reflection none
[   683.535] (II) intel(0): resizing framebuffer to 1366x768
[   683.545] (II) intel(0): switch to mode 1366x768@60.0 on LVDS1 using pipe 0, position (0, 0), rotation normal, reflection none

Вывод xrandr:

sality@laptop:~$ xrandr -q
Screen 0: minimum 8 x 8, current 1366 x 768, maximum 32767 x 32767
LVDS1 connected 1366x768+0+0 (normal left inverted right x axis y axis) 344mm x 194mm
   1366x768      60.00*+
   1360x768      59.80    59.96  
   1280x720      60.00  
   1024x768      60.00  
   1024x576      60.00  
   960x540       60.00  
   800x600       60.32    56.25  
   864x486       60.00  
   640x480       59.94  
   720x405       60.00  
   680x384       60.00  
   640x360       60.00  
DP1 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
VGA1 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

Буду рад любым советам. Уже и не знаю, что делать.

Посмотрел xorg.conf, который использует nvidia, там ничего интересного не нашел.

Совсем забыл, версии пакетов:

X.Org X Server 1.17.2 xubuntu 15.10 nvidia 358 ядро 4.2

P.S Откатился на 355.11 и все заработало.

Ответ на: комментарий от CHIPOK

Определял уже, он же есть на самом деле. Что самое смешное, раньше все было ок, сейчас попробую.

garik_keghen ★★★★★ ()
Ответ на: комментарий от CHIPOK

Способ помог до очередного свитча между картами, потом отвалилось опять. Пока написал маленький скрипт на баше, пускаю его после ребута. Странно это все.

garik_keghen ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.