LINUX.ORG.RU

Debian видеозвонки Skype

 ,


0

2

Всем привет. Имею: Debian 7.9, Skype 4.3. Проблема: При видео звонке не вижу собеседника, хотя меня видят. Странно то, что во время звонка, вместо уменьшенного изображения с моей камеры вижу тоже черный квадрат, хотя при проверке камеры в настройках скайпа все работает. Линукс знаю плохо, потому даже не знаю что гуглить.

Ответ на: комментарий от peregrine

Просто в терминале набрать skype? Ничего не пишет. Или надо запускать с каким-то параметром? В skype --help не вижу ничего для вывода логов работы.

yura881 ()
Ответ на: комментарий от peregrine

В YouTube видео есть, когда залажу в настройки скайпа для тестирования камеры изображение тоже есть. И таки да, ноут старый.:)

yura881 ()
Ответ на: комментарий от peregrine

Это не экзотическая, а очень даже распространенная. Но очень старая.

st4l1k ★★ ()
Ответ на: комментарий от st4l1k

Прочитал ман 2 раза, описания и решения своей проблемы не вижу. Если можно, напишите где вы увидели решение проблемы.

yura881 ()
Ответ на: комментарий от anonymous

Если имелось ввиду

Вопрос: Почему я не могу использовать веб-камеру?

Ответ: Скорее всего вам надо загрузить v4l совместимость.

Попробуйте это:

LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so /usr/bin/skype

то камера у меня работает, но я попробовал - не помогло

yura881 ()
Ответ на: комментарий от yura881

Это печальн, но в таком случае помочь больше нечем. Как вариант можно попробовать запустить от рута или стереть конфиги.

st4l1k ★★ ()
Последнее исправление: st4l1k (всего исправлений: 1)

Тебе скорее всего просто не хватает какой-то 32-ух битной библиотеки (у тебя 64бита или 32?). Все LD_PRELOADы что ты видел - для тех у кого с их камеры не показывает, у тебя обратная проблема. И это нехватка чего-то из библиотек или проблемы с композитингом оконного менеджера на скайпе на твоей видяхе, а может и то и то.

Во первых 32 или 64? Если 64 - то посмотри, каких библиотек не хватает. Ссылка

Во вторых: Какое у тебя окружение, гном, КДЕ, ещё что-то, пользуешься ли ты композитным режимом? На VIA с их Хромом много проблем на линуксе.

Deleted ()
Ответ на: комментарий от maloi
root@Fujitsu:/home/polina# xvinfo
X-Video Extension version 2.2
screen #0
  Adaptor #0: "XV_SWOV"
    number of ports: 1
    port base: 62
    operations supported: PutImage
    supported visuals:
      depth 24, visualID 0x21
    number of attributes: 6
      "XV_COLORKEY" (range 0 to 16777215)
              client settable attribute
              client gettable attribute (current value is 2081)
      "XV_BRIGHTNESS" (range 0 to 10000)
              client settable attribute
              client gettable attribute (current value is 5000)
      "XV_CONTRAST" (range 0 to 20000)
              client settable attribute
              client gettable attribute (current value is 10000)
      "XV_SATURATION" (range 0 to 20000)
              client settable attribute
              client gettable attribute (current value is 10000)
      "XV_HUE" (range -180 to 180)
              client settable attribute
              client gettable attribute (current value is 0)
      "XV_AUTOPAINT_COLORKEY" (range 0 to 1)
              client settable attribute
              client gettable attribute (current value is 1)
    maximum XvImage size: 1920 x 1200
    Number of image formats: 7
      id: 0x32595559 (YUY2)
        guid: 59555932-0000-0010-8000-00aa00389b71
        bits per pixel: 16
        number of planes: 1
        type: YUV (packed)
      id: 0x32315659 (YV12)
        guid: 59563132-0000-0010-8000-00aa00389b71
        bits per pixel: 12
        number of planes: 3
        type: YUV (planar)
      id: 0x30323449 (I420)
        guid: 49343230-0000-0010-8000-00aa00389b71
        bits per pixel: 12
        number of planes: 3
        type: YUV (planar)
      id: 0x434d5658 (XVMC)
        guid: 56494100-0000-0010-8000-00aa00389b71
        bits per pixel: 12
        number of planes: 1
        type: YUV (planar)
      id: 0x35315652 (RV15)
        guid: 52563135-0000-0000-0000-000000000000
        bits per pixel: 16
        number of planes: 1
        type: RGB (packed)
        depth: 15
        red, green, blue masks: 0x7c00, 0x3e0, 0x1f
      id: 0x36315652 (RV16)
        guid: 52563136-0000-0000-0000-000000000000
        bits per pixel: 16
        number of planes: 1
        type: RGB (packed)
        depth: 16
        red, green, blue masks: 0xf800, 0x7e0, 0x1f
      id: 0x32335652 (RV32)
        guid: 52563332-0000-0000-0000-000000000000
        bits per pixel: 32
        number of planes: 1
        type: RGB (packed)
        depth: 24
        red, green, blue masks: 0xff0000, 0xff00, 0xff

yura881 ()
Ответ на: комментарий от yura881

А, значит опенбокс и никаких композитов. Значит проблема именно в видеодровах. А покажи-ка вывод /var/log/Xorg.o.log

А когда ставил, были проблемы с графическим режимом? Пришлось ручками grub править? или просто всё встало и работает?

Deleted ()
Ответ на: комментарий от Deleted

вывод /var/log/Xorg.o.log - No such file or directory
Сначала поставил 8.2 и были страшные глюки. Вернулся на 7.9 - поставилось все хорошо. Конфиги не правил. Скриншот глюков надо?

yura881 ()
Ответ на: комментарий от yura881

А глюки и так понятны :) тут вопрос больше в том, что у тебя вместо драйвера :)

Deleted ()
Ответ на: комментарий от Sora

Юзай веб версию скайпа.

там нет видеозвонков в линуксе

CHIPOK ★★★ ()
Ответ на: комментарий от Sora

Ну хз. Я не знаю, насколько просто это реализовать даже если отбросить усложнения протокола скайпа как такового

Deleted ()
Ответ на: комментарий от yura881

Так. Я пописить ходил :)

Хм, я посмотрел твой лог. Ничего такого страшного не вижу, а компы с VIA на работе, нет возможности посмотреть. Так. Ты уверен, что никакой compton не запущен? Или Cairo-dock? Что там ещё использует композитинг... не помню.

Короче, это проблема с композитингом. Я просто уверен на 180%. Но я не гуру, может я тебе тут просто мозг парю :) Советы что я помню, да и теперь всессылки на них - запускать скайптак:

export XLIB_SKIP_ARGB_VISUALS=1 && skype

Но, в опенбоксе (который за оконный менеджер в LXDE) нет композитинга. Тут три выхода:

  • у тебя запущен compton, тогда веше указанная команда должна помочь.
  • Включить композитинг, может скайповцы решая проблему с композитингом и теперь у тебя проблемы, особенно с учётом видяхи, которая не умеет нормально работать. Тогда установи и запусти compton, посмотри, исправит ли?
  • Это проблема с драйверами, тем как реализована поддержка видео на твоей Хро́мине. Тут я не знаю что делать. Тут мои скудные познания вообще заканчиваются.

П.С. Не выкладывай во всякие уандрайвы. Выкладывай на pastebin.com, а сюда ссылочку.

Deleted ()
Ответ на: комментарий от yura881

ну... не знаю. Так ты делал скайпу ldd, как я в ссылке давал, что показывает?

И ещё: скайп как ставил?

Deleted ()
Ответ на: комментарий от Deleted

ldd: http://pastebin.com/vmpvjApC
Устанавливал раза 3 разными способами. Точно помню что скачал файл и установил через GUI. Через консоль:

# apt-get install gdebi
# wget -O skype-install.deb http://www.skype.com/go/getskype-linux-deb
# gdebi skype-install.deb
И ещё как-то через консоль

yura881 ()
Ответ на: комментарий от yura881

Блин, вроде всё что нужно.

Погоди.

А это не поможет?

Там пишут про возможные проблемы с EXA. Тебе придётся попробовать XAA Пиощи в дебьяновских мануалах, как настраивать Xorg, куда добавлять Вот тебе ещё сылка почитай.

А ещё там про поддержку кодеков пишут, тоже почитай.

Deleted ()
Последнее исправление: Chelobaka (всего исправлений: 1)
Ответ на: комментарий от yura881

И ещё, судя по твоим логам у тебя композитинг отключен.

EXA composite acceleration disabled

У тебя хоть что-то поменялось, когда xcompmgr запустил? походу он не работает? Или работает? В опенхромеже и про композитинг есть.

Deleted ()
Последнее исправление: Chelobaka (всего исправлений: 1)
Ответ на: комментарий от yura881

Логи Xorg. У тебя, судя по всему, отключен композитный режим в самом Хсервере. В инструкции опенхрома (твоего драйвера) говорится, что его включить надо. Поэтому ты и не увидел разницы. С xcompmgr должны были появиться тени вокруг окон. Попробуй сделать как там описано. Только я не знаю, где лежат конфиги Xorg утебя. Тут ты уж сам поищи, почитай мануалы. Они могут быть в /etc/X11/Xorg.conf /etx/X11/Xorg.conf.d или /usr/share/X11/дге-то. Но помни - они не любят ошибок, одна ошибка в синтаксисе - графический режим не включится вообще. Надо понимать, что делаешь. Советую установить mc, если сделаешь ошибку и останется одна консоль, логинься от рута и запускай mc и ищи тот файл, что испортил.

И в любом случае, эти видяхи - говно в принципе, а в линуксе так вообще. Что VIA, что Sis.

Deleted ()
Ответ на: комментарий от Deleted

Я сам сижу на вин10, а ковыряю debian через ssh. Так что если GUI не запустится, я разницы почти не замечу:) Попробую что-то сделать по твоих советах, если выйдет - напишу результат.

yura881 ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.