LINUX.ORG.RU

Debian7->8

 ,


0

2

Всем привет. Суть вопроса такова: был Дебиан 6 потом Дебиан 7 обновление прошло хорошо, вот теперь Дебиан 7 на Дебиан 8, возникла проблема

Предварительная настройка пакетов ...
(Чтение базы данных … на данный момент установлено 120657 файлов и каталогов.)
Подготовка к распаковке …/libck-connector0_0.4.6-5_i386.deb …
Распаковывается libck-connector0:i386 (0.4.6-5) на замену (0.4.5-3.1) …
Подготовка к распаковке …/udev_215-17+deb8u2_i386.deb …
Since release 198, udev requires support for the following features in
the running kernel:

- inotify(2)            (CONFIG_INOTIFY_USER)
- signalfd(2)           (CONFIG_SIGNALFD)
- accept4(2)
- open_by_handle_at(2)  (CONFIG_FHANDLE)
- timerfd_create(2)     (CONFIG_TIMERFD)
- epoll_create(2)       (CONFIG_EPOLL)

Please upgrade your kernel before or while upgrading udev.

AT YOUR OWN RISK, you can force the installation of this version of udev
WHICH DOES NOT WORK WITH YOUR RUNNING KERNEL AND WILL BREAK YOUR SYSTEM
AT THE NEXT REBOOT by creating the /etc/udev/kernel-upgrade file.
There is always a safer way to upgrade, do not try this unless you
understand what you are doing!


dpkg: ошибка при обработке архива /var/cache/apt/archives/udev_215-17+deb8u2_i386.deb (--unpack):
 подпроцесс новый сценарий pre-installation возвратил код ошибки 1
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/udev_215-17+deb8u2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
вижу что проблема с udev, подскажите как это решить? У кого-то были такие проблемы?

★★★★★

Никак после обновления с 6 до 7 не перезагружался? В 7ке ядро 3.2, где всё перечисленное включено.

redgremlin ★★★★★ ()
Ответ на: комментарий от redgremlin

с 6 на 7 комп проработал долго (годик точно), теперь пришла пора на 8 перейти, и вот такая вот штука получилась

mul4 ★★★★★ ()
Ответ на: комментарий от mul4

Позор моим сединам, ЭТО был единственный комп на котором было ядро 2.6.32, на остальных было 3.2, и я по забывчивости подумал что везде так, почему именно на нем и такое ядро - я не знаю, так получилось. Скачал pf-kernel 4.1 поставил его (dpkg -i), перезагрузил - и перезагрузка идет. И кстати там комп на АМД-К6-2 (500Мгц), 192 оперативки. Так что можете сказать что я извращенец. Посоветуйте ядро что бы 486-586 и по-шустрее).

mul4 ★★★★★ ()
Ответ на: комментарий от mul4

Скачал 3.2.** bpo**- 486, установил, исправил пакеты, все ок. Кто бы мог подумать. Тема решена.

mul4 ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.