LINUX.ORG.RU

Не работает звук, неправильное определение карты.

 , ,


0

1

Доброго всем времени суток.
Вчера пропал звук:

00:01.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Trinity HDMI Audio Controller
00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD] FCH Azalia Controller (rev 01)
Однако, похоже alsamixer считает что у меня карты от intel: Скрин mixer-a
Скорее всего я что то не понял. Пожалуйста, помогите разобраться.
Debian 8 x86_64.

Прям 95-я винда, «Установка оборудования» которой определяла ISA-звук как модем.

ZenitharChampion ★★★★★ ()

Всё правильно показывает. Так и должно быть.

До этого звук работал? Модули snd_hda_intel и snd_hda_intel_hdmi загружены? Если стоит pulseaudio, то через какую карточку звук выводится?

На 8-м дебьяне изредка встречаю ситуацию, когда звук не работает, но альса и пульса рапортуют, что всё ок. Лечится выключением компа (простой ребут не помогает).

anonymous ()
Ответ на: комментарий от anonymous

Тэкс, в модулях это:

snd_hda_codec_idt      48816  1 
snd_hda_codec_generic    63181  1 snd_hda_codec_idt
snd_hda_codec_hdmi     45118  1 
snd_hda_intel          26327  0 
snd_hda_controller     26646  1 snd_hda_intel
snd_hda_codec         104463  5 snd_hda_codec_hdmi,snd_hda_codec_idt,snd_hda_codec_generic,snd_hda_intel,snd_hda_controller
snd_hwdep              13148  1 snd_hda_codec
snd_pcm                88662  4 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel,snd_hda_controller
snd_timer              26614  1 snd_pcm
snd                    65244  8 snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_hda_codec_idt,snd_pcm,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel
soundcore              13026  2 snd,snd_hda_codec
В PulseAudio не смог. Оно вроде поставилось, но что с ним делать я не знаю. Команда pulseaudio говорит что нет запущенного сервера. Перезагрузка и выключение не помогли.

seidakey ()
Ответ на: комментарий от seidakey

О PulsAudio:

$ pulseaudio --start
E: [autospawn] core-util.c: Failed to create secure directory (/run/user/1000/pulse): Отказано в доступе
W: [autospawn] lock-autospawn.c: Не удалось получить доступ к блокировке, используемой для запуска сервера по требованию.
E: [pulseaudio] main.c: Failed to acquire autospawn lock

# pulseaudio --start
W: [pulseaudio] main.c: Эта программа не предназначена для запуска с привилегиями администратора (кроме случая, когда указан ключ «--system»).

$ pulseaudio
E: [pulseaudio] core-util.c: Failed to create secure directory (/run/user/1000/pulse): Отказано в доступе

# pulseaudio
W: [pulseaudio] main.c: Эта программа не предназначена для запуска с привилегиями администратора (кроме случая, когда указан ключ «--system»).
E: [pulseaudio] pid.c: Daemon already running.
E: [pulseaudio] main.c: Произошла ошибка при выполнении pa_pid_file_create().[/cut]
seidakey ()
Ответ на: комментарий от seidakey

Звук настроил, не хватало gstreamer-a. Но всё же, почему звука не было с простой alsa?

seidakey ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.