LINUX.ORG.RU

xfce эмулятор терминала добавляет символ 'C' при наборе известной ему команды

 , ,


1

2

Замечено мною в линукс минте, убунте и дебиане (все версии - последние). Везде пользуюсь xfce DE.

python - pythCCon
locate - locaCtCel
create - creaCCte

Например, при наборе команды 'python', когда печатаю символ 'h', в строке добавдяется 'CCon', причём курсор встаёт на 'o'. Я понимаю, что это кривая автоподстановка, но где и как её отключить - не знаю. Жутко бесит, услужливый дурак - хуже врага.

В линуксе я новичок, хелп, плз.

Я сам фанат XFCE. И во всех выше названных дистрибутивах такое проблемы не наблюдаю. Быть может ты где накуролесил?

ToaDron ()
Ответ на: комментарий от ToaDron

Сомневаюсь. Я не настолько хорош. )) Замечено мною в минте, убунте и дебиане на двух ПК. Поиск вообще не знает о такой проблеме, или я не могу правильно подобрать ключевые слова. Вот единственное упоминание, подвтерждающее, что я не совсем одинок: http://www.askdev.ru/question/21138/не-правльный-ввод-символов-в-эмуляторе-те...

ssadfaf ()

как это он добавляет? по табу что ли?

amorpher ★★★★★ ()

Это только в терминале проявляется? Клавиатура исправна?

vladimir_putin ()
Ответ на: комментарий от amorpher

В том-то и дело, что во время набора текста, я ж не идиот. В моём примере с 'python' происходит при нажатии клавиши 'h'.

ssadfaf ()
Ответ на: комментарий от vladimir_putin

Да, это происходит только в терминале. Клавиатура исправна, более того, на двух компах разные клавы.

ssadfaf ()
Ответ на: комментарий от ssadfaf

Ну в терминале можно открыть комбинации клавишь и посмотреть что за комбинация на h установлена.

vladimir_putin ()
Ответ на: комментарий от ssadfaf

В том-то и дело, что во время набора текста, я ж не идиот. В моём примере с 'python' происходит при нажатии клавиши 'h'.

у меня при нажатии клавиши 'h' печатается 'h'

у тебя видимо хомяк 1 на всё?

amorpher ★★★★★ ()
Последнее исправление: amorpher (всего исправлений: 1)

посмотри в настройках Xfce привязку клавиш

amorpher ★★★★★ ()
Ответ на: комментарий от vladimir_putin

Да 'h' - это только в 'python'. Когда я печатаю 'local', он реагирует так же на 'а' и получается locaCl.

ssadfaf ()

Короче, терминал так реагирует, когда он думает, что угадал, какое слово я имею ввиду.
Если я набираю 'command', он на второй 'm' так же реагирует и добавляет 'CCCand' и получается 'commCCCand', курсор встаёт на 'a'. А букв 'C' он добавляет столько, сколько символов в автозавершении.

ssadfaf ()

в не vte-based терминалах баг сохраняется? xterm

arrecck ★★ ()
Ответ на: комментарий от arrecck

Опаньки! В xterm'e вообще текст не набирается! Он вообще на клаву никак не реагирует.

ssadfaf ()
Ответ на: комментарий от arrecck

Поправка: xterm'e всё работает. А что такое tty? Если это та консоль, которая при выборе OS при загрузке, то там всё ОК.

ssadfaf ()

Разобрался! Спасибо всем,особенно arrecck, который подвёл меня к ответу!

Виной всему было, конечно же, не прекрасное xfce, используемое во всех осях на всех компах, а Xneur, также присутствующая везде. ))

Решение: В Preferences >> Autocompletion добавил Xfce4-terminal в исключения и всё стало путём.

P.S.: Xneur использую неактивным, без автопереключения, но он хорош для исправления раскладки уже набранного текста (У меня - кнопка 'Pause' для последнего набранного слова и 'Shift'+'Pause' для выделенного текста). А про автодополнение я вот забыл. ))

ssadfaf ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.