LINUX.ORG.RU

У кого-нибудь получилось скомплилировать?


0

0

.. субж: DrDivx или
http://www.linux.org.ru/view-message.jsp?msgid=1181369

Выдается ошибка при компиляции:
make[3]: Entering directory `/home/star/installers/drdivx2-2.0.0-b1/drdivx2/src/property'
if g++ -DHAVE_CONFIG_H -I. -I. -I../.. -I../../include -I/usr/local/include -I/usr/local/include/libxml2 -march=pentium4 -O3 -MT OpaqueProperty.o -MD -MP -MF ".deps/OpaqueProperty.Tpo" -c -o OpaqueProperty.o OpaqueProperty.cpp; \
then mv -f ".deps/OpaqueProperty.Tpo" ".deps/OpaqueProperty.Po"; else rm -f ".deps/OpaqueProperty.Tpo"; exit 1; fi
OpaqueProperty.cpp: In member function 'virtual ErrorCode OpaqueProperty::GetValue(std::string&)':
OpaqueProperty.cpp:79: error: 'itoa' was not declared in this scope
make[3]: *** [OpaqueProperty.o] Error 1
make[3]: Leaving directory `/home/star/installers/drdivx2-2.0.0-b1/drdivx2/src/property'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/star/installers/drdivx2-2.0.0-b1/drdivx2/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/star/installers/drdivx2-2.0.0-b1/drdivx2'
make: *** [all] Error 2

Спасибо за ответы.

anonymous

Re: У кого-нибудь получилось скомплилировать?

nА ты сильно расстроишься если узнаешь что это виндовые сорцы?

iRunix ★★★★ ()

Re: У кого-нибудь получилось скомплилировать?

Не расстроюсь, потому что сорцы линуховые, вот отсюда брал: http://prdownloads.sourceforge.net/drdivx/drdivx2-2.0.0-b1.tar.bz2?download

Так будут дельные советы? Кто-нибудь вообще уже поставил себе линуховый DrDivx?

Первый анонимус.

anonymous ()

Re: У кого-нибудь получилось скомплилировать?

В смысле "еще один"? gcc --version gcc (GCC) 4.0.2 20050901 (prerelease) (SUSE Linux)

Всё (autoconf, automake, и т.д.) стандартное из SuSE 10.0, кроме ffmpeg, поставил сам из сорцов.

Делал всё, как было написано в INSTALL. Кстати, в нем же (INSTALL) никакого намека на версии компайлера.

Главное, все команды вплоть до make выполнились корректно, без ошибок. Как дальше?

Первый анонимус.

anonymous ()

Re: У кого-нибудь получилось скомплилировать?

Я пробовал собирать с помощью 4.0.2, даже собиралось, но не всегда работало, поэтому использую родной 3.3.4 (Slackware 10)!
Попробуй поставь 3.3.x!

UVV ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.