LINUX.ORG.RU

Пусто на TTY в Debian Jessie после установки драйверов nvidia

 , , ,


0

2

Debian 8.1, systemd, проприетарные драйвера nvidia. При переключении на tty экран гаснет и уходит в спячку (как когда компьютер вообще выключен, т.е нет сигнала). При возвращении на tty7, где иксы, всё опять начинает работать. Такое поведение появилось после установки проприетарных драйверов nvidia из репозитория. Подскажите, пожалуйста, как лечить (кроме удаления nvidia, systemd, Debian). Заранее спасибо.

★★

Откати дрова на более старую версию, наблюдаю такое уже пару лет. Совершенно точно лечилось откатом блоба на предыдущую версию.

wakuwaku ★★★★ ()
Ответ на: комментарий от wakuwaku

Мне помогла установка nomodeset в параметрах ядра. Попробуй.

Кстати, из-за чего такая проблема и что меняет nomodeset?

Valdor ★★ ()
Ответ на: комментарий от Valdor

Это KMS. Надо попробовать, чем чёрт не шутит. Хотя никаких свободных дров в системе нет, и блоб вполне работает в консоли, до запуска иксов (однако, разрешение экрана можно менять только через vga=, video= и остальное не работает. очень мыльно)

wakuwaku ★★★★ ()
Ответ на: комментарий от anonymous

То есть, если я его выпилю из системы, то nomodeset вообще не потребуется?

Valdor ★★ ()
Ответ на: комментарий от Valdor

Насколько я знаю, через vga нельзя выставить разрешение WUXGA, только UXGA или около того. Во всяком случае, гуглится только такая табличка и везде напоминания о том, что это жуткое deprecated и вообще работать не будет.

wakuwaku ★★★★ ()
Ответ на: комментарий от anonymous

Хм, а я о чём? И разве отключает? Раньше вроде открытый драйвер работал лучше без KMS. Что интел, что ати, что нуво.

wakuwaku ★★★★ ()
Ответ на: комментарий от wakuwaku

раньше это лет пять назад. сейчас не работает

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.