LINUX.ORG.RU

Ubuntu 15.04 console font setup

 , ,


0

1

Кто-нибудь уже менял шрифт в консоли, чтобы тот применялся после загрузки? Из-за этого винегрета из systemd и upstart понять не могу что вообще его должно загружать. После start/restart скрипта из /etc/init.d/console-setup ничего не происходит, ровно так же, как и после перезапуска systemd-vconsole-setup. На всякий случай добавил /etc/vconsole.conf с параметром FONT. Не помогло. Модуль видеокарты загружен(radeon).


добавил /etc/vconsole.conf с параметром FONT

Для восьмого дебиана этого достаточно. Новую убунту ещё не трогал, но точно ничего не меняется? systemd-vconsole-setup же просто обёртка вокруг loadkeys и setfont.

redgremlin ★★★★★ ()
Ответ на: комментарий от redgremlin

Содержимое /etc/vconsole.conf:

KEYMAP=us
FONT=Uni2-Terminus12x6
Содержимое systemd-vconsole-setup.service:
# shim unit to satisfy dependencies until Debian/Ubuntu enable systemd-vconsole
[Unit]
Description=Setup Virtual Console
DefaultDependencies=no
Conflicts=shutdown.target
Requires=console-setup.service
ConditionPathExists=/dev/tty0

[Service]
Type=oneshot
RemainAfterExit=yes
ExecStart=/bin/true
При перезапуске ничего не меняется. setfont шрифта из /etc/vconsole.conf устанавливает тот шрифт, который мне нужно

Gi ()
Ответ на: комментарий от Gi

При перезапуске ничего не меняется

ExecStart=/bin/true

Не удивительно :). Читай убунтуфорумы, как оно в убунте устроено. Если я правильно понимаю, то оно должно настраиваться через dpkg-reconfigure console-setup, ибо

Requires=console-setup.service

redgremlin ★★★★★ ()
Ответ на: комментарий от redgremlin

Я так понимаю в нормальном варианте systemd-vconsole-setup должен иметь такое значение в этой строке:

ExecStart=/usr/lib/systemd/systemd-vconsole-setup
? Нагуглить этот скрипт не удалось. Может вы подскажете где взять можно посмотреть? console-setup.service выполняет loadkeys, то есть шрифты он не выставляет, если не ошибаюсь. dpkg-reconfigure console-setup - это первое, что я выполнял

Gi ()

Если setupcon уже вписал, то осталось включить фреймбуфер. Я таки сделал русский в tty. Но вот в recovery квадраты не поборол. А в 14.10 еще все из коробки было хорошо.

anonymous ()

Всем огромное спасибо. Вопрос для меня наконец-то решился. Поправил systemd-vconsole-setup.service:

# shim unit to satisfy dependencies until Debian/Ubuntu enable systemd-vconsole
[Unit]
Description=Setup Virtual Console
DefaultDependencies=no
Conflicts=shutdown.target
#Requires=console-setup.service
ConditionPathExists=/dev/tty0

[Service]
Type=oneshot
RemainAfterExit=yes
ExecStart=/bin/setupcon
console-setup.service закоментировал, чтобы не сносились настройки из /etc/default/keyboard
Внес правки, как и в прежних версиях убунты в файлы /etc/defalt/console-setup и /etc/default/keyboard, добавил модуль видеокарты в /etc/initramfs-tools/modules и пересобрал

Gi ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.