LINUX.ORG.RU

Настройка проводного подключения к сети в Arch Linux

 , ,


0

2

Никак не могу разобраться, как всё-таки в Arch настроить проводное подключение к сети со статическим IP-адресом. Проблемы возникают ещё в самом начале процесса установки, так что я даже не могу загрузить базовую систему.

Сразу скажу, что статью Network configuration в ArchWiki я прочёл целиком и на русском, и на английском, однако же получить нормальное подключение мне так и не удалось.

Я ранее (около 2 месяцев назад) уже успешно устанавливал Arch, и тогда проблем с подключением к сети не возникало, но тогда я подключался через роутер, и получал IP-адресс автоматически по DHCP. Сейчас роутера у меня нет и к сети подключиться не удаётся.

Пытался настроить соединение, используя netctl (использовал пример «ethernet-static»), но при попытке запуска, созданного мной профиля, сообщало об ошибке и предлагало смотреть systemctl_status_netctl@ethernet\x2dstatic.service и journalctl-xe

Что я делаю не так?

Имя интерфейса в конфиге netctl правильно написали?

anonymous ()
Ответ на: комментарий от Qazder

В логе такая строка есть:

Jan 06 15:45:46 archiso systemd[1]: Starting dhcpcd on enp2s0...

На этом интерфейсе уже dhcpcd запущен (наверное инсталлятор сам его запускает)

Попробуй перед запуском netctl сделать

systemctl stop dhcpcd@enp2s0

crowbar ()
Ответ на: комментарий от crowbar

Пробовал вроде. Ничего не изменилось. В логе же есть строка:

Jan 06 15:53:34 archiso systemd[1]: Stopping dhcpcd on enp2s0...

Qazder ()
Ответ на: комментарий от Qazder

Кто-то отломал LORCODE, пишу нечитаемую простыню.

Я не знаю что ты там и как делаешь, но все что тебе нужно было сделать (насколько я помню), это скопировать /etc/netctl/exmaple-static в /etc/netctl/lan (например), подправить этот файл заменив в нем как минимум параметры Interface и Address, добавить получившийся профиль в автозагрузку:
sudo systemctl enable lan@netctl.service
(имя lan взято из моего примера выше) и запустить его:
sudo systemctl start lan@netctl.service
Если у тебя уже каким-то чудом активен профиль example-static, предварительно останови и отключи его (каким-то же образом он загрузился):
sudo systemctl stop example-static@netctl.service && sudo systemctl disable example-static@netctl.service

m0rph ★★★★★ ()
Последнее исправление: m0rph (всего исправлений: 2)
Ответ на: комментарий от m0rph

скопировать /etc/netctl/exmaple-static в /etc/netctl/lan (например), подправить этот файл заменив в нем как минимум параметры Interface и Address

Собственно, я всё так и делал.

Только зачем добавлять в автозагрузку? Проблема проявляется уже на самой начальной стадии установки системы.

Qazder ()
Ответ на: комментарий от Qazder

Да ёшкин кот, опусти этот сраный интерфейс руками. И выруби все эти кривые костыли, коли они оказались кривыми.

Gotf ★★★ ()
Ответ на: комментарий от anonymous

Да, если указать вручную, предварительно отключив dhcp (который сам загружается при запуске), соединение появляется. Но как, всё-таки, настроить соединение, используя netctl?

Qazder ()
Ответ на: комментарий от Qazder

Непонятно, что ему надо. У меня всё проще, настройки во dhcp, поэтому netctl я использовал только после установки, во время не пробовал, может тоже закривлялся бы :)

anonymous ()
Ответ на: комментарий от Qazder

Зачем тебе настраивать netctl для установки? Подними интерфейс вручную, потом настроишь уже на готовой системе.

m0rph ★★★★★ ()
Ответ на: комментарий от m0rph

потом настроишь уже на готовой системе

Поставил я систему, установил KDE, скачал апплет, как рекомендуется на вики, однако создать соединение с его помощью всё равно не выходит. Нажимаю «Добавить», заполняю все поля, жму «OK», но только что созданное соединение просто не появляется в списке соединений.

Qazder ()
Ответ на: комментарий от anonymous

Служба NetworkManager запущена? Всякие netctl и dhcpcd должны быть отключены.

Точно. Спасибо.

Qazder ()

ip route add default via 192.168.1.1

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.