LINUX.ORG.RU

В каком дистре хорошо готовят дрова для WiFi?

 ,


0

1

Есть карточка DWA-525 на чипе RaLink-3092. Единственный дистрибутив который завел и адекватно с ней работал - xubuntu 14.04. Ubuntu 14.04 же внезапно не захотела вообще с сетевушкой дружить. То сетей не видит, то отваливается, то еще что. Эта сетевая - единственный доступ машины в инет.

У кого сетевухи на таком чипсете - каким дистром пользуетесь?

★★★

Попробуй на debian или любом другом просто поставить пакет с нужным драйвером. Можешь в synaptic искать пакет по описанию указав модель или изготовителя устройства.

rezedent12 ☆☆☆ ()
Ответ на: комментарий от rezedent12

Пробовал на бубунту накатить драйвера для линукса с FTP длинка - не взлетело.

liss21 ★★★ ()

Единственный дистрибутив который завел и адекватно с ней работал - xubuntu 14.04. Ubuntu 14.04 же внезапно не захотела вообще с сетевушкой дружить.

если ты уже начал проводить это исследование — то почему бы тебе не выяснить причины того почему так произошло? :-)

думаю для начала тебе lspci -k показала бы какой модуль используется.

затем ты можешь поглядеть в чём различие версий этих модулей в различных дистрибутивах..

user_id_68054 ★★★★★ ()
Ответ на: комментарий от liss21

Пробовал на бубунту накатить драйвера для линукса с FTP длинка - не взлетело.

Ты не понял. Из самого репозитория ставь. Ветка non-free.

rezedent12 ☆☆☆ ()

работал xubuntu 14.04

Ubuntu 14.04 же внезапно не захотела

для тебя шiндошс восьмёрочка

anonymous ()

xubuntu 14.04. Ubuntu 14.04 же внезапно не захотела вообще с сетевушкой дружить.

Что за ***? Там же одно и то же ведро.

Попробуй поставить compat-drivers (https://backports.wiki.kernel.org/index.php/Main_Page), только без инета будет трудновато. И да, у меня такое было (на другом ralink), что прошивку нужно было из официального пакета закинуть в /lib/firmware. Не знаю, нужно ли это сейчас.

te111011010 ()
Ответ на: комментарий от te111011010

У ralink разве non-free?

Точно не знаю. Поищи пакет firmware-ralink

Вот его описание:

This package contains the binary firmware for wireless network cards with
the Ralink RT2501 [Turbo], RT2600, RT5201 [Turbo], RT5600, RT5201USB,
RT2800P[D], RT2700P[D], RT2700E[D], RT2800E[D], RT2800U[D] or RT3000E[D]
chipsets or RT3070/RT3071/RT3072 chips, supported by the rt61/rt61pci,
rt73/rt73usb, rt2860sta, rt2870sta/rt2870, rt3070sta or rt3090sta drivers.

Contents:
 * Ralink RT2561 (RT2501/RT5201 chipset) firmware, version 1.2
   (rt2561.bin)
 * Ralink RT2561S (RT2501 Turbo/RT5201 Turbo chipset) firmware, version
   1.2 (rt2561s.bin)
 * Ralink RT2661 (RT2600/RT5600 chipset) firmware, version 1.2
   (rt2661.bin)
 * Ralink RT2760/RT2790/RT2860/RT2890/RT3090
   (RT2700P[D]/RT2700E[D]/RT2800P[D]/RT2800E[D]/RT3000E[D] chipset)
   firmware, version 34 (rt2860.bin, rt3090.bin)
 * Ralink RT2870/RT3070/RT3071/RT3072 (RT2800U[D] chipset) firmware,
   version 29 (rt2870.bin, rt3070.bin)
 * Ralink RT3071/RT3072 firmware, version 29 (rt3071.bin)
 * Ralink RT3290 firmware, version 1 (rt3290.bin)
 * Ralink RT2571W/RT2671 (RT2501USB/RT5201USB chipset) firmware,
   version 1.8 (rt73.bin)
rezedent12 ☆☆☆ ()
Последнее исправление: rezedent12 (всего исправлений: 1)

Единственный дистрибутив который завел и адекватно с ней работал - xubuntu 14.04. Ubuntu 14.04 же внезапно не захотела вообще с сетевушкой дружить.

А что, если я скажу тебе, что это один и тот же дистрибутив?

Axon ★★★★★ ()
Последнее исправление: Axon (всего исправлений: 2)

В любом, наверное. Я не слышал, чтобы разработчики дистрибутивов принимали участие в разработки драйверов.

Lavos ★★★★★ ()
Ответ на: комментарий от Lavos

не слышал, чтобы разработчики дистрибутивов принимали участие в

разработки драйверов ты не поверишь. фиксы в апстрим шлют на постоянной основе, по крайней мере

anonymous ()


Единственный дистрибутив который завел и адекватно с ней работал - xubuntu 14.04. Ubuntu 14.04 же внезапно не захотела вообще с сетевушкой дружить.


МИСТИКА!

J ★★★★ ()
Ответ на: комментарий от anonymous

в апстрим шлют

Ну тогда точно в любом. Вот если бы только у себя пачтили...

Lavos ★★★★★ ()
Ответ на: комментарий от Lavos

шлют в linux-next, в другом дистрибутиве могут не скопировать/портировать патч на текущее ядро. но это до следующего релиза ядра, да

anonymous ()
Ответ на: комментарий от Axon

Этого не может быть, потому что этого не может быть. Ага. Вот только сей факт имеет место.

liss21 ★★★ ()
Ответ на: комментарий от liss21

Это теоретически возможно только в одном случае: в одном случае был установлен апдейт ядра, а в другом - нет.

Axon ★★★★★ ()
Ответ на: комментарий от Axon

есть ещё один, более вероятный вариант — pebkac

anonymous ()
Ответ на: комментарий от anonymous

На это я и намекал своим первым сообщением.

Axon ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.