LINUX.ORG.RU

Ответ на: комментарий от anonymous

Я конечно дико извиняюсь но на dpms манов много и написаны они непонятным для меня языком. Не могли бы Вы более развернуто прокомментировать мой вопрос?

Заранее спасибо!

iten55 ()
Ответ на: комментарий от iten55

А что за среда в Kali Linux? Разве там не GNOME? Вроде в GNOME свои настройки скринсейверов. Зачем тебе потребовался XScreenSaver?

Disclamer: судя по второму сообщению, ты новичок («они непонятным для меня языком»), поэтому сразу не ясно, правильно ли ты вообще потянулся к XScreenSaver.

UPD: https://wiki.archlinux.org/index.php/XScreenSaver

Zubok ★★★★★ ()
Последнее исправление: Zubok (всего исправлений: 1)
Ответ на: комментарий от Zubok

Да просто хочу скринсэйверов побольше дурь конечно но учиться то надо. Да там гном его скрин я apt-get remove а XSreenSaver я тянул так: apt-get install xscreensaver xscreensaver-gl xscreensaver-gl-extra xscreensaver-data-extra потом его в автозагрузку с командой запуска xscreensaver -nosplash Итог: время приходит заставки черный экран, запускаю XSreenSaber -demo говорит у вас демон не запушен.

iten55 ()
Ответ на: комментарий от iten55

потом его в автозагрузку с командой запуска

Как именно? После старта среды посмотри, есть ли в списке запущенных процессов xscreensaver. Если нет, то ты его неправильно прописал или не туда. Тогда давай больше информации: куда вписал и как именно.

Zubok ★★★★★ ()
Последнее исправление: Zubok (всего исправлений: 1)
Ответ на: комментарий от Zubok

Процесса естественно нет. Вписывал утилитой Приложения - системные - параметры - запускаемые приложения.... Может так и неправильно. Я обычно демонов в /etc/RS.d/ или /etc/init.d/ символической ссылкой пихал. Насколько я понял 1-е это служба а 2-е сервис.

iten55 ()
Ответ на: комментарий от iten55

Тогда давай больше информации: куда вписал и как именно.

Ох, ну все приходится выуживать. :) Покажи, что прописал в автозапуск до буковки.

Zubok ★★★★★ ()
Ответ на: комментарий от iten55

в автозагрузку с командой запуска xscreensaver -nosplash

Ну, во-первых, -no-splash, а не -nosplash. Так по man.

Во-вторых, попробуй с полным путем, то есть

/usr/bin/xscreensaver -no-splash

Если не сработает (то есть в процессах так и не появился), то проверь из терминала, нет ли каких ошибок при запуске:

$ xscreensaver -no-splash &
$ xscreensaver-demo

Сообщи, что получилось. По результатам подумаем.

Zubok ★★★★★ ()
Последнее исправление: Zubok (всего исправлений: 2)
Ответ на: комментарий от iten55
root@i-netbook:~# xscreensaver -no-splash
No protocol specified
xscreensaver: 22:54:27: Can't open display: :0.0
xscreensaver: 22:54:27: initial effective uid/gid was root/root (0/0)
xscreensaver: 22:54:27: running as nobody/nogroup (65534/65534)

xscreensaver: 22:54:27: This is probably because you're logging in as root.  You
              shouldn't log in as root: you should log in as a normal user,
              and then `su' as needed.  If you insist on logging in as
              root, you will have to turn off X's security features before
              xscreensaver will work.

              Please read the manual and FAQ for more information:

              http://www.jwz.org/xscreensaver/faq.html
              http://www.jwz.org/xscreensaver/man.html
iten55 ()
Ответ на: комментарий от iten55

root@i-netbook:~# xscreensaver -no-splash

1. Зачем ты от root запускаешь? От пользователя запускай!

2. Ты амперсанд забыл указать в конце. Внимательнее смотри, что я написал.

3. Путь к xscreensaver:

$ which xscreensaver

Поэтому выясни путь, впиши с путем. Если его нет в /usr/bin, то он угодил куда-то в нестандартное место. Это очень странно.

Zubok ★★★★★ ()
Последнее исправление: Zubok (всего исправлений: 1)
Ответ на: комментарий от iten55

Это как бы ничего не сказало? Ну ведь ты прочел? :)

xscreensaver: 22:54:27: This is probably because you're logging in as root.  You
              shouldn't log in as root: you should log in as a normal user,
              and then `su' as needed.  If you insist on logging in as
              root, you will have to turn off X's security features before
              xscreensaver will work.
Zubok ★★★★★ ()
Ответ на: комментарий от Zubok

В Кали все делаеться от рута Почему xscreensaver-gl? По поиску нашел папку /usr/share/xscreensaver там лежит файл xscreensaver-deamon может уже его запускать то надо?

iten55 ()
Ответ на: комментарий от iten55

Это как бы ничего не сказало? Ну ведь ты прочел? :)

:-) Я немного знаю инглиш

iten55 ()
Ответ на: комментарий от iten55

ТЫ все сделал, что я написал? Путь выяснил при помощи which?

В Кали все делаеться от рута

Это какой-то смех. Покажи мне, пожалуйста, где такое написано? У тебя есть пользователь или ты одного root только создал?

Zubok ★★★★★ ()
Ответ на: комментарий от Zubok

Путь нашел, указал вот вывод:

root@i-netbook:~# No protocol specified
xscreensaver: 00:53:42: Can't open display: :0.0
xscreensaver: 00:53:42: initial effective uid/gid was root/root (0/0)
xscreensaver: 00:53:42: running as nobody/nogroup (65534/65534)

xscreensaver: 00:53:42: This is probably because you're logging in as root.  You
              shouldn't log in as root: you should log in as a normal user,
              and then `su' as needed.  If you insist on logging in as
              root, you will have to turn off X's security features before
              xscreensaver will work.

              Please read the manual and FAQ for more information:

              http://www.jwz.org/xscreensaver/faq.html
              http://www.jwz.org/xscreensaver/man.html
iten55 ()
Ответ на: комментарий от iten55

И второй

root@i-netbook:~# xscreensaver-demo
xscreensaver-demo: 00:59:36: we're still running as root!  Disaster!

Ну и вываливаеться окошко что типа демон на монитор не запушен.

Мои скромные выводы, он прибивает процесс потому что его запускает рут. Опять же рядом стоит сервер с ЛХДЕ на борту там все ок работает....

iten55 ()
Ответ на: комментарий от iten55

Все, я сдаюсь. Сказал же, не запускай от root. Блин, ты когда логинишься в графическую среду, ты пользователя root указываешь?

Zubok ★★★★★ ()
Ответ на: комментарий от iten55

Вот, сделай по инструкции. Создай нового обычного пользователя, выйди и зайди под ним.

https://help.gnome.org/users/gnome-help/3.3/user-add.html

У тебя по root xscreensaver работать не будет без знания зачем тебе это вообще надо. Поэтому у тебя ничего и не работает.

Путь нашел, указал вот вывод:

Так какой путь? Почему ты заставляешь из тебя вытягивать?

Zubok ★★★★★ ()
Последнее исправление: Zubok (всего исправлений: 1)
Ответ на: комментарий от Zubok

Вот, сделай по инструкции. Создай нового обычного пользователя, выйди и зайди под ним.

Путь как оказалось /usr/bin/xscreensaver. Под обычным юзером все отлично работает. Мне надо чтоб под рутом работало... А можно как то от имени обычного запустить под рутом?

iten55 ()
Ответ на: комментарий от iten55

Объясни, зачем ты работаешь под рутом? И зачем тебе xscreensaver под root? Работать правильно под обычным пользователем. Тебя еще не раз мокнут в это.

Путь как оказалось /usr/bin/xscreensaver.

Так и должно быть.

Под обычным юзером все отлично работает.

Так и надо делать.

Zubok ★★★★★ ()
Ответ на: комментарий от iten55

Хорошо я согласен от рута он не запускаеться но почему под рутом уже от имени др. юзера то не запускаеться?

root@i-netbook:~# sudo -u iten xscreensaver -no-splash

sudo: unable to resolve host i-netbook No protocol specified xscreensaver: 18:17:08: Can't open display: :0.0 xscreensaver: 18:17:08: running as iten/iten (1000/1001)

xscreensaver: 18:17:08: Errors at startup are usually authorization problems. But you're not logging in as root (good!) so something else must be wrong. Did you read the manual and the FAQ?

http://www.jwz.org/xscreensaver/faq.html http://www.jwz.org/xscreensaver/man.html

iten55 ()
Ответ на: комментарий от iten55

Блин, это какой-то трешак. Зачем ты вообще хочешь запускать процесс от root? Объясни мне, зачем?!

И также объясни, ты в графическую среду как логинишься? Как root или как пользователь? Если от root, то зачем? Я тебя уже раз третий спрашиваю. Такое ощущение, что ты сам не можешь объяснить и всячески уходишь от ответа. У меня только такое объяснение.

Zubok ★★★★★ ()
Последнее исправление: Zubok (всего исправлений: 1)
Ответ на: комментарий от Zubok

Да я логинюсь в иксы под рут? Что в этом такого необыкновенно страшного? Для кали линукс это нормально это еше с бэк-трэка пошло... Видишь ли ну удобнее мне без SUDO работать.... Конечно это нарушение порядка и концепции линукс но и Кали не совсем обычный дистрибутив...

iten55 ()
Ответ на: комментарий от iten55

Да я логинюсь в иксы под рут? Что в этом такого необыкновенно страшного? Для кали линукс это нормально

Бугога. Ну, ладно, не буду бороться с заблуждениями. Ты один такой тут, наверное, под root работаешь. :)

Вот: http://www.jwz.org/xscreensaver/faq.html#root-solution

И в ответ на эти строки xscreensaver (ниже) читай еще про pam_xauth (man pam_xauth).

xscreensaver: ...
              If you insist on logging in as
              root, you will have to turn off X's security features before
              xscreensaver will work.

Но помогать тебе в этом деле я уже не буду, потому что это блажь.

Zubok ★★★★★ ()
Ответ на: комментарий от Zubok

>> Бугога. Ну, ладно, не буду бороться с заблуждениями. Ты один такой тут, наверное, под root работаешь. :)

Пожалуйста объясни мне неразумному внятно что плохого в в работе под РУТ? Или все КуЛц линуксоиды работают под юзером боясь повредить свою дражайшую ось? Если есть какие то реальные угрозы работы под рут (не считая невнимательность админа) поясни плиз.... А то получаеться «Бугога. Ну, ладно, не буду бороться с заблуждениями.» а обоснования то нет... ;-)

Кстати может кому пригодиться как запускать процесс xscreensawer под root. Делаем исполняемяй скриптик xsc.sh такого содержания:

#!/bin/sh
xhost local: & xhost
sudo -u iten /usr/bin/xscreensaver -no-splash

Скриприк бросаем в /usr/local/bin/

Забрасываем его в автозапуск (проверено только на гном на кали линукс) с командой /usr/local/bin/sxc.sh и все.

Получаем нормальный скринсэйвер под рутами.

Автору идеи отдельное спасибо! ;-))))

iten55 ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.