LINUX.ORG.RU

Отвалилась спячка

 , ,


0

1

Перестал работать спящий режим в xfce/mint-17. В чем причина пока не установил. RAM-6Gb, SWAP 10Gb, уже и уменьшал, и увеличивал, и правил /etc/initramfs-tools/conf.d/resume и grub.cfg - безрезультатно.

Самое удивительное в первые дни он работал. Подозрения падают на установку пакетов и обновления системы.

Что думаете по этому поводу, у кого-нибудь было такое? Да, и самое главное, как лечить?

★★★★★

Так зима закончилась, кажись осенью опять в спячку впадет

По теме: Это же Ubuntu-based. Там и ядро после обновления может отвалиться...

Nycteas ()
Ответ на: комментарий от naszar

В общем, как-то проблему решил, а именно так:

поставил uswsusp , проверил с ним работает, удалил его, с pm-hibernate попробовал отправить в спячку - то же заработало! Сейчас все так все равно на uswsusp без шифрования, а то уже были проблемы uswsusp -> s2disk -> rsa

Кстати даже спячка в файл запахала с этим s2disk

Идея пока такая, что чего-то не обновилось в плане конфигов и чего-то неПОДсгенирировалось, выяснить конечно хороше бы что было на будущее, вот пока что думаю, вот.

NK ★★★★★ ()
Ответ на: комментарий от naszar

опять отвалилась( но зато по s2disk пашет, если же граф.кнопочками из xfce кликаю на спящий режим - не срабатывает

в /var/log/pm-suspend.log что пишут?

http://pastebin.kde.org/pqhyr5rjp не посмотришь?

NK ★★★★★ ()
Последнее исправление: NK (всего исправлений: 3)
Ответ на: комментарий от NK
Running hook /usr/lib/pm-utils/sleep.d/99local hibernate hibernate:
-1 1
          minimum CPU frequency  -  maximum CPU frequency  -  governor
CPU  0       774000 kHz ( 42 %)  -    1801000 kHz (100 %)  -  performance
CPU  1       774000 kHz ( 42 %)  -    1801000 kHz (100 %)  -  performance
CPU  2       774000 kHz ( 42 %)  -    1801000 kHz (100 %)  -  performance
CPU  3       774000 kHz ( 42 %)  -    1801000 kHz (100 %)  -  performance
mkdir: cannot create directory '/tmp/apt-cache-archives': File exists
/usr/lib/pm-utils/sleep.d/99local hibernate hibernate: Returned exit code 1.
 
Mon Jul  7 05:37:53 MSK 2014: Inhibit found, will not perform hibernate

Похоже что это /usr/lib/pm-utils/sleep.d/99local не дает системе уснуть. А что он хочет делать, что там?

naszar ()
Ответ на: комментарий от naszar

/usr/lib/pm-utils/sleep.d/99local

dell ~ # ls -l /usr/lib/pm-utils/sleep.d/99local 
lrwxrwxrwx 1 root root 13 июня  26 22:53 /usr/lib/pm-utils/sleep.d/99local -> /etc/rc.local
dell ~ # cat /etc/rc.local 
#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

#exit 0
# DELL fan
i8kfan - 1

# i3
#cpufreq-set -r -g performance
for i in 0 1 2 3; do cpufreq-set -c $i -g performance; done
cpufreq-info -o

# APTCACHE 
mkdir /tmp/apt-cache-archives
NK ★★★★★ ()
Ответ на: комментарий от naszar

а вот вроде получилось, спасибо, mkdir закомментил - запахало (наверно условие добавлю), просто знаешь странно, по команде пашет в строке s2disk, по кнопке физической, так и графической не срабатывает

NK ★★★★★ ()
Последнее исправление: NK (всего исправлений: 1)
Ответ на: комментарий от NK

Лучше наверное не комментировать, а сделать:

[ ! -d "/tmp/apt-cache-archives" ] && mkdir /tmp/apt-cache-archives
Или симлинк убрать, не похоже что /etc/rc.local делает что-то сверхнужное для спячки. Если с ходу, то похоже бага.. ибо судя по

This script is executed at the end of each multiuser runlevel

директорий создается всегда, а спать не пойдет никогда. По хорошему бы на соответствующий багтрекер нажаловаться.

по команде пашет в строке s2disk, по кнопке физической, так и графической не срабатывает

Я если честно s2disk не смотрел.. у тебя поломато pm-utils, а точнее хук из его кухни, а сам он набор скриптов на баше, которые в самом конце дергают ядро за ручку в /sys/power.

naszar ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.