LINUX.ORG.RU

GMA3600 Xorg Driver

 , , ,


0

2

Собираю LFS. При сборке ядра 3.10.10 поставил checkbox на GMA3600/GMA3650 Experimental support [NEW], последний раз собирал ядро 3.2.0, там этого не было. В консоли все разрешение нормальное (а не vga, как при использовании linux 3.2.0), даже внешний монитор сам подхватился при подключении. Вопрос такой: где собственно брать драйверы для Xorg? Нужно просто скомпилировать fbdev или modesetting или нужно собрать тарбалл интелловских драйверов или поставить бинарники отсюда https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=21938?


или нужно собрать тарбалл интелловских драйверов

Они отродясь эту шнягу не поддерживали, ибо PowerVR.

или поставить бинарники отсюда

Вестимо.

redgremlin ★★★★★
()

бинарники отсюда

отсюда не нужны, т.к. работают только на определенных версиях xorg, mesa и kernel (собрано только под meego)

Нормальная работа фрейбуфера с ядра >3.8 и >xorg-x11-drv-intel-2.21 (без 3D, ускорения видео и т.п.).

arson ★★★★★
()

Вам, собственно правильно отвелит arson. Нормальных драйверов под этот «видео адаптер» под Linux нет. И строго говоря это даже не Intel, т.к. разработкой этого адаптера занималась сторонняя фирма, почитайте в Internet.

Собственно, всё, что вы можете сделать, это включить в ядре поддержку CONFIG_GMA3600 и установить в качестве видео драйвера xf86video-modesetting.

У вас будет только некоторое 2D ускорение и никакого 3D. Ну и проблемы с прочими видео разъёмами, HDMI, S-VIDEO и прочим.

Вообще, лучше было перед покупкой оборудования почитать в Internet про поддержку этого видео адаптера в Linux, в общем в момент объявления архитектуры Cedar Trail было заявлено, что первое время будет обеспечена первоочередная поддержка платформы Windows, а поддержки Linux пока не будет, о сроках и объёмах обеспечения поддержки Linux не было ничего сказано.

Так что вот те бинарные драйверы это всё, что пока есть и, скорее всего, больше ничего и не будет, за исключением того, что я вам написал выше. К тому же, как уже сказали, они действительно поддерживают только определённую версию xorg-server`а, а модуль собирается только на определённом ядре. Нет, в Internet где-то есть исходники, они были открыты и их можно было скачать даже с сайта Intel, но сейчас их не особо найдёшь, а если у вас всё же возникнет желание их использовать в современной системе, то вам придётся их портировать под текущие версии ядра и xorg-server`а.

Так что решайте сами, стоит ли вообще использовать Linux на такой платформе.

kostik87 ★★★★★
()
Последнее исправление: kostik87 (всего исправлений: 1)
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.