LINUX.ORG.RU
ФорумAdmin

Откат до gtk 3.4

 ,


0

1

Добрый день! Сегодня меня черт дергнул обновить систему, обновил гтк с 3.4 до 3.8. Теперь половину гткшных программ не запускается, вылетает с сообщением об ошибке сегментирования.

dima@lmde:~$ shotwell
(shotwell:26658): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:198:20: Not using units is deprecated. Assuming 'px'.
(shotwell:26658): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:199:20: Not using units is deprecated. Assuming 'px'.
(shotwell:26658): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:229:20: Not using units is deprecated. Assuming 'px'.
(shotwell:26658): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:230:20: Not using units is deprecated. Assuming 'px'.
(shotwell:26658): Gtk-WARNING **: Theme parsing error: button.css:164:20: Not using units is deprecated. Assuming 'px'.
(shotwell:26658): Gtk-WARNING **: Theme parsing error: button.css:165:20: Not using units is deprecated. Assuming 'px'.
(shotwell:26658): Gtk-WARNING **: Theme parsing error: content-view.css:45:20: Not using units is deprecated. Assuming 'px'.
(shotwell:26658): Gtk-WARNING **: Theme parsing error: content-view.css:51:20: Not using units is deprecated. Assuming 'px'.
(shotwell:26658): Gtk-WARNING **: Theme directory actions48 of theme hi-lights-icons has no size field
(shotwell:26658): Gtk-WARNING **: Theme directory actions48 of theme hi-lights-icons has no size field
(shotwell:26658): Gtk-WARNING **: Theme directory actions48 of theme hi-lights-icons has no size field
(shotwell:26658): Gtk-WARNING **: Theme directory actions48 of theme hi-lights-icons has no size field
(shotwell:26658): Gtk-WARNING **: Theme directory actions48 of theme hi-lights-icons has no size field
(shotwell:26658): Gtk-WARNING **: Theme directory actions48 of theme hi-lights-icons has no size field
(shotwell:26658): Gtk-WARNING **: Theme directory actions48 of theme hi-lights-icons has no size field
(shotwell:26658): Gtk-WARNING **: Theme directory actions48 of theme hi-lights-icons has no size field
(shotwell:26658): Gtk-WARNING **: Theme directory actions48 of theme hi-lights-icons has no size field
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
(shotwell:26658): Gtk-WARNING **: Style property "border-top-left-radius" is not gettable
(shotwell:26658): GLib-GObject-WARNING **: /build/glib2.0-EIRQgp/glib2.0-2.36.3/./gobject/gtype.c:4239: type id `0' is invalid
(shotwell:26658): GLib-GObject-WARNING **: can't peek value table for type `<invalid>' which is not currently referenced
Ошибка сегментирования

Подскажите как откат сделать, либо раскурить не работающие программы. Пробовал через purgе, не помогло. Система (ex Mint Debian) Debian 7 Под root`om работает нормально

Подскажите как откат сделать, либо раскурить не работающие программы.

У тебя там ясно написано: ошибка парсинга темы. Обнови/выкинь/пропатчь её

derlafff ★★★★★ ()
Последнее исправление: derlafff (всего исправлений: 2)

вот вам и стабильный дебиан :D как откатить не знаю, но предлагаю поставить убунту 12.04. тут все еще 3.4 (тфу-тфу).

waker ★★★★★ ()
Ответ на: комментарий от waker

вот вам и стабильный дебиан

В стабильном Debian нет GTK 3.8. Вообще.

предлагаю поставить убунту 12.04. тут все еще 3.4 (тфу-тфу).

Я вот только восстановил работоспособность системы после обновления до xserver-xorg-lts-raring (откатом до версий *-quantal) :/ Вот вам и стабильный LTS.

Gotf ★★★ ()
Ответ на: комментарий от derlafff

У тебя там ясно написано: ошибка парсинга темы. Обнови/выкинь/пропатчь её

эпт. помогло о_0

Большое спасибо!

вот вам и стабильный дебиан :D как откатить не знаю, но предлагаю поставить убунту 12.04. тут все еще 3.4 (тфу-тфу).

Не нравиться мне ваша убунта. У меня компутер старенький и дебиан в разы быстрей работает ;)

Lanavidat ()
Ответ на: комментарий от Gotf

понятно. хорошо, что это по-умолчанию выключено в 12.04.0. и спасибо за инфу, кстати.

waker ★★★★★ ()

В той теме негодовали, зачем я написал, а уже 2е наступили на те же грабли, продолжаем подсчет...

Lordwind ★★★★★ ()

Кстати unico от 12.12.12 из бубунты уже с фиксом, можешь дернуть.

Lordwind ★★★★★ ()

Это гытыка, детка, здесь внезапно покривившаяся по желанию левой пятки разработчиков css'ка запросто валит любую софтину.

leave ★★★★★ ()
22 февраля 2014 г.

Твоя тема gtk3 не портирована на версию 3.8. Обнови, может есть порт. В противном случае, ищи новую, которая поддерживает gtk 3.8, или откатывайся на старый gtk 3.4 со stable, а также окатывай весь сопутствующий софт.

Я предпочел последний вариант. Очень люблю flat studio ^_^

permafrost ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.