LINUX.ORG.RU
решено ФорумAdmin

Как поставить node 10 на тестинг?

 , ,


0

1

Точнее, ноде то поставился в общем-то (хотя bin/node не появился и после node-legacy). В экспериментале как раз есть 10, проблема с npm.

$ ie npm
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 npm : Зависит: node-ansi но он не может быть установлен
       Зависит: node-archy но он не может быть установлен
       Зависит: node-block-stream но он не может быть установлен
       Зависит: node-fstream (>= 0.1.22) но он не будет установлен
       Зависит: node-fstream-ignore но он не может быть установлен
       Зависит: node-glob (>= 3.1.21) но он не может быть установлен
       Зависит: node-graceful-fs (>= 1.2.0) но он не может быть установлен
       Зависит: node-inherits но он не может быть установлен
       Зависит: node-ini (>= 1.1.0) но он не может быть установлен
       Зависит: node-lockfile но он не может быть установлен
       Зависит: node-minimatch (>= 0.2.11) но он не будет установлен
       Зависит: node-gyp (>= 0.9.3) но он не будет установлен
       Зависит: node-npmlog но он не может быть установлен
       Зависит: node-once но он не может быть установлен
       Зависит: node-osenv но он не может быть установлен
       Зависит: node-read но он не может быть установлен
       Зависит: node-read-package-json но он не может быть установлен
       Зависит: node-request но он не может быть установлен
       Зависит: node-retry но он не может быть установлен
       Зависит: node-slide но он не может быть установлен
       Зависит: node-tar (>= 0.1.17) но он не будет установлен
       Зависит: node-which но он не может быть установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

Такая вот беда, где пакеты? В тестинге собственно так-же.

сорцес.лист уже несколько раз чинил, щас там только так:

deb http://http.debian.net/debian testing main contrib non-free
deb http://http.debian.net/debian experimental main contrib non-free

Родной список реп Джесси нигде найти не могу.

Руками ставить не хочу. Откуда его нормально поставить и как оно у меня стояло раньше на визи?

checkinstall. в люьом случае тебе, похоже, придутся ручками разгребать.

rikardoac ()

Ветку unstable добавить, тогда всё разрешится, иначе вручную

Excavator ()
Ответ на: комментарий от Excavator

О, правда оттуда нпм поставился, спасибо. Жуть, по всем веткам пришлось собирать.

С node-legacy правда всё равно ерудна какая-то, но руками симлинк сделал.

Kalashnikov ★★★ ()

Советую использовать вот это https://github.com/creationix/nvm/ и ставить локально. Даже на продакшене.

Потом по инструкции прописываете скрипт в bash, и

nvm install 0.10
nvm alias default 0.10
Vit ★★★★★ ()
Ответ на: комментарий от Vit

Вторую строчку можно пропустить, если не собираетесь использовать несколько разных версий (0.8.хх) - будет выбирать всегда самую последнюю.

Кнопелять ничего не надо, оно готовые блобы с нодовского сайта качает.

Vit ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.