LINUX.ORG.RU
решено ФорумAdmin

BigBlueButton переход на HTML5

 ,


0

1

Сейчас пытаюсь перевести BBB на html5.

При установке выдает такую ошибку:

Setting up node-retry (0.6.0-1) ...
Setting up node-sha (1.2.3-1) ...
Setting up node-slide (1.1.4-1) ...
Setting up npm (3.5.2-0ubuntu4) ...
Setting up bbb-webrtc-sfu (1:2.0.0-66) ...

> bufferutil@1.2.1 install /usr/local/bigbluebutton/bbb-webrtc-sfu/node_modules/                                                                                                                     bufferutil
> node-gyp rebuild

/bin/sh: 1: node: not found
gyp: Call to 'node -e "require('nan')"' returned exit status 127 while in bindin                                                                                                                     g.gyp. while trying to load binding.gyp
gyp ERR! configure error
gyp ERR! stack Error: `gyp` failed with exit code: 1
gyp ERR! stack     at ChildProcess.onCpExit (/usr/share/node-gyp/lib/configure.j                                                                                                                     s:354:16)
gyp ERR! stack     at emitTwo (events.js:87:13)
gyp ERR! stack     at ChildProcess.emit (events.js:172:7)
gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_proces                                                                                                                     s.js:200:12)
gyp ERR! System Linux 4.15.0-33-generic
gyp ERR! command "/usr/bin/nodejs" "/usr/bin/node-gyp" "rebuild"
gyp ERR! cwd /usr/local/bigbluebutton/bbb-webrtc-sfu/node_modules/bufferutil
gyp ERR! node -v v4.2.6
gyp ERR! node-gyp -v v3.0.3
gyp ERR! not ok

npm ERR! Linux 4.15.0-33-generic
npm ERR! argv "/usr/bin/nodejs" "/usr/bin/npm" "rebuild"
npm ERR! node v4.2.6
npm ERR! npm  v3.5.2
npm ERR! code ELIFECYCLE
npm ERR! bufferutil@1.2.1 install: `node-gyp rebuild`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the bufferutil@1.2.1 install script 'node-gyp rebuild'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the bufferutil package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node-gyp rebuild
npm ERR! You can get information on how to open an issue for this project with:
npm ERR!     npm bugs bufferutil
npm ERR! Or if that isn't available, you can get their info via:
npm ERR!     npm owner ls bufferutil
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR!     /usr/local/bigbluebutton/bbb-webrtc-sfu/npm-debug.log
Reloading nginx.service using systemd
Adding bbb-webrtc-sfu.service to autostart using systemd
Created symlink from /etc/systemd/system/multi-user.target.wants/bbb-webrtc-sfu.                                                                                                                     service to /usr/lib/systemd/system/bbb-webrtc-sfu.service.
Adding kurento-media-server.service to autostart using systemd
Synchronizing state of kurento-media-server.service with SysV init with /lib/sys                                                                                                                     temd/systemd-sysv-install...
Executing /lib/systemd/systemd-sysv-install enable kurento-media-server
Setting up bbb-html5 (1:2.0.0-453) ...
Installing meteor packages (this may take a moment)
Updating Node packages for bbb-html5 (this may take a moment)

> fibers@2.0.0 install /usr/share/meteor/bundle/programs/server/node_modules/fibers
> node build.js || nodejs build.js

sh: 1: node: not found
/usr/bin/env: ‘node’: No such file or directory
node-gyp exited with code: 127
Please make sure you are using a supported platform and node version. If you
would like to compile fibers on this machine please make sure you have setup your
build environment--
Windows + OS X instructions here: https://github.com/nodejs/node-gyp
Ubuntu users please run: `sudo apt-get install g++ build-essential`
Alpine users please run: `sudo apk add python make g++`
meteor-dev-bundle@0.0.0 /usr/share/meteor/bundle/programs/server
├─┬ chalk@0.5.1
│ ├── ansi-styles@1.1.0
│ ├── escape-string-regexp@1.0.5
│ ├─┬ has-ansi@0.1.0
│ │ └── ansi-regex@0.2.1
│ ├── strip-ansi@0.3.0
│ └── supports-color@0.2.0
├── meteor-promise@0.8.6
├─┬ multipipe@1.0.2
│ ├─┬ duplexer2@0.1.4
│ │ └─┬ readable-stream@2.3.3
│ │   ├── core-util-is@1.0.2
│ │   ├── isarray@1.0.0
│ │   ├── process-nextick-args@1.0.7
│ │   ├── safe-buffer@5.1.1
│ │   ├── string_decoder@1.0.3
│ │   └── util-deprecate@1.0.2
│ └── object-assign@4.1.1
├─┬ node-gyp@3.6.2
│ ├─┬ fstream@1.0.11
│ │ └── inherits@2.0.3
│ ├─┬ glob@7.1.3
│ │ ├── fs.realpath@1.0.0
│ │ ├─┬ inflight@1.0.6
│ │ │ └── wrappy@1.0.2
│ │ ├── once@1.4.0
│ │ └── path-is-absolute@1.0.1
│ ├── graceful-fs@4.1.11
│ ├─┬ minimatch@3.0.4
│ │ └─┬ brace-expansion@1.1.11
│ │   ├── balanced-match@1.0.0
│ │   └── concat-map@0.0.1
│ ├─┬ mkdirp@0.5.1
│ │ └── minimist@0.0.8
│ ├─┬ nopt@3.0.6
│ │ └── abbrev@1.1.1
│ ├─┬ npmlog@4.1.2
│ │ ├─┬ are-we-there-yet@1.1.5
│ │ │ └── delegates@1.0.0
│ │ ├── console-control-strings@1.1.0
│ │ ├─┬ gauge@2.7.4
│ │ │ ├── aproba@1.2.0
│ │ │ ├── has-unicode@2.0.1
│ │ │ ├── signal-exit@3.0.2
│ │ │ ├─┬ string-width@1.0.2
│ │ │ │ ├── code-point-at@1.1.0
│ │ │ │ ├─┬ is-fullwidth-code-point@1.0.0
│ │ │ │ │ └── number-is-nan@1.0.1
│ │ │ │ └─┬ strip-ansi@3.0.1
│ │ │ │   └── ansi-regex@2.1.1
│ │ │ ├─┬ strip-ansi@3.0.1
│ │ │ │ └── ansi-regex@2.1.1
│ │ │ └── wide-align@1.1.3
│ │ └── set-blocking@2.0.0
│ ├─┬ osenv@0.1.5
│ │ ├── os-homedir@1.0.2
│ │ └── os-tmpdir@1.0.2
│ ├─┬ request@2.88.0
│ │ ├── aws-sign2@0.7.0
│ │ ├── aws4@1.8.0
│ │ ├── caseless@0.12.0
│ │ ├─┬ combined-stream@1.0.6
│ │ │ └── delayed-stream@1.0.0
│ │ ├── extend@3.0.2
│ │ ├── forever-agent@0.6.1
│ │ ├─┬ form-data@2.3.2
│ │ │ └── asynckit@0.4.0
│ │ ├─┬ har-validator@5.1.0
│ │ │ ├─┬ ajv@5.5.2
│ │ │ │ ├── co@4.6.0
│ │ │ │ ├── fast-deep-equal@1.1.0
│ │ │ │ ├── fast-json-stable-stringify@2.0.0
│ │ │ │ └── json-schema-traverse@0.3.1
│ │ │ └── har-schema@2.0.0
│ │ ├─┬ http-signature@1.2.0
│ │ │ ├── assert-plus@1.0.0
│ │ │ ├─┬ jsprim@1.4.1
│ │ │ │ ├── extsprintf@1.3.0
│ │ │ │ ├── json-schema@0.2.3
│ │ │ │ └── verror@1.10.0
│ │ │ └─┬ sshpk@1.14.2
│ │ │   ├── asn1@0.2.4
│ │ │   ├── bcrypt-pbkdf@1.0.2
│ │ │   ├── dashdash@1.14.1
│ │ │   ├── ecc-jsbn@0.1.2
│ │ │   ├── getpass@0.1.7
│ │ │   ├── jsbn@0.1.1
│ │ │   ├── safer-buffer@2.1.2
│ │ │   └── tweetnacl@0.14.5
│ │ ├── is-typedarray@1.0.0
│ │ ├── isstream@0.1.2
│ │ ├── json-stringify-safe@5.0.1
│ │ ├─┬ mime-types@2.1.20
│ │ │ └── mime-db@1.36.0
│ │ ├── oauth-sign@0.9.0
│ │ ├── performance-now@2.1.0
│ │ ├── qs@6.5.2
│ │ ├── safe-buffer@5.1.2
│ │ ├─┬ tough-cookie@2.4.3
│ │ │ ├── psl@1.1.29
│ │ │ └── punycode@1.4.1
│ │ ├── tunnel-agent@0.6.0
│ │ └── uuid@3.3.2
│ ├── rimraf@2.6.2
│ ├── semver@5.3.0
│ ├─┬ tar@2.2.1
│ │ └── block-stream@0.0.9
│ └─┬ which@1.3.1
│   └── isexe@2.0.0
├─┬ node-pre-gyp@0.6.36
│ ├── nopt@4.0.1
│ ├─┬ rc@1.2.8
│ │ ├── deep-extend@0.6.0
│ │ ├── ini@1.3.5
│ │ ├── minimist@1.2.0
│ │ └── strip-json-comments@2.0.1
│ └─┬ tar-pack@3.4.1
│   ├─┬ debug@2.6.9
│   │ └── ms@2.0.0
│   ├── fstream-ignore@1.0.5
│   └── uid-number@0.0.6
├─┬ promise@8.0.1
│ └── asap@2.0.6
├── semver@5.4.1
├─┬ source-map-support@0.3.2
│ └─┬ source-map@0.1.32
│   └── amdefine@1.0.1
├─┬ split2@2.1.1
│ └─┬ through2@2.0.3
│   └── xtend@4.0.1
└── underscore@1.5.2

npm WARN meteor-dev-bundle@0.0.0 No description
npm WARN meteor-dev-bundle@0.0.0 No repository field.
npm WARN meteor-dev-bundle@0.0.0 No license field.
npm ERR! Linux 4.15.0-33-generic
npm ERR! argv "/usr/bin/nodejs" "/usr/bin/npm" "install"
npm ERR! node v4.2.6
npm ERR! npm  v3.5.2
npm ERR! file sh
npm ERR! code ELIFECYCLE
npm ERR! errno ENOENT
npm ERR! syscall spawn

npm ERR! fibers@2.0.0 install: `node build.js || nodejs build.js`
npm ERR! spawn ENOENT
npm ERR!
npm ERR! Failed at the fibers@2.0.0 install script 'node build.js || nodejs build.js'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the fibers package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node build.js || nodejs build.js
npm ERR! You can get information on how to open an issue for this project with:
npm ERR!     npm bugs fibers
npm ERR! Or if that isn't available, you can get their info via:
npm ERR!     npm owner ls fibers
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR!     /usr/share/meteor/bundle/programs/server/npm-debug.log
dpkg: error processing package bbb-html5 (--configure):
 subprocess installed post-installation script returned error exit status 1
Processing triggers for libc-bin (2.23-0ubuntu10) ...
Processing triggers for systemd (229-4ubuntu21.4) ...
Processing triggers for ureadahead (0.100.0-19) ...
Errors were encountered while processing:
 bbb-html5
E: Sub-process /usr/bin/dpkg returned an error code (1)

Инструкция тут: http://docs.bigbluebutton.org/html/html5-install.html#1-install-mongdb-and-no...

Не существует никакого HTML5. Ты пытаешься перевести что-то, на несуществующее нечто.

anonymous ()

Не верно прочитал документацию. Начал устанавливать этот пакет не установив компоненты для конфигурирования.

Shulman ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.