LINUX.ORG.RU
решено ФорумAdmin

Permission denied (publickey)

 


0

1
$ ssh -p22054 -i ~/test/bridget.pub user@remote_host
Enter passphrase for key '/home/alex/test/bridget.pub': 
Permission denied (publickey).

Для ключа пассфразы не устанавливал.

$ ls -la bridget.pub 
-rw------- 1 alex alex 740 Июн  3 12:37 bridget.pub
В чем дело?


Как это понимать?
Вы приходите сюда, постите вопрос, без всякой даже попытки предоставить сопутствующую информацию.
Это что, отделение саппорта?
Тут люди оказывают друг другу помощь, а не служат.
Переделывайте и дополняйте пост.

Spirit_of_Stallman ★★★ ()
Ответ на: комментарий от Spirit_of_Stallman

Что еще нужно из информации? Я не могу понять почему ключ запрашивает пассфразу, если ее там нет изначально.

Вот еще

$ ssh -v -p22054 -i ~/test/bridget.pub user@remote_host
OpenSSH_6.1p1 Debian-4, OpenSSL 1.0.1c 10 May 2012
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Connecting to remote_host [IP] port 22054.
debug1: Connection established.
debug1: identity file /home/alex/test/bridget.pub type 1
debug1: Checking blacklist file /usr/share/ssh/blacklist.RSA-4096
debug1: Checking blacklist file /etc/ssh/blacklist.RSA-4096
debug1: identity file /home/alex/test/bridget.pub-cert type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_6.0p1 Debian-4
debug1: match: OpenSSH_6.0p1 Debian-4 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_6.1p1 Debian-4
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-ctr hmac-md5 none
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: sending SSH2_MSG_KEX_ECDH_INIT
debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
debug1: Server host key: ECDSA bd:c7:e4:a8:a2:4d:df:5d:d2:93:e7:52:73:37:a0:7s
debug1: Host '[remote_host]:22054' is known and matches the ECDSA host key.
debug1: Found key in /home/alex/.ssh/known_hosts:14
debug1: ssh_ecdsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: Roaming not allowed by server
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey
debug1: Next authentication method: publickey
debug1: Offering RSA public key: /home/alex/test/bridget.pub
debug1: Server accepts key: pkalg ssh-rsa blen 535
debug1: key_parse_private_pem: PEM_read_PrivateKey failed
debug1: read PEM private key done: type <unknown>
Enter passphrase for key '/home/alex/test/bridget.pub': 
debug1: No more authentication methods to try.
Permission denied (publickey).
$ cat /etc/ssh/sshd_config 
Port 22
Protocol 2
HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_dsa_key
HostKey /etc/ssh/ssh_host_ecdsa_key
UsePrivilegeSeparation yes
KeyRegenerationInterval 3600
ServerKeyBits 768
SyslogFacility AUTH
LogLevel INFO

LoginGraceTime 120
PermitRootLogin no
StrictModes yes

RSAAuthentication yes
PubkeyAuthentication yes
#AuthorizedKeysFile     %h/.ssh/authorized_keys

# Don't read the user's ~/.rhosts and ~/.shosts files
IgnoreRhosts yes
# For this to work you will also need host keys in /etc/ssh_known_hosts
RhostsRSAAuthentication no
# similar for protocol version 2
HostbasedAuthentication no
# Uncomment if you don't trust ~/.ssh/known_hosts for RhostsRSAAuthentication
#IgnoreUserKnownHosts yes

# To enable empty passwords, change to yes (NOT RECOMMENDED)
PermitEmptyPasswords no

# Change to yes to enable challenge-response passwords (beware issues with
# some PAM modules and threads)
ChallengeResponseAuthentication no

# Change to no to disable tunnelled clear text passwords
#PasswordAuthentication yes

X11Forwarding yes
X11DisplayOffset 10
PrintMotd no
PrintLastLog yes
TCPKeepAlive yes
#UseLogin no

#MaxStartups 10:30:60
#Banner /etc/issue.net

# Allow client to pass locale environment variables
AcceptEnv LANG LC_*

# PAM authentication, then enable this but set PasswordAuthentication
# and ChallengeResponseAuthentication to 'no'.
UsePAM yes

Nokman ()
Ответ на: комментарий от Nokman

sshd_config
Port 22

ssh -v -p22054
-p22054

Это точно тожественные конфиг, и сервер, куда вы коннектитесь?

Spirit_of_Stallman ★★★ ()
Ответ на: комментарий от Nokman

Что еще нужно из информации? Я не могу понять почему ключ запрашивает пассфразу, если ее там нет изначально.

Да потому что для авторизации нужен privat ключ, а вы пытаетесь использовать public.

ventilator ★★★ ()
Ответ на: комментарий от Spirit_of_Stallman

Нет, не идентичен. Сейчас покажу конфиг удаленного сервера.

$ cat /etc/ssh/sshd_config 
Port 22054
Protocol 2
HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_dsa_key
HostKey /etc/ssh/ssh_host_ecdsa_key
UsePrivilegeSeparation yes
KeyRegenerationInterval 3600
ServerKeyBits 768
# Logging
SyslogFacility AUTH
LogLevel INFO

# Authentication:
LoginGraceTime 120
PermitRootLogin no
StrictModes yes

RSAAuthentication yes
PubkeyAuthentication yes
AuthorizedKeysFile      %h/.ssh/authorized_keys

IgnoreRhosts yes
# For this to work you will also need host keys in /etc/ssh_known_hosts
RhostsRSAAuthentication no
# similar for protocol version 2
HostbasedAuthentication no
# Uncomment if you don't trust ~/.ssh/known_hosts for RhostsRSAAuthentication
#IgnoreUserKnownHosts yes

# To enable empty passwords, change to yes (NOT RECOMMENDED)
PermitEmptyPasswords no

# Change to yes to enable challenge-response passwords (beware issues with
# some PAM modules and threads)
ChallengeResponseAuthentication no

# Change to no to disable tunnelled clear text passwords
PasswordAuthentication no

X11Forwarding yes
X11DisplayOffset 10
PrintMotd no
PrintLastLog yes
TCPKeepAlive yes

# Allow client to pass locale environment variables
AcceptEnv LANG LC_*

# PAM authentication, then enable this but set PasswordAuthentication
# and ChallengeResponseAuthentication to 'no'.
UsePAM yes

Nokman ()
Ответ на: комментарий от Spirit_of_Stallman

Тоесть? Он идентичен удалённому? Или это и есть мастер, куда вы стучитесь?

А к чему тут вообще sshd_config локалхоста? На локалхосте его вообще может и не быть.

ventilator ★★★ ()
Ответ на: комментарий от ventilator

А к чему тут вообще sshd_config локалхоста?

Ну, когда я вижу sshd_config, то предполагаю что это конфиг сервера, куда идёт коннект, вестимо :)

Spirit_of_Stallman ★★★ ()
Ответ на: комментарий от ventilator
$ ssh-keygen -t rsa
............................
Enter passphrase (empty for no passphrase): 
Enter same passphrase again:
..................

Ключ работает из ~/.ssh/ без всяких пассфраз. Если скопировать ключ в другой каталог (сохраняя те же права естественно), то все так как описал выше. Ведь с помощью ключа -i ключ должен работать независимо от места хранения?

Nokman ()
Ответ на: комментарий от ventilator

И вообще, почему все должно работать с приватным ключом, если на сервер в authorized_keys занесен (ssh-copy-id) именно публичный и он проверяется насколько я понимаю?

Nokman ()
Ответ на: комментарий от Nokman

На удаленном хосте лежит публичный, на локальном - приватный, соответствующий этому публичному. Почитайте-ка про несимметричное шифрование.

leave ★★★★★ ()
Ответ на: комментарий от Nokman

именно публичный и он проверяется насколько я понимаю?

Бьюсь под столом в истерике. Ага, ты авторизуешься по тому же самому ключу, который можешь светить везде.

И вообще, почему все должно работать с приватным ключом

Потому что *тадам* генерируется ПАРА ключей, один из которых приватный (читай - является твоим пропуском), а второй - публичный (фейс-контроль, который без пропуска пнёт тебя нахрен). Естественно, что если ты будешь использовать публичный, то он фиг когда валидацию пройдёт.

Valkeru ★★★★ ()

о!, если тебе доступен sshd_config сервера, тогда смотри логи secure.log, messages. или повышай LogLevel в sshd_config
вангую на права на %h/.ssh/authorized_keys, или слишком широкие права на ~/ ~/.ssh/

bl ★★★ ()
Ответ на: комментарий от Valkeru

Разобрался. Действительно работает именно с приватным и я прилично ошибался. Закинул его в тестовый каталог, сделал права 644 и все заработало. Всем спасибо.

Nokman ()
Ответ на: комментарий от Nokman

Кстати, что бы не писать каждый раз в запуск путь к ключу, забей этот путь в /etc/ssh/ssh_config в стороку IdentityFile, выглядит это примерно так:

IdentityFile /etc/ssh/my_key
И ещё советую почитать про ~/.ssh/config, он тоже сильно облегчает жизнь. Пример:
valkeru@valkeru-desktop:/etc/ssh$ cat ~/.ssh/config 
Host=mom
Hostname=10.3.41.24
Port=13665
User=valkeru

Valkeru ★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.